10-30-08 02:55 PM
28 12
tools
  1. conmetal's Avatar
    Based on the responses here, I need to give Amaze another shot. I haven't tried the latest version, but the last time I tried it was amazingly slow. As a result I've been happily using Nav4All for about 8 months now. I've only had a few hiccups with it and it was due to the GPS loosing the signal and turn by turn had me riding in circles.
    10-30-08 11:47 AM
  2. BruceRTL's Avatar
    Based on the responses here, I need to give Amaze another shot. I haven't tried the latest version, but the last time I tried it was amazingly slow. As a result I've been happily using Nav4All for about 8 months now. I've only had a few hiccups with it and it was due to the GPS loosing the signal and turn by turn had me riding in circles.
    That's been my experience as well but like you, after reading all of these posts, I may give it another try.
    10-30-08 02:32 PM
  3. PvT's Avatar
    OK then the power of Crackberry... Sounds like it's worth giving it a try. Using Nav4all currently and will give AmAzeGPS a try. Downloading now....

    Note from their site:
    Download via your phone browser
    Just type the following WAP address in your mobile phone browser: wap.amazegps.com and follow the downloading instructions on the screen. Once the download is completed, exit your mobile browser and open the application (typically the application is saved under the ‘applications’ menu on your phone).

    Note for Blackberry users: Please write down the user name and password submitted to you on this WAP site. You’ll be asked to insert them on the first time you open the application (required only once).
    When I choose Download now... it reads:

    "Download amAze for Blackberry (Bold) [jad] (665KB)"

    also:

    gives you a link to:

    "Download an Enterprise Server (BES)version of amAze for Blackberry (Bold) [jad] (665KB)"

    They see what's nippin at their site. I like the Blackberry friendly welcome wagon.
    Last edited by PvT; 10-30-08 at 03:02 PM. Reason: Bold'ing text... why? Because I have a Bold ;~)
    10-30-08 02:55 PM
28 12
LINK TO POST COPIED TO CLIPBOARD
";