Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Dazlr Boy's Avatar
    CrackBerry Abuser

    Posts
    396 Posts
    Thread AuthorThread Author   #1  

    Default My z10 is not charging?

    whenever I attach charge to my z10, it shows only 2 second charging, ,then again becomes red with a "!" inside ...
    What it means?

    My z10 is not charging?-img_20140610_182918.png

    @dazlr
  2. masterful's Avatar
    CrackBerry Addict

    Posts
    722 Posts
    #2  

    Default

    Try another battery or it could be the charger

    ? Slicing using my ?
  3. Dazlr Boy's Avatar
    CrackBerry Abuser

    Posts
    396 Posts
    Thread AuthorThread Author   #3  

    Default

    But, ,,it is one month old only.......sometimes it is charging and sometimes, not
    Is there any relation with temperature ,,,because when the outside temperature is high,,,it doesn't charge but when I put in ac condition,,,it starts charging.....

    @dazlr
  4. Man_apart's Avatar
    Banned

    Posts
    299 Posts
    Global Posts
    300 Global Posts
    #4  

    Default

    Try charging it with the phone "off". hold the power button for 3 seconds to turn off ur device. Charge it then.

    From my ? phone
  5. Dazlr Boy's Avatar
    CrackBerry Abuser

    Posts
    396 Posts
    Thread AuthorThread Author   #5  

    Default

    Its shows charging but after an hour, ,when I switched on and checked it ,,,nothing changed....
    I think it doesn't charge in high temperature case but in cold conditions, ,it works

    @dazlr
  6. green_ember's Avatar
    CrackBerry Abuser

    Posts
    287 Posts
    #6  

    Default

    With the charger connected, try holding down the unlock button on top until you see a charging screen with a picture of a battery or a blank screen and the light blinking with the device off (will vary based on which os version you have)
  7. hakimmmmm's Avatar
    CrackBerry Addict

    Posts
    546 Posts
    Global Posts
    811 Global Posts
    #7  

    Default

    I had some what same problem n I had to change the cord n used my playbooks charges n now it charges properly and charges 50 percent faster. I know it's cuz of the charger

    Posted using my Q10 with double type keyboard issue
  8. Dazlr Boy's Avatar
    CrackBerry Abuser

    Posts
    396 Posts
    Thread AuthorThread Author   #8  

    Default

    Z10STL100-1/10.2.1.3175, ,,,,,is there any effect on using another brand adapter, ,,because after 10 days of buying z10 , , its adapter got boomed,,,due to high power supply and since that I m using Samsung adapter..

    @dazlr

Similar Threads

  1. Changing global ringtone on a Z10
    By fish323 in forum BlackBerry Z10
    Replies: 2
    Last Post: 07-21-14, 09:48 PM
  2. Install Wireless Charging in a PB?
    By Dominic Hagan in forum BlackBerry PlayBook
    Replies: 3
    Last Post: 06-12-14, 08:35 AM
  3. Z10 price in India so low now!
    By Sahajdeep Gill in forum BlackBerry Z10
    Replies: 7
    Last Post: 06-11-14, 03:25 PM

Posting Permissions