1. Murphy5156#CB's Avatar
    I currently have two e-mail accounts pushing to my BB, a personal and a work. I have the BB set so that the personal account is the "default", so that when I send a new e-mail from the BB it shows on the recipient's end as coming from that account. Here's my issue: when I try to reply to a message that was sent to my work account, it looks like my reply is being sent using my personal address and not the work one where the message originated. So, let's say I get an email from someone sent to my work address, when I reply to it the recipient gets the reply from my personal (Comcast.net) mailbox. Does that sound like the way BBs are supposed to work? It wouldn't be a big deal if I could somehow change which account the reply comes from prior to sending it, but I can't seem to find a way to do that. Has anyone else noticed this? It seems to me the reply should use the same e-mail account that received the original message, regardless of which account I have set up as my default, right?
    05-11-08 08:43 AM
  2. Murphy5156#CB's Avatar
    Sorry everyone.....I must have been a little slow the other day when I tried this, because I think the e-mail is actually working fine.....just sent myself an e-mail from my work address to my personal on the BB, then simply replied to it....and the reply was sent from the originating work e-mail address, so I guess I don't have a problem after all (well, at least not as far as my BB is concerned that is). Thanks! :-)
    05-11-08 08:50 AM
  3. jidx's Avatar
    So you corrected the problem, right?
    05-11-08 08:53 AM
  4. jeffh's Avatar
    You're not slow, and unfortunately you probably haven't solved the problem either. It's happened to me twice. Emails I sent from my blackberry appeared to come from my personal email account. When people replied to them, the reply went to my personal account. The problem seems to be caused by the default setting getting wrong. When I changed Send Using from [Default] to 'Desktop,' that fixed it. The next email [Default] was back to being 'Desktop.'

    But it's happened twice that [Default] got pointed to my 'hamj@...' address and I don't know why or how, so I don't consider the problem solved.
    05-11-08 10:23 AM
  5. Flurrycat's Avatar
    If you have two email accounts on the phone and you put one of them in the "TO" line, the berry automatically sets the "FROM" to the other account. So in order to truly test this you'd need to send the email to your berry from an external account that's not on your berry at all. Hope that helps your troubleshooting.
    05-11-08 04:46 PM
  6. jeffh's Avatar
    I don't mean to hijack Murphy's thread, but I think he and I are describing the same situation.

    I have two accounts on my BB: work, jeff.h@... and personal, hamj@...
    The work acct is on BES. The personal email is a POP3.

    If I send an email from the 8830 to jeff.h@, it will say 'Sent Using: Desktop (Secure) and when I get on my desktop, the address To: and the address From: will both be the jeff.h@ address.

    The problem is, sometimes the Sent Using will default to the hamj@ address. I don't know what causes that, and I'm not sure what I've done to fix it. It seems to correct itself as mysteriously as it starts.

    Does that make sense? It doesn't quite fit with what you described, but it's close enough that I think you're onto something, I'm just not sure how to apply it.
    05-11-08 05:19 PM
LINK TO POST COPIED TO CLIPBOARD