04-18-14 03:44 AM
70 123
tools
  1. aseemgosain's Avatar
    Awesome! works!

    btw, if you already have the non functioning v4.5.3, first DELETE it, then install v3, then choose NOT to upgrade, then install v4.5.3 with the given OTA link.

    if you dont delete the original v4.5.3, it'll give an ungaughtexception error when you install v3.

    cheers!
    manxdriver likes this.
    12-15-12 01:27 PM
  2. jgb@etree's Avatar
    Finally i've founded way to get my Google Map back to work.

    Simply use the Google Map version 3 and you can forget about the stupid "Terms & Conditions" step.

    Cheers

    Link for download: https://www.dropbox.com/s/i8w6jymjdv...ogleMap-v3.zip

    [Update] Even better news: after first successful run of v3 you can update to v4.5.3 and it'll get back to work normally .

    OTA link: http://dl.google.com/dl/mobile/maps/...GoogleMaps.jad

    Outstanding job finding this workaround. Thanks.
    12-15-12 01:29 PM
  3. manxdriver's Avatar
    Attachment 128355 thanks , you rock !!! , works perfect Attachment 128355
    thank you -- thank you!!!!!!!!!!!!!!!!!!!!
    12-15-12 01:35 PM
  4. jndrad's Avatar
    wonder if google calendar sync has been disabled as well...doesnt work for me,
    12-15-12 01:44 PM
  5. bimmerdriver's Avatar
    What phone and OS do you have? I have a 9900 with 7.1.0.284, and I installed v3 (got Exception Error) then updated to v4.5.3. NO LUCK!
    U P D A T E..... Now it works! I first went in and totally deleted Google Maps from my 9909, and when I installed v3, it worked! For now, I am not even going to try and go to v4.5.3 -- I'm happy with v3!! MANY THANKS!!!!!!!!!!
    Why not upgrade to v4.5.3? Then you will be at the most recent version for blackberry. Also, why are you running such an old OS on your blackberry? There are newer and much better OSes around.
    12-15-12 02:14 PM
  6. Datle's Avatar
    Any chance with Google Sync? I still can't get it work in my new 9700 but the old 8700 still working.

    Edit: a little out of topic, sorry
    12-15-12 02:19 PM
  7. OmarVlogable's Avatar
    Thank you!
    12-15-12 02:19 PM
  8. ubizmo's Avatar
    My main reason for using Google maps on BB is that it has public transit information; BB maps doesn't. I don't need this all that often but when I need it I really need it.
    JAGWIRE likes this.
    12-15-12 03:30 PM
  9. JC61's Avatar
    I can't believe this is such an issue for people.
    Could it be perhaps because their needs and circumstances are different from yours?
    12-15-12 09:04 PM
  10. JAGWIRE's Avatar
    My main reason for using Google maps on BB is that it has public transit information; BB maps doesn't. I don't need this all that often but when I need it I really need it.
    same thing for me. BB Maps has no public transportation aspect to it and that is VERY inconvenient for myself. I have a car but every so often i have to take the bus to and from work.
    12-15-12 10:19 PM
  11. mithrazor's Avatar
    So how do I put the zip file contents onto my phone? Or rather where?
    12-15-12 11:45 PM
  12. nonya10009's Avatar
    won't work on bbb 9700. bummer! i loved google maps and sucks without it. they were only app service w/ nyc train and bus schedules - more up to date than bus post notices. looks like i can't even download the 511 ny Map app b/c it's not compatible w/ bbb 9700
    12-16-12 12:33 AM
  13. NOLAKjun's Avatar
    I've been using BB Maps since Google Maps crashed on me a few days ago and I agree, once I figured out how to navigate the interface I like it a lot... except for the lack of traffic.
    12-16-12 04:00 AM
  14. owadkelly's Avatar
    But I was still able to get version 4.5.3 here Google Mobile for my 9900 just now.
    12-16-12 07:56 AM
  15. melb_me's Avatar
    Worked for me on my 9900. Delete v4 and restart. Copy v3 to SD card. Use your "file" app to find it on your SD card. File app should be in your applications folder. Click on .jad file to install. Make sure to run v3 once while choosing NOT to upgrade this will let it download "whatever it is you need from Google".
    Lastly go to google site and click on upgrade link (Just search for google maps with the blackberry browser and the link will be near top of search results) to upgrade and it absolutely should work for you.
    mithrazor likes this.
    12-16-12 08:26 AM
  16. qbnkelt's Avatar
    This thread should be stickied.

    EXTREMELY helpful.


    Sent from my SEXY HOT RED SGIII using Tapatalk 2
    12-16-12 10:44 AM
  17. Postfuhramt's Avatar
    Thanks, Kelvin, this really does work !!
    Last edited by Postfuhramt; 12-16-12 at 12:26 PM.
    12-16-12 11:38 AM
  18. djenkins6's Avatar
    I thought I saw someone mention voice navigation. I just installed using the 3 to 4.5.3 path on my 9810 and I don't see any options for spoken directions.
    12-16-12 08:36 PM
  19. Phill_UK's Avatar
    I thought I saw someone mention voice navigation...
    That's only available on Android devices.
    12-16-12 08:45 PM
  20. Hamp's Avatar
    OK, did the same as so many others here. I updated my 9780 to 6.0.3049 just to find out Google Maps no longer works. Read the posts and tried to install Google Maps V3 but no luck. Uncaught exception every time. I have made sure Google Maps is deleted from the phone but I still cannot use the links here to download and install V3. So am I missing something here? Should I NOT have upgraded the OS in order for it to work? Please someone give it to me straight. What am I doing wrong?

    - getting tired of trying
    12-16-12 11:24 PM
  21. bintaro_gw's Avatar
    Thamk you. It works
    12-16-12 11:37 PM
  22. hza71's Avatar
    Thanks a lot - after browsing the web for more than 4 hours - I finally ended - here.
    This works fine - and right - after installing V3 - V4.5.3 can be installed and everything is what it had been before.
    Thanks so much - I am totally happy that people like you post the "right" thing.
    Have a pleasant week!!
    12-17-12 07:19 AM
  23. csantoss's Avatar
    Worked perfectly...

    Shame we have to come up with workarounds for getting the apps we want back on our BBs...

    Let's hope BB10 initiates a turnaround for this uncomfortable trend.
    12-17-12 08:30 AM
  24. Nyan_Cat100's Avatar
    I can't believe this is such an issue for people. In my opinion, Google maps on BlackBerry has always sucked. Like the poster above said, it doesn't even look, feel or work like Google maps on any of the other platforms. It just meh. I'd rather use BlackBerry traffic than Google maps to be honest.

    All of Google's BlackBerry apps that I use have always sucked. Anyone that uses Google voice knows what I mean. The SMS doesn't even have push. Its kinda sad but Google never seemed to try to very hard to please BlackBerry users. Hopefully that changes with BB10.
    I have a huge problem with using BBTraffic and that is:
    It can't be used in the UK!
    12-17-12 11:42 AM
  25. Nyan_Cat100's Avatar
    Worked for me on my 9900. Delete v4 and restart. Copy v3 to SD card. Use your "file" app to find it on your SD card. File app should be in your applications folder. Click on .jad file to install.
    I did that with v3 and I got an error 503 invalid COD when I tried to run the Jad
    12-17-12 12:01 PM
70 123

Similar Threads

  1. I stop getting emails on my BB after a day
    By mohammedj53 in forum BlackBerry Bold 9930/9900
    Replies: 4
    Last Post: 01-16-12, 01:14 PM
  2. Google Maps works on my 9530
    By Spuds93 in forum Telus Canada
    Replies: 2
    Last Post: 11-07-09, 06:12 PM
  3. How do I get browser back on my Curve after wipe handheld?
    By asteria in forum BlackBerry Curve 83xx
    Replies: 3
    Last Post: 09-17-09, 06:06 PM
  4. get email back on my bb
    By vergo in forum BlackBerry 87xx Series
    Replies: 2
    Last Post: 02-24-08, 11:30 AM
  5. I FINALLY got data put back on my phone...
    By xbellendaine in forum BlackBerry Pearl 8100
    Replies: 6
    Last Post: 02-14-08, 08:41 PM
LINK TO POST COPIED TO CLIPBOARD
";