Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 14 of 14
  1. janekim1223's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #1  

    Default Incoming calls not displaying name...?

    does anyone know why my bb pearl 8130 doesn't always display the name associated with an incoming call? sometimes the name shows up, sometimes it doesn't... please help!
  2. sunkast's Avatar
    Super Bad

    Posts
    11,932 Posts
    Global Posts
    11,937 Global Posts
    #2  

    Default

    That is an unusual behavior. Are you certain the person calling is in your address book? Have you tried a battery pull?
  3. janekim1223's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #3  

    Default

    yeah, the names are in my address book. what's a battery pull?
  4. pashan's Avatar
    CrackBerry Addict

    Posts
    783 Posts
    Global Posts
    789 Global Posts
    PIN
    31d360bc
    #4  

    Default

    A battery pull is exactly what the name implies... just pull the battery out. Leave your phone on, remove the battery, then replace the battery and allow your phone to reboot. Should be your first course of action whenever you experience Weird Pearl Activity! Best way for me to explain is that this is the Blackberry equivalent to Ctl+Alt+Del!

    When you do not see the name is your Blackberry locked and password protected? My company recently instituted an IT policy requiring device passwords. Prior to that event my Caller ID ALWAYS displayed the associated Address Book entry, even when my phone was "locked". Now, if my phone is locked (requires password to operate) the caller ID works (I can see the incoming number) but it doesn't pull the name from my address book.

    Sorry I don't have more to offer, but I second the notion that you should do a battery pull and let us know if you are still having the problem!

    Good Luck!!
    Verizon Droid & T-Mo Curve 8520
    Addicted since June, 2006

    7130e - Pearl - Curve 8330 - Droid & Curve 8520
    ___________________
    When in doubt, pull the battery out!

    NEWBIES MUST READ: Crackberry 101 Lecture Series

    Friend Me:
    My Facebook
  5. eyemabug's Avatar
    CrackBerry Abuser

    Posts
    177 Posts
    PIN
    205B8B21
    #5  

    Cool

    Check if your smart dialling has the right country code. Go to Call Logs and then Options. Go to Smart Dialling.

    Save your contacts in the international dialling format (+ CountryCode AreaCode Number)

    Was it doing the samething ever since u got the device?

    Posted from my CrackBerry at wapforums.crackberry.com
  6. janekim1223's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #6  

    Default

    yes, my phone is password protected and locked... i guess that would be the problem then, right?

    thanks for everyone's help!
  7. tevansen's Avatar
    CrackBerry User

    Posts
    79 Posts
    PIN
    3064320D
    #7  

    Default

    If you do a search of this forum you will find the answer. You need to turn off content protection.

    Posted from my CrackBerry at wapforums.crackberry.com
  8. pashan's Avatar
    CrackBerry Addict

    Posts
    783 Posts
    Global Posts
    789 Global Posts
    PIN
    31d360bc
    #8  

    Default

    OMG!! Tevansen is exactly right!!

    Options>Security Options>General Settings>Content Protection

    I just thought if the BB was "locked" I couldn't see the contact names from my address book on incoming calls!!!!

    Thanks a bazillion!!
    ~Paige
    Verizon Droid & T-Mo Curve 8520
    Addicted since June, 2006

    7130e - Pearl - Curve 8330 - Droid & Curve 8520
    ___________________
    When in doubt, pull the battery out!

    NEWBIES MUST READ: Crackberry 101 Lecture Series

    Friend Me:
    My Facebook
  9. tevansen's Avatar
    CrackBerry User

    Posts
    79 Posts
    PIN
    3064320D
    #9  

    Default

    No problem! Glad it worked.

    Posted from my CrackBerry at wapforums.crackberry.com
  10. ramzi188's Avatar
    CrackBerry Abuser

    Posts
    129 Posts
    #10  

    Default

    I have tried all the above and still did not work.

    What made it work for me was i changed the (National Number Length) "Under smart dialing" from 10 which i had as default to 0. Everything worked fine for me since.

    This was a common bug in the iphone that you needed a 3rd party software to fix.
  11. Guarddog's Avatar
    CrackBerry Abuser

    Posts
    116 Posts
    #11  

    Thumbs up Caller ID "by name" don't work

    Quote Originally Posted by pashan View Post
    OMG!! Tevansen is exactly right!!

    Options>Security Options>General Settings>Content Protection

    I just thought if the BB was "locked" I couldn't see the contact names from my address book on incoming calls!!!!

    Thanks a bazillion!!
    ~Paige
    I just wanted to reserect this post. Tevansen and pashan are correct. I just wanted to give you a twist. I have the 8830 WE and and when I received an incomming call I could see the phone number but not the name of the caller (both phone number and name are in my contacts list). My company has an IT security policy requiring the device password to be "enabled" and content protection to be "enabled" I can't change these options however, if you do not include address book you will always get the name and number of the incomming caller device locked or not.
    Try this ...

    Options>Security Options>General Settings>
    Content Protection = "Enabled"
    Strength = "Stronger"
    Include address book = "NO"

    Escape>Save>Receive Call>View name and number>Ignore call>Take a nap

    Enjoy
    GuardDog
  12. BlackPearl890's Avatar
    CrackBerry Genius

    Posts
    1,614 Posts
    PIN
    ......
    #12  

    Default

    Quote Originally Posted by Guarddog View Post
    Options>Security Options>General Settings>
    Content Protection = "Enabled"
    Strength = "Stronger"
    Include address book = "NO"
    thanks 4 this!!!

    i ♥ my 8900!!! (5.0.0.509)
    blackpearl890@crackberry.com

    Follow me on Twitter*
  13. znoblebb's Avatar
    CrackBerry User

    Posts
    85 Posts
    Global Posts
    93 Global Posts
    PIN
    3220C32C
    #13  

    Default

    ok i need to revive this post because i need to do exactly when ur trying to take off here, i need to, while the phone is locked, find a way to make it so that contact names are not displayed when calls are coming in when the phone is locked.. and to make it even trickier, not be able to answer calls without the password when locked....
  14. crackbobb's Avatar
    CrackBerry User

    Posts
    87 Posts
    #14  

    Default

    Old thread, but exactly what I have been looking for. It was driving me nuts that sometimes, it showed the contact name and sometimes it didn't. I wasn't able to find the pattern. So - many thanks for posting this solution.

    Znoble15, the answer to the first part of your question is 2 posts above you. Not sure about the 2nd part but there may be an app for that.

    Cheers

Posting Permissions