1. yyman#CB's Avatar
    Okay - before everyone jumps down my throat - I promised I searched the board and was not able to find a solution to this problem.

    I purchased a curve two weeks ago and set up my GMail account through POP and was receiving my messages pretty much in real time - even before I saw it in my Gmail folder. However, I didn't like maintaining my inbox in two places so I decided to give IMAP a shot. I switched over and realized that real time was more important so quickly gave it up and went back to POP.

    Well here's where my problem started - I am now only receiving SOME of my emails on my Blackberry and cannot figure out why. Basically, my emails that are coming through on my BB are in real time - pure POP but those that don't come through I never get.

    I tried the following: I disabled IMAP in my GMail settings, renabled POP, removed the account on the BIS website, rebooted, resent the service books ... but I'm running out of solutions.

    OH, I even called Sprint BB support and was told - wait wait get this - that I should just forward my GMail to a sprint account since GMail is not real time and is only pulled every 15 minutes and that when I was getting GMail in real time it was a glitch in the system .

    Anyways, I am at a loss as to how to restore my original settings. Any advice??
    07-28-08 04:50 PM
  2. li2327's Avatar
    Gmail doesn't poll. It's push email. It seems like you did everything to get it working. Are the emails you aren't getting still show up in your inbox on your pc?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-28-08 06:09 PM
  3. songbird's Avatar
    oh wow, i had the same problem, but i'm with verizon. they transferred me to someone from RIM and got it all sorted out quickly. check your PM!
    07-28-08 06:48 PM
  4. Hewsinator's Avatar
    It seems like you have tried to deal with this, but in another thread I was reading a poster said that if you have both pop and IMAP enabled, you will not get all emails. Maybe if your read this closely someting may ring a bell.

    Found it:

    "Note: If you have POP and IMAP turned on in Gmail there will be a conflict issue and you will have speratic email dlievery, and you will only get 30% of your emails. See this thread for more details: Anyone having problems with Gmail, Push Email This will show some experiments i did which lead to me getting Gmail IMAP working properly."

    from here:

    forums.crackberry.com/f3/blackberry-push-email-rogers-gmail-imap-fix-26986/

    Sorry for the lack of a link, I am not allowed to do that yet. If I am good I should be able to help people out better soon.
    Last edited by Hewsinator; 07-28-08 at 08:33 PM.
    07-28-08 08:31 PM
  5. Hewsinator's Avatar
    Gmail doesn't poll. It's push email. It seems like you did everything to get it working. Are the emails you aren't getting still show up in your inbox on your pc?

    Posted from my CrackBerry at wapforums.crackberry.com
    I believe this is wrong or I am not familiar enough with the terminology, but for me, it seems that if you enable IMAP, it certainly does not happen in real time, and likewise for the GMail mobile app.
    07-28-08 08:32 PM
  6. UncleMike's Avatar
    I read somewhere, in the many hours I've spent reading about Blackberry since getting mine two weeks ago, that removing and setting up the same email account, in the same session of managing your BIS settings, would result in the service book(s) not getting re-sent to the phone. This was presented as a way to get real PUSH email while using IMAP for its synchronization features. It never did work as advertised (at least for me anyway).

    What I ended up doing afterwards was deleting the account in my BIS settings, and logging out of BIS. I then disables BOTH POP3 AND IMAP on my Gmail account. I then setup my BIS account the "normal" way - providing my email address and password. This causes POP3 to be re-enabled on your Gmail account. After that, everything worked.
    07-28-08 10:24 PM
  7. yyman#CB's Avatar
    Thanks everyone for your suggestions. I ended up calling RIM and was placed on hold for a ridiculous amount of time. The wait music advices me to check blackberry.com/btsc and I found the solution.

    Anyway, I'm not sure why this works but I selected my gmail account and deleted all prior messages, eliminating all my gmail messages on my BB. WOLA - working push email. Don't know why but it works.
    07-29-08 03:59 PM
LINK TO POST COPIED TO CLIPBOARD
";