1. travisthomson's Avatar
    On my curve 8900 with Tmobile - when I try to connect to app world it "Fails to Transmit". This is on BIS, not BES - I've tried the deleting the IPPP trick, no go. Wiped the phone, checked permissions and set to full, etc. No luck.

    Facebook does something similar: "Cannot establish connection to facebook server". Tmobile has been useless and rude. Anyone able to help?
    04-23-09 07:27 AM
  2. cnorton's Avatar
    Go to Options--> Advanced Options--> TCP

    If the settings look like this:

    APN:
    User:
    Password:

    Change them to this:

    APN: wap.voicestream.com
    User: Leave blank
    Password: Leave blank

    I had a similar issue and this fixed it.
    04-23-09 07:38 AM
  3. cnorton's Avatar
    change the epc.tmobile.com to the wap.voicestream.com
    04-23-09 07:41 AM
  4. travisthomson's Avatar
    I did try changing the settings to that. No go. The default is:

    APN: epc.tmobile.com

    Username:
    Password:
    04-23-09 07:42 AM
  5. cnorton's Avatar
    I just remembered that was with my 8120.

    I have no other ideas, someone else take over!
    04-23-09 07:48 AM
  6. travisthomson's Avatar
    Thank you for the attempt though.
    04-23-09 07:51 AM
  7. travisthomson's Avatar
    Anyone? Anyone?
    04-23-09 12:48 PM
  8. travisthomson's Avatar
    Tried uninstalling and resinstalling the apps, no-go.
    04-24-09 06:22 AM
  9. travisthomson's Avatar
    Ok, I Got it... this is going to save everyone who is still struggling with this:

    It's simple: YOU NEED TO CHANGE THE DEFAULT BROWSER FROM "INTERNET" to "TMOBILE" or the apps WILL NOT WORK!
    04-24-09 09:34 AM
LINK TO POST COPIED TO CLIPBOARD