1. Hydroshock's Avatar
    So my dad brought me his BB Pearl, and it seems that any call, there is no sound in or out. Does not ring (but other phones receive calls), talking does not produce sound on either end =(. Anyone know if this could possibly be a software problem?
    04-14-08 08:46 PM
  2. Timewalk's Avatar
    Could be corrupt phone system application..
    Have you tried a battery pull??
    04-14-08 08:48 PM
  3. jeffh's Avatar
    Pull the battery out while the phone is turned on. Leave it out at least 1 minute. Put it back and see if that fixes it.
    04-14-08 08:49 PM
  4. Hydroshock's Avatar
    Hard battery pull didn't work =(. The phone does seem like it's taken alot of abuse though. Anyone know where I could find a cheap Blackberry Pearl, new or used?
    04-15-08 07:34 PM
  5. latina berry's Avatar
    Hard battery pull didn't work =(. The phone does seem like it's taken alot of abuse though. Anyone know where I could find a cheap Blackberry Pearl, new or used?
    Welcome to CB.

    Bienvenido!
    04-15-08 07:44 PM
  6. uncheels23's Avatar
    Hard battery pull didn't work =(. The phone does seem like it's taken alot of abuse though. Anyone know where I could find a cheap Blackberry Pearl, new or used?
    ya i got mine on ebay for 150
    04-15-08 07:45 PM
  7. mzshey2x's Avatar
    Check the Marketplace here on CB!

    Welcome!
    04-15-08 09:04 PM
  8. NoMoreWindows's Avatar
    Try reinstalling the latest OS. It fixes some weird things.
    04-15-08 09:09 PM
  9. truckman's Avatar
    i dont want to be an ****-nugget here but i dont understand why everyone thinks a hard reset (or as most common folk would say a battery pull) f ixes every problem with the blackberry no audio no matter what situation is a little more serious than a common roobot. im just tired of people posting a hard reset as a solution, its not always gna fix it like people think. and most people think of that before they post it.
    04-15-08 11:01 PM
  10. user0011's Avatar
    i dont want to be an ****-nugget here but i dont understand why everyone thinks a hard reset (or as most common folk would say a battery pull) f ixes every problem with the blackberry no audio no matter what situation is a little more serious than a common roobot. im just tired of people posting a hard reset as a solution, its not always gna fix it like people think. and most people think of that before they post it.
    Feels kinda like a Windows help forum, eh? "Reboot."
    04-15-08 11:34 PM
  11. fonebrkr's Avatar
    Try plugging in a set of headphones, jack might be corroded or dirty, alcohol on a qtip works..

    Posted from my CrackBerry at wapforums.crackberry.com
    04-15-08 11:37 PM
  12. Hydroshock's Avatar
    Thanks for the suggestion about the headphone jack. It'll keep the phone useful for a bit longer as the headphones still work.
    04-17-08 06:43 PM
  13. fonebrkr's Avatar
    Next step would be to try a Bluetooth headset, see if it breathes a bit more life into it. Sounds like it might have got wet.. CNN.CN has a lot of replacement parts.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-18-08 12:58 AM
LINK TO POST COPIED TO CLIPBOARD