1. deepsands02's Avatar
    I was able to connect to my house's wifi yesterday (not really sure how, it suddenly showed as connected on my home screen). Now I am trying to connect again and it just gets stuck on the "Connecting to..." screen.

    Doesn't go anywhere from there. I have data connection turned on and wifi is preferred. Not sure what I might have changed since it last worked, pretty sure I haven't changed anything in fact.

    Any idea why its getting stuck on that screen? I dont even get an error, I just have to cancel it after a while.

    Thanks.
    06-21-08 12:16 PM
  2. bmcclure937's Avatar
    What version Device Software are you running??

    4.2 or 4.5??

    Search through this forum and there are a number of different threads that have helped people with WiFi. I would go through detailed steps to help trouble-shoot, but I know for a fact they have been covered before

    Welcome to CrackBerry!!
    06-21-08 01:15 PM
  3. raylol16's Avatar
    Did you try a battery pull or soft reset first?
    06-21-08 02:18 PM
  4. Reed McLay's Avatar
    I was able to connect to my house's wifi yesterday (not really sure how, it suddenly showed as connected on my home screen). Now I am trying to connect again and it just gets stuck on the "Connecting to..." screen.

    Doesn't go anywhere from there. I have data connection turned on and wifi is preferred. Not sure what I might have changed since it last worked, pretty sure I haven't changed anything in fact.

    Any idea why its getting stuck on that screen? I dont even get an error, I just have to cancel it after a while.

    Thanks.

    That is good news, it rules out compatibility problems with your gear.

    Troubleshooting the connection starts with a site survey. That is an option under Wifi diag. You are looking for your network and any other networks within range. If there are other networks on the same channel, you are likely dealing with interference.

    Choose an open channel and re-program your Router.

    Try the connection again, if it succeeds your done.

    If it fails, there will be an error code in Wifi Diag. That will tell you why it has failed.

    The most common cause is a security conflict W010. If so, the best way to troubleshoot the problem is resetting your router back to factory defaults and connect while Open.

    If that is successful, you can re-establish security on the router and on the BlackBerry.

    Good luck.
    06-21-08 03:17 PM
LINK TO POST COPIED TO CLIPBOARD