1. BerryMedic20's Avatar
    I went to Citibank's site, logged in, then went to the mobile download page. My service is supported (Verizon), and my phone is supported (Curve 8330). They sent me the text message, I went to the link, and clicked to download... Then I get redirected to a page that says my "8300" is not supported. But I don't have an 8300... I have an 8330. Is this a glitch? It also says to go to their site to see which phones are supported. The circular logic is killing me!

    Anyone know of a way to make this work? Or are they just screwed up on their end?
    12-17-08 12:51 PM
  2. johnprimo78's Avatar
    In that term 8300 is just a generic phrase for the phone, the 8330 is in the 8300 Family different searies of teh 8300 family supported different things and improved on others, so it more then likely is that your 8330 is not supported since its in the 8300 family,on my 8330 I am limited with banking sites as well, it may not be a glitch it has to do with how there security perametors are set up


    do you have OS 4.3 or 4.5
    12-17-08 12:55 PM
  3. BerryMedic20's Avatar
    I have OS 4.5... I see what you mean, but it's strange that it's listed on their website as supported, but then says it's not on the link. I guess they're just screwy.
    12-17-08 12:59 PM
  4. wreckz619's Avatar
    I think I heard on the news that citibank was having issues with there website.
    12-17-08 01:06 PM
  5. johnprimo78's Avatar
    The idea of a "mobile website" is still somewhat new so I don't think these websites are going to perfect for sometime to come

    Posted from my CrackBerry at wapforums.crackberry.com
    12-17-08 01:16 PM
  6. antdogs24's Avatar
    yeah i wanted to try this out too and i got the error too argh sucks i would like to use my citibank on my curve
    12-17-08 09:26 PM
  7. Tre Lawrence's Avatar
    I have had intermittent problems accessing the Citi Mobile site.
    12-17-08 09:35 PM
  8. Crack_Dealer's Avatar
    Same issue!
    My guess is that stupidass text character limitation on SMS messages. The download URL is being chopped when sent to the device.

    Grrrrrrrrrrrr
    03-11-09 07:37 PM
  9. dquestic's Avatar
    I just figured out a way to get this working on the Curve 8900. It was actually so simple I wanted to kick myself. This was done on Tmobile but should work without issue for AT&T users.

    First thing I did was sign up at the myciti site using my info and selecting the 8320. I received the txt and clicked the link. I then received the error so many here have also gotten.

    Blackberry Curve 8300 is currently unsupported phone or whatever it is.

    I realized that the 8300 was listed as a supported phone on the AT&T options and that my Curve 8900 was being recognized as a 8300. That was actually a good thing. First I tried to setup my phone number and set AT&T as my network, but needless to say, fail! So I changed back to tmobile and tried a different route.

    Next I looked at the link i received in the text and saw that carrier was last part. In my case the link ended in carrier=tmobile. I copied the link, pasted it into the browser and changed carrier= to att. App downloaded without an issue. I now have the citibank mobile app installed and running. Good Times. I don't see why this wouldn't work on a bold also, as long as it is recognized as a 8300.
    04-15-09 11:26 AM
  10. cardona1130's Avatar
    Brilliant....
    04-27-09 07:49 AM
LINK TO POST COPIED TO CLIPBOARD