Results 1 to 7 of 7
  1. brendy23's Avatar
    CrackBerry Newbie

    Posts
    4 Posts
    Thread AuthorThread Author   #1  

    Default camera wont open on my bb curve please help me.!!!

    i've taken out my battery cleared my event log closed all applications on my bb curve and the camera still wont start up what can i do?
  2. albee 1's Avatar
    CrackBerry Genius

    Posts
    4,047 Posts
    Global Posts
    4,051 Global Posts
    PIN
    3302D65A
    #2  

    Default

    My old curve would show a black screen when this happened. Push the lens in gently with a qtip or pencil eraser till it snaps back in. Be careful others have broken the lens doing this. Do you remember dropping it lately?

    Posted from my CrackBerry at wapforums.crackberry.com
  3. sterling_bandit's Avatar
    CrackBerry Abuser

    Posts
    270 Posts
    #3  

    Default

    try deleting last installed app and battery pull or upgrade OS via desktop manager, if you're already on latest OS, install lastest leaked OS for your phone, if that fails take it back to the shop. good luck.
  4. brendy23's Avatar
    CrackBerry Newbie

    Posts
    4 Posts
    Thread AuthorThread Author   #4  

    Default

    albee 1 yes i have dropped it recently i dropped it inn the sink nd it got wet i took out the battery put it in a bowl of rice after tht the phn worked perfectly fine so did the camera now the camera wont work it says could not start the camera close other applications and try opening the camera again
  5. albee 1's Avatar
    CrackBerry Genius

    Posts
    4,047 Posts
    Global Posts
    4,051 Global Posts
    PIN
    3302D65A
    #5  

    Default

    Quote Originally Posted by brendy23 View Post
    albee 1 yes i have dropped it recently i dropped it inn the sink nd it got wet i took out the battery put it in a bowl of rice after tht the phn worked perfectly fine so did the camera now the camera wont work it says could not start the camera close other applications and try opening the camera again
    You may have some moisture left in it. That is my guess if it worked after you dropped it. I would dry it out some more. Good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
  6. vicm1969's Avatar
    CrackBerry User

    Posts
    12 Posts
    #6  

    Default

    had same issue, ii did battery pull and it worked fine.
  7. brendy23's Avatar
    CrackBerry Newbie

    Posts
    4 Posts
    Thread AuthorThread Author   #7  

    Default

    well mine still doesnt work i ran out of ideas

Posting Permissions