1. GRIME's Avatar
    So I read about the software update on the front page and opened up my Desktop Software and sure enough it was ready to go, I plugged my phone in and watched the program do its thing, all of a sudden a screen comes up in my berry asking if I want to do mass storage mode, I click yes, then some apps ask permission for various things and I assumed this was because they were being reinstalled, so I accepted, but then when the update got to the end of step 10 there was some kind of error saying that a password needed to be entered. Well, I didn't have a password set on my device, so I clicked retry, and it's starting step 10 all over again, which apparently takes about an hour. I hope I didn't mess something up?
    05-13-09 03:52 PM
  2. xliderider's Avatar
    Why would you want to enable Mass Storage Mode when you are trying to do a software update?

    Mass Storage Mode is for copying files to your memory card (media card) and has nothing to do with OS installations/upgrades. Correct answer = No.
    05-13-09 03:56 PM
  3. GRIME's Avatar
    Well I just got this thing the other day and I'm still pretty unfamiliar with this stuff, in addition I'm not very technologically inclined, thanks for clearing that up for me though. Step 10 is about to be finished, I'm just hoping it doesn't give me an error again..
    05-13-09 03:59 PM
  4. GRIME's Avatar
    It did it again, the exact error says:

    "The desktop loader is unable to connect to the device.

    You may need to enter the password on the device."


    What should I do? Disconnect and start over?
    05-13-09 04:14 PM
  5. xliderider's Avatar
    What version of DM are you using, what OS are you using on your PC (XP,Vista, Vista 64-bit)?

    Also, what guide are you referring to (you referred to step #10.)?
    05-13-09 04:16 PM
  6. GRIME's Avatar
    DM is 4.7, I'm running Windows XP on VMWare Fusion on my Mac, step 10 refers to the software update, it's not a guide just a 'Step in Progress'
    05-13-09 04:19 PM
  7. xliderider's Avatar
    Have you tried to just press Enter, or Next to bypass the password screen?
    05-13-09 04:20 PM
  8. GRIME's Avatar
    The only options are 'retry' and 'cancel'
    05-13-09 04:26 PM
  9. Phelos's Avatar
    Had a similar prob. So I just gave up and still with OS 4.2.2.170. =8'( maybe one of these days when I care about the OS I'll get downloading it. But hopefully by then I'll have a new shiny berry. =8')
    05-13-09 04:28 PM
  10. xliderider's Avatar
    I'm not sure if your issue is with DM 4.7 or the fact that you are using VMWare Fusion on a Mac to do your upgrade. DM 4.7 can be buggy when used with the Curve series, especially for doing OS upgrades.

    I have never received a password screen come up when I do OS upgrades.

    Do you have a friend or relative with a PC that you can borrow some time on?
    05-13-09 04:31 PM
  11. GRIME's Avatar
    But is the phone ok as it is? The apps are still there but I guess they have been reinstalled, however my photos are all gone and my settings have all been reset. Fortunately I just got it so I didn't do much customization yet, it wouldn't be difficult to get everything back the way I had it, I just don't know what this process did to my phone and if I need to undo it or just leave it as is. Of course, preferably I would like the new OS..
    05-13-09 04:32 PM
  12. GRIME's Avatar
    I'm not sure if your issue is with DM 4.7 or the fact that you are using VMWare Fusion on a Mac to do your upgrade. DM 4.7 can be buggy when used with the Curve series, especially for doing OS upgrades.

    I have never received a password screen come up when I do OS upgrades.

    Do you have a friend or relative with a PC that you can borrow some time on?
    No unfortunately everyone in my family has a Mac..
    05-13-09 04:33 PM
  13. xliderider's Avatar
    What OS is on it now? 4.5.0.110?

    And what OS are you trying to load?
    05-13-09 04:34 PM
  14. GRIME's Avatar
    Well I just did a restore but the 'About' field in my options folder says that my OS is 4.6.0.167 which I believe is the OS that just got released and I was trying to install

    I'm not sure what's going on lol, at least the restore worked

    I restarted my PC and I'm going to go for a bike ride and try the update again when I come back, I'll keep you guys posted, thanks for the help so far
    05-13-09 04:47 PM
  15. branden3112's Avatar
    If youre trying to load 4.6 onto your 83xx, that's your problem. You can not loaf anything above 4.5 onto to an 83xx device with the exception of the 8350i.
    05-13-09 07:20 PM
  16. GRIME's Avatar
    nah it's a blackberry bold, is it ok for the bold?
    05-13-09 07:52 PM
  17. branden3112's Avatar
    nah it's a blackberry bold, is it ok for the bold?
    Oh, you should probably change your profile then.
    05-13-09 08:04 PM
  18. GRIME's Avatar
    oh, haha, sorry this is an old account, will do

    so, now it's saying that there is no update available, this is really weird, my phone says that i'm running the new OS, but it says that after i have restored it, ugh
    05-13-09 08:09 PM
  19. branden3112's Avatar
    Have you tried you tried using loader.exe and have you deleted Vendor.xml? There's a link in signature on proper upgrade procedure.
    Last edited by branden3112; 05-13-09 at 08:25 PM.
    05-13-09 08:14 PM
  20. xliderider's Avatar
    For DM 4.7 you also have to disconnect from the internet because DM 4.7 checks for the official OS version for your carrier.

    If you are trying to load something above that official version, it will say there is nothing to load.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-13-09 08:20 PM
  21. GRIME's Avatar
    Have you tried you tried using loader.exe and have you deleted Vendor.xml? There's a link in signature on proper upgrade procedure.
    I don't have the vendor.xml file, when I restored the berry I did it with the LoaderBackup.ipd file that was created today during the upgrade, but I also have the backup.ipd from yesterday

    I'm not sure what the upgrade was supposed to do for the phone, it seems to be working fine, only thing is I had to setup all of my downloaded apps again, they were on the phone, but I had to put all of my info in again
    05-13-09 08:59 PM
  22. GRIME's Avatar
    I don't know if I really am running the newest version and I just had to do the last step manually or if the phone is mixed up..is there any way to tell? Or is there anyway to try the update again? I have a backup.ipd file that was made yesterday that I could run, maybe that would get me back to the old software and then I could try the update again?
    05-13-09 09:29 PM
LINK TO POST COPIED TO CLIPBOARD
";