1. serenity3's Avatar
    Ok, I tried a search and found nothing so here goes. I just got a blueant Z9 about 2 weeks ago to use with my bb 8830WE. I planned on just using in the car when driving (I have a long commute and get bored). So, I've called 2 people and both have described the sound on their end as (aliens talking in the backseat of the car). WTH? My sound quality is fine, but apparently the aliens are quite loud on their end. It doesn't seem to be a location thing either because I travel about 30-40 miles to work and the aliens are there the whole drive. Has anyone experienced anything like this? Is it just MY blueant or is this a universal thing? Everyone said such great things about it I'm hoping I just got a screwed up one. Any help is appreciated in exterminating the aliens.
    03-27-08 12:47 AM
  2. cdmaguy's Avatar
    Ok, I tried a search and found nothing so here goes. I just got a blueant Z9 about 2 weeks ago to use with my bb 8830WE. I planned on just using in the car when driving (I have a long commute and get bored). So, I've called 2 people and both have described the sound on their end as (aliens talking in the backseat of the car). WTH? My sound quality is fine, but apparently the aliens are quite loud on their end. It doesn't seem to be a location thing either because I travel about 30-40 miles to work and the aliens are there the whole drive. Has anyone experienced anything like this? Is it just MY blueant or is this a universal thing? Everyone said such great things about it I'm hoping I just got a screwed up one. Any help is appreciated in exterminating the aliens.
    Have you tried to upgrade the firmware?
    Got to - www . blueantz9 . com and click on the Support link at the top of the page.

    I have the 8130 with v4.3.0.71 and i bought the Z9 a couple of days ago. I immediately upgraded the firmware and to be honest I am not that impressed with this. I'm thinking about returning for the Jawbone.

    The sound is very clear yet it soesn't sound natural. The noise cancelling on "max" mode does not seem to work at all. It breaks up my voice and doesn't really get rid of the background noise. I have turned off the echo control and it does not seem to improve.
    03-27-08 11:12 AM
  3. serenity3's Avatar
    I haven't tried that. Thanks!

    Posted from my CrackBerry at wapforums.crackberry.com
    03-27-08 01:17 PM
  4. Flurrycat's Avatar
    I have tried that. The aliens didn't go away. The longer I used it the worse they got. I had to return it.

    Wish I had better news for you...
    04-19-08 07:09 PM
  5. serenity3's Avatar
    Yeah, I upgraded the firmware and it helped a little (or so I'm told). I've stopped using it really, and apparently it's tolerable now. I hope it doesn't get worse though!!
    04-20-08 12:18 AM
LINK TO POST COPIED TO CLIPBOARD