Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. adicktuz's Avatar
    CrackBerry Abuser

    Posts
    224 Posts
    Global Posts
    225 Global Posts
    Thread AuthorThread Author   #1  

    Arrow Desktop Manager Update

    Hi, I've been using my Desktop Manager for my Bold 9780 since the first day I got my BB. I use it to update my OS.

    But today, I tried to connect my sister's Curve 8520 to update her OS, but it says that it needs to update the Device Software. The current version installed on the Curve is 4.6.1.272, and I'm trying to update it to OS 5.2.0.104 (latest OS that showed up on Desktop Manager).

    Whenever I try to update it, it says, An updated BlackBerry Desktop Software component must be installed before you can continue.

    Do I have to install every single OS versions before the 5.2.0?

    I never had this problem with my 9780.

    Thank you.
  2. Techno-Emigre's Avatar
    CrackBerry Abuser

    Posts
    483 Posts
    #2  

    Default

    I had trouble twice when I had my Storm 2 with DM saying I had an OS update that was below the one installed in my device. I ONLY use official OS from Verizon. I just ignored it. When I got my Torch 9850 I assumed there probably was an OS update as I was activating the phone. Oh, bad decision ... the OS DM downloaded bricked my phone. I ended up with RIM (who gave me excellent customer service BTW) and they had me reinstall the OS thry Apploader. It was easy. I no longer trust DM for anything other than syncing and backups.

    It almost sounds as tho you are talking about two seperate things ... getting a message you need to update Desktop Manager software in order to proceed ... AND DM saying you need to update the device OS?

    If that is true, I would remove the device from USB and update DM software, close it and reopen and see if you get the correct OS listed. I would only use Apploader to update your OS. You can get the official OS from your carrier and I am sure you can get directions by searching CB. Hope that helps.
  3. fotyc's Avatar
    CrackBerry Abuser

    Posts
    178 Posts
    Global Posts
    278 Global Posts
    #3  

    Default

    Quote Originally Posted by adicktuz View Post

    Whenever I try to update it, it says, An updated BlackBerry Desktop Software component must be installed before you can continue.

    Do I have to install every single OS versions before the 5.2.0?

    I never had this problem with my 9780.

    Thank you.
    I coincidentally had this happen today too. I connected my Torch to my PC to move a bunch of photos, and it told me to update DM, so I did. Then I restarted DM and it told me I had an OS update available. When I said I wanted to apply the update, it said I had to install an updated desktop software component first, so I said to go ahead and do that, and it tried and then it said an error occurred while doing that task. I retried a couple of times and always got the same message.

    Disclaimers: I am running the same version of DM that came with my previous phone, a Verizon Curve. (Do I need to uninstall it and install the version from the CD I got from AT&T with my Torch?) I never disconnected and reconnected the Torch from the PC during this exercise (would that help?).

    Windows XP operating system with all updates.

    I assume from what people have been saying here that just because DM offers me an OS update doesn't mean I should take it... but I don't know if AT&T would notify me of updates?

    edited to add: on the AT&T update page the updates are available for download - should I download All languages or Multilanguage? What is the difference?? Thanks, sorry to be dense!
    Last edited by fotyc; 09-17-2011 at 06:07 PM. Reason: added another question!

Posting Permissions