Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
  1. raxamillion's Avatar
    CrackBerry Abuser

    Posts
    269 Posts
    Thread AuthorThread Author   #1  

    Default Z10 Refuses to connect to PC anymore, HELP!

    My Z10 doesn't connect to my PC via USB regardless of whether link is up and running or not. only way i can get to see the phone is to turn mass storage on. when i do plug it in all i get is three low tonnes in quick succession on my PC and a red exclamation mark on the battery icon on my phone.

    Any help would be greatly appreciated. cannot do any backups or syncs until this is resolved.
    Bold 9000>Torch 9800>White Z10>White Z30 STA100-2 running 10.2.1.2228

    And two 64gb Playbooks used almost daily.
  2. rav813's Avatar
    CrackBerry Addict

    Posts
    508 Posts
    Global Posts
    522 Global Posts
    #2  

    Default

    what version of Windows are you running?
  3. KDB84's Avatar
    CrackBerry Master

    Posts
    1,048 Posts
    Global Posts
    1,049 Global Posts
    #3  

    Default

    Which USB port are you using? Had this issue when plugged into a USB Hub; main USB2.0 plug on my laptop fixed it.
  4. slashstarfish's Avatar
    CrackBerry User

    Posts
    66 Posts
    #4  

    Default

    It seems to be a problem with the software on your computer. Please try to uninstall all Blackberry software completely, then restart the computer and install again. Afterwards plug the device in and let it sit for a few minutes to give windows time to install it. Then restart Windows again and now it should finally detect the device. If it does not you can either play around with settings (going to the hardware manager etc.) or reinstall the operating system (if you have Windows, if you have OSX instead please do not reinstall the operating system, it probably won't help). Then you might want to get help from a friend who is into computers and has time to look at it.
    Thanked by:
    raxamillion (03-01-2013) 
  5. colorwatch2000's Avatar
    CrackBerry Abuser

    Posts
    101 Posts
    #5  

    Default

    Mine doesn't even recognize the BlackBerry as a device. It just charge it. HELP!!!
  6. raxamillion's Avatar
    CrackBerry Abuser

    Posts
    269 Posts
    Thread AuthorThread Author   #6  

    Default

    uninstalled and reinstalled link software. worked after a few reboots for some reason . Thank you so much.
    Bold 9000>Torch 9800>White Z10>White Z30 STA100-2 running 10.2.1.2228

    And two 64gb Playbooks used almost daily.
  7. colorwatch2000's Avatar
    CrackBerry Abuser

    Posts
    101 Posts
    #7  

    Default

    OK cool I'll try that to
  8. jabirvelom's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #8  

    Default Z10 Refuses to connect to PC anymore, HELP!

    windows 7 64bit
  9. SlickCity's Avatar
    CrackBerry User

    Posts
    52 Posts
    #9  

    Default

    When plugged in to PC, hold down the power button on the Z10 to reboot while BB Link is still on.
    That worked for me.
  10. phakama anelia's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #10  

    Default ms

    i just want to know what to do my blackberry doesnt want to connect to pc
  11. deanupam's Avatar
    CrackBerry User

    Posts
    19 Posts
    #11  

    Default

    Me facing same problem. Will do as suggested. Rebooting the BlackBerry

    Posted via CB10
  12. bintheredundat's Avatar
    CrackBerry Master

    Posts
    1,352 Posts
    #12  

    Default

    Try going into windows device manager and find and delete all blackberry devices that were previously connected.
    Then when you plug in the new device it should install as if it's the first time you connected.



    Posted via CB10 on my Z10 Oreo
    Posted from my Z10 Oreo
  13. deanupam's Avatar
    CrackBerry User

    Posts
    19 Posts
    #13  

    Default

    Did that. Will try again.

    Posted via CB10
  14. deanupam's Avatar
    CrackBerry User

    Posts
    19 Posts
    #14  

    Default

    Didn't connect
    . Never asked for password. Git disgusted. Could load android apps thru chrome extension and Wi Fi. Ipv4 Wi Fi iP address. Used a free contacts backup.

    Posted via CB10
  15. der_mit's Avatar
    CrackBerry Addict

    Posts
    833 Posts
    #15  

    Default

    Don't have link running

    Just fire up the pc.

    Turn off the Z10.

    Plug Z10 in to pc.

    Turn on the Z10.

    Let the pc install the Z10 drivers.

    You need to do this every time BlackBerry link is updated.


    Posted via CB10
  16. Kyle McMillan's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #16  

    Default

    This happened to me and for so long I couldn't figure it out but then did something so simple I thought that it couldn't be that easy.
    All you need to do if it's not connecting to link wirelessly or USB cable is to,
    1) do a battery pull
    2) take out media card and reinsert it

    *note* when I did this it connected right away, it sync'd all media on the phone as I had it before I did step 1 & 2. It will take a few mins to re-sync so don't freak out when u see no media on your phone right away like I did

    Cheers.
  17. deanupam's Avatar
    CrackBerry User

    Posts
    19 Posts
    #17  

    Default

    Will try that too. Actually I use mail now to transfer data as attachment. Then save in media file.

    Posted via CB10
  18. Anonymous23400's Avatar
    CrackBerry Abuser

    Posts
    390 Posts
    #18  

    Default

    Happened to me as well. Funny thing is my bold and playbook connected fine. Did a factory restore on my phone and that didn't work. I reinstalled windows and that worked. No idea what happened......

    Posted via CB10

Similar Threads

  1. [Help] DDPB unable to connect to Z10
    By Knightcrawler in forum BB10 Android App Sideloading
    Replies: 54
    Last Post: 03-09-2014, 02:27 PM
  2. Replies: 12
    Last Post: 12-22-2009, 11:59 AM
  3. Unable to connect to USB HELP!!!
    By Snicholson717 in forum BlackBerry Storm
    Replies: 8
    Last Post: 07-16-2009, 10:18 PM
  4. Can't connect my Pearl to my PC anymore........help please
    By dcheser in forum BlackBerry Pearl 81xx
    Replies: 2
    Last Post: 05-21-2009, 01:54 PM
  5. Need to know how to connect to PC via Usb
    By Moonbaby in forum BlackBerry Curve 83xx
    Replies: 11
    Last Post: 03-01-2009, 02:43 PM

Posting Permissions