Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. nb17's Avatar
    CrackBerry User

    Posts
    11 Posts
    Thread AuthorThread Author   #1  

    Default Z10-Black screen. led flashing red. HELP PLEASE

    I Love my phone and I'm really hoping someone can help me fix it. I tried sending a message, and I looked at my phone a minute later and it wasn't there, so I retyped it and sent it again, and it did not show up again, so I restarted my phone, well tried to. It came onto the normal blackberry screen, but then it went black again. It will not turn on, but there is a sequence of 5 red led light flashes. One, then three faster, and then one again. I have tried pulling the battery, charging it, etc. Nothing has worked. I tried connecting it to blackberry link and it said it could not connect to my device. So I tried to reload the software.but it wont get past saying, initializing software. I also tried updating the software straight off of the internet and nothing.



    HELP PLEASE!
  2. UND_OSU's Avatar
    CrackBerry User

    Posts
    17 Posts
    #2  

    Default

    This happened to me and I just ended up getting a replacement phone. I tried the same things you did, but failed to work. Maybe someone else has had better luck. On a more positive note, my replacement phone has been perfect. My original would only get about 6-8 hours of battery life and I hardly use my phone, where as the replacement gets me through almost two days!
  3. chickenman18's Avatar
    CrackBerry Abuser

    Posts
    257 Posts
    #3  

    Default

    Mine did the same thing. Take it back to your carrier. They told me the motherboard was fried.

    Posted via CB10
  4. New_Z10's Avatar
    CrackBerry Abuser

    Posts
    484 Posts
    #4  

    Default

    Dead phone.

    Posted via CB10
  5. rcs36's Avatar
    CrackBerry Abuser

    Posts
    189 Posts
    #5  

    Default

    Have you tried a leaked autoloader instead of link?
  6. Thunderbuck's Avatar

    Posts
    5,793 Posts
    Global Posts
    5,796 Global Posts
    PIN
    2B6927F7
    #6  

    Default

    Nope, I had it happen to me, too. Tried autoloaders, tried everything I possibly could. Took it back to the retailer.





    "Max Power doesn't 'cuddle'! You strap yourself in and feel the Gs!"
  7. SDM7171's Avatar
    CrackBerry Abuser

    Posts
    261 Posts
    #7  

    Default

    Me too. It is not recoverable

Similar Threads

  1. Transfer from the Torch to a Z10
    By BlueRocks in forum BlackBerry Z10
    Replies: 6
    Last Post: 11-07-2013, 06:14 PM
  2. Will LTE Z10 (STL100-3) work on Straight Talk?
    By cbnoobster in forum BlackBerry Z10
    Replies: 4
    Last Post: 10-21-2013, 04:03 PM
  3. Unable to call Z10
    By snarlybear in forum BlackBerry Z10
    Replies: 13
    Last Post: 09-28-2013, 02:43 PM
  4. WTB Z10 or Q10 in Toronto area
    By ricktw in forum The Marketplace - Buy, Sell & Trade
    Replies: 4
    Last Post: 09-27-2013, 09:10 AM
  5. High dropped call rate on my Z10?
    By psmith0803 in forum BlackBerry Z10
    Replies: 4
    Last Post: 09-26-2013, 10:04 AM

Posting Permissions