Page 1 of 2 12 LastLast
Results 1 to 25 of 26
  1. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #1  

    Default What the heck happened to my battery?

    Battery life was doing ok from day one, improving daily...
    Then today it suddenly decided to drain fast and die in only a few hours??
    So I charged it again this afternoon, full charge and it has been off the charger about an hour now..
    58% already!!! I have barely used it!
  2. playbookster's Avatar
    CrackBerry Genius

    Posts
    4,067 Posts
    #2  

    Default

    Perhaps you have a defective battery. Take it back. That does not sound like normal battery drain.
  3. Silkyfresh's Avatar
    CrackBerry User

    Posts
    18 Posts
    #3  

    Default

    How is the service where you are at? Does it occasionally lose signal? When was the last time you power cycled your device?

    Posted using CrackBerry App on BB10
  4. Whitecaps's Avatar
    Banned

    Posts
    378 Posts
    Global Posts
    380 Global Posts
    #4  

    Default

    were u using it to watch videos the whole time?
  5. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #5  

    Default

    power cycled...huh

    I turned my LTE signal down to HSPA since my house is out of decent LTE range and I have all my bluetooth and nfc etc off...
  6. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #6  

    Default

    Quote Originally Posted by Whitecaps View Post
    were u using it to watch videos the whole time?
    hahahaha nope, Just a bit of texting and bbm.
  7. playbookster's Avatar
    CrackBerry Genius

    Posts
    4,067 Posts
    #7  

    Default

    Quote Originally Posted by noangelx View Post
    hahahaha nope, Just a bit of texting and bbm.
    Yup, sounds like a defective battery.
  8. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #8  

    Default

    OK So I downloaded a battery meter and it was at 61 then and 58 then 57 in a matter of minutes, So i did a battery pull and after it booted up I opened the battery meter and now it says 64!!!!! ?
  9. Silkyfresh's Avatar
    CrackBerry User

    Posts
    18 Posts
    #9  

    Default

    When was the last time you power cycled the device (shut phone off, removed battery and sim card waited about 30 seconds then re insert sim and battery)?

    Also if the phone is going in and out of service that will drain the battery like no tomorrow


    Posted using CrackBerry App on BB10
  10. Whitecaps's Avatar
    Banned

    Posts
    378 Posts
    Global Posts
    380 Global Posts
    #10  

    Default

    Get an external battery charger
  11. clowrym's Avatar
    CrackBerry Abuser

    Posts
    267 Posts
    Global Posts
    269 Global Posts
    #11  

    Default

    how about media sharing.... did you happen to turn it on...and left it on? I lose about 50% bat by noon if its on
  12. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #12  

    Default

    Ohhh I did a battery pull but didn't pull the sim.
    I turned it from LTE to HSPA (My 9900 was on HSPA) Because I live in the outskirts of the city with spotty LTE, Was that a good idea?
  13. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #13  

    Default

    Nope I checked! I haven't turned that on before, But checked in case it got accidentally turned on.

    Quote Originally Posted by clowrym View Post
    how about media sharing.... did you happen to turn it on...and left it on? I lose about 50% bat by noon if its on
  14. Silkyfresh's Avatar
    CrackBerry User

    Posts
    18 Posts
    #14  

    Default

    Quote Originally Posted by noangelx View Post
    Ohhh I did a battery pull but didn't pull the sim.
    I turned it from LTE to HSPA (My 9900 was on HSPA) Because I live in the outskirts of the city with spotty LTE, Was that a good idea?
    Yes. Where I work I have the same issue my z10 fights to get service. To the point where I'd be lucky to get 6 hours out of it. I started going wifi at work and I'm up to 10-12 hours with no issues.

    Posted using CrackBerry App on BB10
  15. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #15  

    Default

    hmmm it went from 64 a few minutes ago to 59 now and I haven't used it at all !!!!!
  16. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #16  

    Default

    I did switch it to HSPA a few hours ago, still seems to be draining fast...
  17. Jerryg50's Avatar
    CrackBerry Abuser

    Posts
    309 Posts
    Global Posts
    311 Global Posts
    #17  

    Default

    If the WiFi hot spot, NFC, and tethering are all on at the same time the battery will go much faster. When I am using the phone as normal, I only have the Bluetooth option active. Email, and everything else is working okay. I found watching movies and using the WiFi hot spot running at the same time will run down the battery very fast.

    I also would not rule out a defective battery...
    Jerry G.
  18. playbookster's Avatar
    CrackBerry Genius

    Posts
    4,067 Posts
    #18  

    Default

    Last time. Its defective lol. Take your phone back, they will give a new phone or a new battery.
  19. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #19  

    Default

    Ya like I said, everything is off... All of it!!!
    I didn't use any media at all or hotspot, just facebook, text, bbm, but not even much at all today.

    Quote Originally Posted by Jerryg50 View Post
    If the WiFi hot spot, NFC, and tethering are all on at the same time the battery will go much faster. When I am using the phone as normal, I only have the Bluetooth option active. Email, and everything else is working okay. I found watching movies and using the WiFi hot spot running at the same time will run down the battery very fast.

    I also would not rule out a defective battery...
  20. EauRouge's Avatar
    CrackBerry Master

    Posts
    1,268 Posts
    Global Posts
    1,624 Global Posts
    #20  

    Default

    Drain it fully, recharge it to full and see if it happens again. May be defective
  21. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #21  

    Default

    I just don't get why it started doing this so suddenly, it was fine before. The battery was getting better everyday...

    Quote Originally Posted by playbookster View Post
    Last time. Its defective lol. Take your phone back, they will give a new phone or a new battery.
  22. playbookster's Avatar
    CrackBerry Genius

    Posts
    4,067 Posts
    #22  

    Default

    Quote Originally Posted by noangelx View Post
    I just don't get why it started doing this so suddenly, it was fine before. The battery was getting better everyday...
    I had the same issue with my old torch. Was great the first few weeks then suddenly it wouldnt last more than 3 hours. It was the battery, Rogers gave me new one and it lasted me 2 more years.
  23. noangelx's Avatar
    CrackBerry Abuser

    Posts
    278 Posts
    Thread AuthorThread Author   #23  

    Default

    grrrrrrrrrrrrrrr
  24. sportline's Avatar
    CrackBerry Genius

    Posts
    2,007 Posts
    Global Posts
    2,009 Global Posts
    #24  

    Default

    i tried to get wifi on at work..it helps the battery///the problem is when i got out of office (out of wifi range) the phone heats up..and burns battery. so the wifi management is not good. i can have my wifi ipad mini turned on for days on no-wifi zone and the battery still intact..no excessive drains.
  25. swtnotZ10's Avatar
    CrackBerry User

    Posts
    52 Posts
    #25  

    Default

    Quote Originally Posted by noangelx View Post
    Battery life was doing ok from day one, improving daily...
    Then today it suddenly decided to drain fast and die in only a few hours??
    So I charged it again this afternoon, full charge and it has been off the charger about an hour now..
    58% already!!! I have barely used it!
    Mine has been acting strange also. I listen to my music (no streaming) at work and a few days ago after work it still had more than half life left in it. Then today, it had 25% life left in it. Also, there are times I recharge it and it never fully charges. I do have an extended warrenty on my battery so I may just take it in and get it replaced.
Page 1 of 2 12 LastLast

Similar Threads

  1. what the heck happened to the forums???
    By mrwestphal in forum General BlackBerry Discussion
    Replies: 5
    Last Post: 11-09-2009, 07:58 AM
  2. So what the heck happened to Verizon's official OS update?
    By slinky317 in forum BlackBerry Tour 9630
    Replies: 3
    Last Post: 09-30-2009, 04:59 AM
  3. What the heck happened to my Bold? Serious trouble here!
    By the urban politician in forum BlackBerry Bold 9000
    Replies: 23
    Last Post: 04-09-2009, 06:50 PM
  4. Calling Any or All Storm Guru's...What the heck happened to my phone?
    By Carol64 in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 02-17-2009, 10:20 PM
  5. What The **** Just Happened To My Bold?
    By maxm in forum BlackBerry Bold 9000
    Replies: 2
    Last Post: 11-13-2008, 08:13 PM

Posting Permissions