Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 59
Like Tree22Likes
  1. chopachain's Avatar
    CrackBerry Abuser

    Posts
    336 Posts
    Thread AuthorThread Author   #1  

    Default Should there be Factory Recall for Z10 STL100-1?

    The title I have used here might sound a bit drastic, but trust it is what it is. This phone model is being sold as we speak with a design and manufacture flaw that affects the STL100-1 model only. The sad and disappointing part is that BlackBerry knows about this and remains silent on this matter and keeps on selling the phone. This is just wrong, on so many levels.

    The problem I speak of here is the BATTERY CHARGING CALIBRATION problem. The symptom/problem will be a phone that does not charge all the way to 100% and or a phone that shuts down without warning at any percent. Mine does it at around 30%. There is no solution to this problem. I have researched it. There are temporary solutions. You can plug and unplug the charging pin adaptor a few times for the not charging to 100% problem or remove the battery for a hour or more for the shutting down without warning problem. I usually remove the battery over night. But it will be temporary. In a day or two the problem will be back. Its a constant cycle. It is highly frustrating and annoying.

    For those who don't think this is a problem with the phone. Do a search on the www and all the forums including this one and see what you get. We even have a petition running on this forum.
    I have tried to phone BB to get some sort of solution but all I get is the person at the other end of the line telling me, this phone number is not for public use.
    I do not want to take my new pristine condition Z10, which has passed the 7 day return policy, to the retail store and have it sent away for however long to receive a refurbished phone in return. I paid top dollar for my Z10 $750 and expect this phone to be swopped out immediately at the retail store from where I bought it. But we all know without some sort of directive from BB this will not happen. If a solution can be found without returning the phone, that would be a bonus. My phone has official 10.2.0.424 on and I have never loaded a leak.

    Kevin I would appreciate your assistance here or anybody for that matter who can get a direct line to BB and get some sort of solution here and advise the way forward, please.
    CeeZ
    Thanked by:
    ami.one (01-22-2014) 
  2. homer1475's Avatar
    CrackBerry Genius

    Posts
    4,134 Posts
    #2  

    Default

    What makes you think this affects all stl100-1 models? What also makes you think that BlackBerry even knows about this situation? Have you spoke to someone from the company and they told you they know and are doing nothing?

    Ive read about it a few times, but never to the degree your implying(all stl100-1 models). My Z10 (stl100-3) never charged to 100%, and would shut off at 20% remaining on all the 10.0 OS's. then 10.1 fixed it, and yes I tried all the "solutions" posted in the forums.

    I would think this is a software issue and not an actual hardware issue, reason your not seeing a recall on the device.

    Sounds like a few p*ssed off customers that think their bug affects every device made. I hate to say it, but blame your carriers for carrying whats basically the red headed step child of the STL100 variant.
    Cell Phone History:
    Motorola Bag phone > Motorola Star Tac gen1 > Motorola Star Tac gen 2 > Motorola Razr > BlackBerry Pearl > Iphone gen1 > BlackBerry Curve > BlackBerry Torch > BlackBerry Torch II > BlackBerry Bold 9900 > BlackBerry Z10 > PassPort

    If you think my post helped you, please click the "Thanks" button over there!! -->
  3. chopachain's Avatar
    CrackBerry Abuser

    Posts
    336 Posts
    Thread AuthorThread Author   #3  

    Default

    Quote Originally Posted by homer1475 View Post
    What makes you think this affects all stl100-1 models? What also makes you think that BlackBerry even knows about this situation? Have you spoke to someone from the company and they told you they know and are doing nothing?

    Ive read about it a few times, but never to the degree your implying(all stl100-1 models). My Z10 (stl100-3) never charged to 100%, and would shut off at 20% remaining on all the 10.0 OS's. then 10.1 fixed it, and yes I tried all the "solutions" posted in the forums.

    I would think this is a software issue and not an actual hardware issue, reason your not seeing a recall on the device.

    Sounds like a few p*ssed off customers that think their bug affects every device made. I hate to say it, but blame your carriers for carrying whats basically the red headed step child of the STL100 variant.
    Look seriously this is not something to joke about or to start a war over and attack me. I am genuinely looking for a solution here. If any of my info is incorrect I apologize. I am assuming it is STL100-1 only because these seem to be the only people I found complaining. And no I'm not a pissed off customer or a prophet. My Z30 is a clone software wise and is working flawlessly.
    CeeZ
  4. Deadmunny's Avatar
    CrackBerry Abuser

    Posts
    301 Posts
    #4  

    Default

    I have an STL 100-1, running 10.2.1.1925.
    I bought this phone new from the local carrier for about $600? I have Gone through 3 updates I started* I think* at 10.1.1.4181 or something similar and have never experienced ANY of the battery issues you speak of..sorry, even the much talked about bad battery life for the Z10, I have never had this issue either,(I am convinced because I use a combo holster and therefore my phone's screen is off most of the time I think accounts for my good battery life) that said I concur that it may be a software issue, my 0.02c

    Regards David

    Digicel Jamaica Official10.2.1.1925 release
    Mecca EL likes this.
  5. Andrew4life's Avatar
    CrackBerry Genius

    Posts
    2,869 Posts
    Global Posts
    2,870 Global Posts
    #5  

    Default

    What OS are you on?

    Please update to the newest 10.2 or 10.2.1


    Posted via CB10
    Mecca EL likes this.
  6. zoub91's Avatar
    CrackBerry User

    Posts
    59 Posts
    #6  

    Default

    I have the same problem too
    It never charge to 100%. Am using Z10STL100-1/10.2.1.1925.
    Sometimes am perplexed as the battery goes from 91% to 40% in like 8hrs without using. That is when am sleeping. Sometimes it's hold up to 86 %. I think it's the os.


    Posted via CB10
  7. chopachain's Avatar
    CrackBerry Abuser

    Posts
    336 Posts
    Thread AuthorThread Author   #7  
    CeeZ
    Thanked by:
    RedFoxOne (01-22-2014) 
    RedFoxOne likes this.
  8. dikku11's Avatar
    CrackBerry Abuser

    Posts
    374 Posts
    Global Posts
    376 Global Posts
    #8  

    Default

    Its the OS guys the battery bar or that battery part maybe for other z10 device model so its having problem adjusting itself.I think it will be solved in 10.2.1.
    Mecca EL likes this.
  9. eldricho's Avatar
    CrackBerry Genius

    Posts
    4,747 Posts
    Global Posts
    4,751 Global Posts
    #9  

    Default

    Damn it, thought it was going to say BlackBerry actually recalled the model :P

    I'm still debating whether it's a software or hardware software, seeing as I only occasionally get it on select OS versions.
    Last time I got it was back on .1055, but haven't gotten it since jumping to.1259

    Posted via CB10
    October 2006 - December 2008: Samsung 1310 Flip Phone->December 2008 - December 2009: BB Pearl 8100->December 2009 - March 2013: BB Curve 8520->March 2013 - August 2013: BB Curve 9300->(2013: Bricked 7290)->August 2013+: BB Z10!
    Remember the Thanks Button is just below!
    Mecca EL likes this.
  10. tszasza's Avatar
    CrackBerry Abuser

    Posts
    131 Posts
    #10  

    Default

    very serious issue, almost all the stl100-1 devices are affected here in Hungary...

    after recalibration it starts again... No solution until now: battery switch, change of charger, new OS, factory reset etc nothing helps

    Carriers can not solve the issue, they say we need to launch a service ticket. Than you get your phone back after a while and after a few cycles the issue starts again.

    Support from CB in the direction of BlackBerry would be appreciated!

    Posted via CB10
  11. wilkto's Avatar
    CrackBerry Abuser

    Posts
    156 Posts
    #11  

    Default

    Sorry people, running 10.2.1.1925 leak on STL100-1. No unusual battery issues. Very happy with phone.

    Posted via ZedTen
    Thanked by:
    Anup Z10 (01-22-2014) 
    Mecca EL likes this.
  12. hericstamas's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #12  

    Default

    I solved the problem two times with two different battery on the same mobile. It is after i do a security wipe. Solution for me what is worked on 10.2.1.1925 with stl100-1.
    Let it drain full. After swith off itself, take out the battery for an hour. Then plug the cable and the charger in. But do not plug it to the power. Press the power button for 2 minutes. Put back the battery and plug to power. After a while it powers on itself and it shows 3 percent battery level. Let it charge full. If it does not show 100 percent after it, plug in and out the charger from power while it shows 100.
    I hope it works for you too.

    Posted via CB10
  13. tukiyek's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #13  

    Default

    Mine is STL100-1 and I have been use it for almost 2 months, also had similar problem, battery only last for 3-4 hours. Then I decided to install leak OS to 10.2.1.1925, 'cause some people say this OS has more stable in managing power and it has battery life indicator too. After I installed the indicator shows that my battery could last for 3 days and never goes below 60% then suddenly it shut down. I was looking to forum and searched about Z10 STL 100-1 battery problem and found the answer. I need to re-calibrate my Z10 using this methode:

    1. use your phone until the battery completely empty
    2. remove your battery, sim card and memory card for 30 minutes
    3. charge your phone without battery, sim and memory card
    4. wait until your led turn red and blackberry appears to your screen
    5. put your sim, memory and your battery back to your phone
    6. charge your phone until 100%

    Now my Z10 can last for 10 hours on medium usage (emails, browsing and chatting).
    Thanked by 2:
    RedFoxOne (01-22-2014),  silversmith75 (01-24-2014) 
  14. Anup Z10's Avatar
    CrackBerry User

    Posts
    15 Posts
    #14  

    Default

    Quote Originally Posted by wilkto View Post
    Sorry people, running 10.2.1.1925 leak on STL100-1. No unusual battery issues. Very happy with phone.

    Posted via ZedTen
    Me too, no problem at all. I love my Z10 STL100-1 with 10.2.1.1925

    Posted via CB10
  15. wolexf's Avatar
    CrackBerry User

    Posts
    44 Posts
    Global Posts
    46 Global Posts
    #15  

    Default

    I swapped my battery with a friend and we both stopped having the issue
  16. serbanescu's Avatar
    CrackBerry Master

    Posts
    1,019 Posts
    #16  

    Default

    The battery calibration problem seems to occur when the phone OS underwent a security wipe or an update, while having the battery charged around 50% or bellow this value.

    At least, this was my experience with it.

    I recommend charging the phone to the maximum level possible and, while keeping the phone plugged into the charger, do a security wipe. This is how I solved the problem for my phone.


    --------------------

    Pic Tagger for BB10 and PlayBook
  17. chrizrun30's Avatar
    CrackBerry Abuser

    Posts
    296 Posts
    #17  

    Default

    I also found this as a big problem. I'm running from 10.0, 10.1, 10.2.1.1055 and the latest 10.2.1.1925 and this battery calibration always a problem for my STL100-1.
    Already tried every method I found in this forum, even bought a new battery and this calibration issue never solved.
  18. siddharth's Avatar
    CrackBerry Abuser

    Posts
    171 Posts
    #18  

    Default

    Mine doesn't charge till 100% either, but I've seen it go down till about 10%


    But other than that no problems, battery lasts whole day and more and no sudden deaths


    Posted via Black ZeD on 10.2.1.1925
    Blackberry Bold 9000 : 5.0.0.434
    Blackberry Bold 9700 : 6.0.0.600
    Blackberry Torch 9810 : 7.1.0.1033

    Currently using

    Blackberry Z10 : 10.2.1.1925

    iPhone5S Space Grey 32gig : iOS 7.0.4 Jailbroken \m/
  19. lynxs_claw's Avatar
    CrackBerry Master

    Posts
    1,122 Posts
    Global Posts
    1,126 Global Posts
    #19  

    Default

    Sorry OP if you're having issues, but your title is really deceiving. I thought there was indeed an official recall from Blackberry. The mods should rename the title. Hopefully, Blackberry/Carrier can figure out what's wrong with your device and fix it for you.
    Thanked by:
    kennyiceberry (01-22-2014) 
  20. RedFoxOne's Avatar
    CrackBerry User

    Posts
    86 Posts
    Global Posts
    87 Global Posts
    #20  

    Default

    I've also got the same battery problem.

    White Z10 STL100-1
    Originally loaded with 10.1 : No problems
    Official OTA update to 10.2.0.1767 : Battery and camera problem
    Leaked 10.2.1.1055 : Fixed camera problem, but battery problem still remains.

    Black Z10 STL100-1
    Originally loaded with 10.1 : No problems
    Leaked 10.2.0.1767 : No problems
  21. Shantanu Gupta's Avatar
    CrackBerry User

    Posts
    94 Posts
    #21  

    Default

    I have 3 * STL100-1, 2 * STL100-2 and 1 * SQN100-3. None of those devices have any of the defects you mention. Should you recall your generalisation ? I'd say yes.
    jpvj likes this.
  22. Thrace Ist's Avatar
    CrackBerry User

    Posts
    87 Posts
    #22  

    Default

    Z10 STL 100-1 here in Turkiye.. On 10.2.0.429 Official Update. (I do not use leaks). I love my battery life. 1.5 days average with hard use. Charges upto 100 % in 2 hours and gives alert when below 20%. and does not shut down right after the alerts. Very pleased with the battery.
  23. Thrace Ist's Avatar
    CrackBerry User

    Posts
    87 Posts
    #23  

    Default

    Quote Originally Posted by lynxs_claw View Post
    Sorry OP if you're having issues, but your title is really deceiving. I thought there was indeed an official recall from Blackberry. The mods should rename the title. Hopefully, Blackberry/Carrier can figure out what's wrong with your device and fix it for you.
    I agree. Misleading Title.
  24. chopachain's Avatar
    CrackBerry Abuser

    Posts
    336 Posts
    Thread AuthorThread Author   #24  

    Default

    Quote Originally Posted by Shantanu Gupta View Post
    I have 3 * STL100-1, 2 * STL100-2 and 1 * SQN100-3. None of those devices have any of the defects you mention. Should you recall your generalisation ? I'd say yes.
    How's to post a photo of all six?
    CeeZ
    h20work likes this.
  25. machfive's Avatar
    CrackBerry User

    Posts
    55 Posts
    #25  

    Default

    I have the same problem now.. I have 2 batteries.. One does not charge past 87% it however runs down to zero, the other charges to 100% and shuts off at 60% .. it is important to note that I still get 17+ hrs from both batteries. My issue is that this problem did not exist originally and developed once a new OS was loaded ( leaked or otherwise).. I am yet to find a solution to this issue, however I honestly do not waste a lot of time concerning myself as the battery life has been consistent since I first noticed the problem.. In other words after 13-13 hrs of use I know I will get another 4-5 hrs regardless of the battery reading.. I do not think this is a hardware problem, but more related to the battery itself. If any one can tell me the process to fix the problem I will implement if not, .... oh well still a great phone..

    STL 100-1 running 10.2.1.1925
Page 1 of 3 123 LastLast

Similar Threads

  1. BlackBerry Z10 Docking Station !! original !!
    By Philipp Noller in forum News & Rumors
    Replies: 7
    Last Post: 01-23-2014, 04:07 PM
  2. Using leak .exe file on Sachesi for Mac
    By d987654321 in forum BB10 Leaked/Beta OS
    Replies: 4
    Last Post: 01-22-2014, 11:26 PM
  3. Question/Request for the Crackberry.com moderators!!!
    By d987654321 in forum General BlackBerry Discussion
    Replies: 7
    Last Post: 01-22-2014, 05:22 PM
  4. Replacing Z10 Housing from eBay - Power Button Issue
    By rangelpm in forum BlackBerry Z10
    Replies: 2
    Last Post: 01-22-2014, 05:08 PM

Posting Permissions