Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 25 of 25
Like Tree2Likes
  • 1 Post By bredecks
  • 1 Post By John Pawling
  1. bredecks's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #1  

    Default My Z10 is dead. Will not turn on or charge.

    I really love this phone and it has worked great since getting it from Tmobile on the 26th. Last night before bed phone was fine, no issues. Woke up this morning and it was dead; could not turn it on. Took the battery out for 2 minutes and tried to recharge but nothing. I thought maybe the charger was defective, so I tried it on another device and it worked fine. I have no idea what happened. I'm stuck at work now, but will take it to Tmobile later today. Anyone else have this issue? I've read in previous post that folks with 100-3 devices (I have the same model) have had reboot issues but not this.

    Thanks for your help.
  2. ErinnM's Avatar
    CrackBerry Genius

    Posts
    1,604 Posts
    Global Posts
    1,611 Global Posts
    #2  

    Default

    Can't help but say have TMo give you a new one. Maybe you got a bad phone.

    Posted via Crackberry Z10
  3. John Pawling's Avatar
    CrackBerry Addict

    Posts
    942 Posts
    Global Posts
    945 Global Posts
    #3  

    Default

    Quote Originally Posted by bredecks View Post
    I really love this phone and it has worked great since getting it from Tmobile on the 26th. Last night before bed phone was fine, no issues. Woke up this morning and it was dead; could not turn it on. Took the battery out for 2 minutes and tried to recharge but nothing. I thought maybe the charger was defective, so I tried it on another device and it worked fine. I have no idea what happened. I'm stuck at work now, but will take it to Tmobile later today. Anyone else have this issue? I've read in previous post that folks with 100-3 devices (I have the same model) have had reboot issues but not this.

    Thanks for your help.
    Use BlackBerry Link to reload the OS while the battery is out. Happened to me on my BlackBerry OS7 phone and I believe the same solution can be applied to the BlackBerry OS10 phones.



    Posted Via CB10 on my Zed10
  4. bredecks's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #4  

    Default

    Thanks. Will try that!
    menna34 likes this.
  5. harp666's Avatar
    CrackBerry User

    Posts
    12 Posts
    Global Posts
    20 Global Posts
    #5  

    Default

    I hope your first call was to T-Mobile.....It sounds like your still in the return window..I know for Verizon its 14 days..get it replaced!
  6. russworman's Avatar
    CrackBerry Genius

    Posts
    1,521 Posts
    Global Posts
    1,527 Global Posts
    PIN
    33005276
    #6  

    Default

    This happened on my PlayBook a few times when I let the battery completely drain. It will need to charge for quite a while, maybe ten minutes, and then you should be able to start it up. Might take two attempts before it fully loads up.

    Posted via CB10
  7. bredecks's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #7  

    Default

    So took the phone to a tmobile store and the phone is completely dead. Tried a new battery, which didn't work. I ended up getting a new phone.
  8. jdhooghe's Avatar
    CrackBerry Master

    Posts
    1,299 Posts
    Global Posts
    2,676 Global Posts
    #8  

    Default

    Another quality control issue with BlackBerry. A shame.

    Glad you got a new phone and hopefully this will be better

    Posted via my Zee10
  9. zten's Avatar
    Banned

    Posts
    2,410 Posts
    Global Posts
    2,420 Global Posts
    #9  

    Default

    I hope it's not like when the 9900's bricked over night during September and October of 2011.

    Posted via CB10
  10. John Pawling's Avatar
    CrackBerry Addict

    Posts
    942 Posts
    Global Posts
    945 Global Posts
    #10  

    Default

    Quote Originally Posted by jdhooghe View Post
    Another quality control issue with BlackBerry. A shame.

    Glad you got a new phone and hopefully this will be better

    Posted via my Zee10
    In any electronic device there are failure rates hence the reason most carriers give you 14 days to handle the situation.

    Glad that the OP got a replacement

    Posted Via CB10 on my Zed10
    ErinnM likes this.
  11. mikamay's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #11  

    Default

    I have had 7 devices that went dead on me in 3 months. I am waiting for my 8th device from tmobile. I do not know what is going on but I have had the same issue after issue with device not powering up. I have tried everything, spoke with BB tech and T mobile tech and their is no solution. I will be upgrading soon and leaving BB alone. I had such high hopes. Disappointed.
  12. scrannel's Avatar
    CrackBerry Genius

    Posts
    4,516 Posts
    Global Posts
    4,531 Global Posts
    #12  

    Default

    Quote Originally Posted by mikamay View Post
    I have had 7 devices that went dead on me in 3 months. I am waiting for my 8th device from tmobile. I do not know what is going on but I have had the same issue after issue with device not powering up. I have tried everything, spoke with BB tech and T mobile tech and their is no solution. I will be upgrading soon and leaving BB alone. I had such high hopes. Disappointed.
    Uh, say what? You living next to the Fukushima power plant?
  13. xlncpk's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #13  

    Default

    I have same issue. Last night I have charged my BB Z10 with charger whole night. New update 10.2.1... was in process. But now in morning device is dead. No sign of power is available. I hold the power button but nothing happen. Kindly Help........................................
  14. manonthemoon's Avatar
    CrackBerry Abuser

    Posts
    317 Posts
    Global Posts
    332 Global Posts
    #14  

    Default

    Quote Originally Posted by bredecks View Post
    I really love this phone and it has worked great since getting it from Tmobile on the 26th. Last night before bed phone was fine, no issues. Woke up this morning and it was dead; could not turn it on. Took the battery out for 2 minutes and tried to recharge but nothing. I thought maybe the charger was defective, so I tried it on another device and it worked fine. I have no idea what happened. I'm stuck at work now, but will take it to Tmobile later today. Anyone else have this issue? I've read in previous post that folks with 100-3 devices (I have the same model) have had reboot issues but not this.

    Thanks for your help.
    Yeah same thing happened to me. AT&T and BlackBerry got me a new Z10. No issues with this one for past 9months or so.

    Posted via CB10
  15. Doggerz's Avatar
    CrackBerry Genius

    Posts
    1,737 Posts
    Global Posts
    1,752 Global Posts
    #15  

    Default

    Man. The old Motorola StarTAC phones were built to last. They were the best.

    Posted via CB10
  16. Granrey's Avatar
    CrackBerry Addict

    Posts
    544 Posts
    PIN
    288EAD16
    #16  

    Default

    Quote Originally Posted by Doggerz View Post
    Man. The old Motorola StarTAC phones were built to last. They were the best.

    Posted via CB10
    that phone had the led light in the right location. you could have the phone on your belt and you could see notification colors without grabbing the phone. its hard to believe how such nice feature is gone.
  17. Trini-34's Avatar
    CrackBerry Addict

    Posts
    682 Posts
    #17  

    Default

    I am experiencing the same thing today. My Z10 would not turn on or charge. The battery is charged but cannot turn on the device. I see the resolution is to return it to TMo./carrier. Thank you!
  18. #18  

    Default

    Quote Originally Posted by Trini-34 View Post
    I am experiencing the same thing today. My Z10 would not turn on or charge. The battery is charged but cannot turn on the device. I see the resolution is to return it to TMo./carrier. Thank you!
    Try the RESET

    Try a restart:

    Press and HOLD both Vol Up/Down buttons. Keep holding while the screen goes fully black (ignore the screenshot), keep holding through the Black/White logo and when the Colored Logo shows up, release those buttons.

    If you have the STL100-1 variant the volume button reset method doesn't work. In that case, Press and HOLD the Power On Button until you see the LOGO as above
  19. rex43204's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #19  

    Default

    I am about to receive my 5th BBZ10 in seven months. My carrier is Verizon and the phone was part of one of their plans. So these refurbished Z10's they give out are not reliable. The problem I have is that they will not give me a different model, just keep sending another Z10 every month or so. Calling tech or customer support is useless at either BB or Verizon. They point the finger at each other and tell me it not their problem. Service to the customer does not exist at these companies.
  20. badiyee's Avatar
    CrackBerry Master

    Posts
    1,227 Posts
    Global Posts
    1,234 Global Posts
    PIN
    24E867DB
    #20  

    Default

    just curious, are those all Z10 STL-100-1?
  21. rex43204's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #21  

    Default

    The latest is STL 100-4.
  22. grass_hunter's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #22  

    Default

    Hi there, I am having the same issue with my Z10 STL100-3. My carrier is Bell, both Bell and the insurance company have no clue what to do but keep sending me refurbished phones. My Z10 wont find any networks or charge the battery. I have since changed to the Passport but would love to use my Z10 as aback up when travelling. Any and all help is needed.
  23. yeo123's Avatar
    CrackBerry Addict

    Posts
    522 Posts
    #23  

    Default

    Z10 connect usb cable to PC and reload leaked OS .battery capacity must has power for restart. good luck.

    Posted via CB10
  24. Andy Porter's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #24  

    Default

    Mine died too and led flashes red once pauses then flashes red six times pauses and repeats but won't turn on no matter what.have moved on to a new phone and provider but still think the z10 camera is the best quality I've seen
  25. Rustybronco's Avatar
    CrackBerry Master

    Posts
    1,327 Posts
    Global Posts
    1,330 Global Posts
    #25  

    Default

    ^^
    Find yourself a Z10 battery that's partially charged and swap it with the one that's in the phone currently.

    Posted from my smashed screen Z30

Similar Threads

  1. Z10 Camera Flash?? Will not turn on
    By 1REDRUM in forum BlackBerry Z10
    Replies: 8
    Last Post: 05-03-13, 01:13 AM
  2. My Blackberry Bold 9000 Will not turn on
    By joemoes in forum BlackBerry Bold 9000
    Replies: 2
    Last Post: 06-19-10, 08:03 AM
  3. Help my BB curve 8300 will not turn on
    By sumfamily4 in forum BlackBerry Curve 83xx
    Replies: 1
    Last Post: 10-04-09, 05:03 PM
  4. Blackberry will not turn on, battery is good
    By jepj30 in forum BlackBerry Pearl 8100
    Replies: 6
    Last Post: 03-18-09, 11:02 AM
  5. My Blackberry Curve 8330 will not turn on :(
    By Flounder20 in forum BlackBerry Curve 83xx
    Replies: 1
    Last Post: 02-21-09, 10:44 PM

Posting Permissions