Page 1 of 2 12 LastLast
Results 1 to 25 of 31
Like Tree1Likes
  1. nicole2013's Avatar
    CrackBerry User

    Posts
    64 Posts
    Thread AuthorThread Author   #1  

    Default How to get mail to delete, as opposed to archive?

    So I have been happily deleting emails from my gmail account on my bb10 for weeks now. Or so I thought. I logged into my email account on the computer only to discover that my z10 is archiving my emails as opposed to flat out deleting them.

    Is there a way to change this in the settings? I could not find one. Any help appreciated. Thanks!
  2. Bdot-1's Avatar
    CrackBerry Genius

    Posts
    1,942 Posts
    #2  

    Default

    I heard that there is no option to do this on Z10 in a thread I read a couple weeks back. Same goes with hotmail and others. But I may be mistaken now if someone else can clarify.

    I could on my 9860, what about Android and ios?
  3. nicole2013's Avatar
    CrackBerry User

    Posts
    64 Posts
    Thread AuthorThread Author   #3  

    Default

    I am a former iphone user, and I was able to delete completely. I suppose I can file to Trash, but that's so many more steps than should be necessary.
  4. Morten's Avatar
    CrackBerry Master

    Posts
    1,181 Posts
    PIN
    ask nicely
    #4  

    Default

    My best suggestion if you use gmail, is to make a folder/label called something like "@Deleted mail"

    and from your phone - instead of delete - just Move the emails to that folder, so they are removed from the Hub

    then you can empty that folder whenever you want using your computer
  5. xamdam's Avatar
    CrackBerry Genius

    Posts
    3,051 Posts
    Global Posts
    3,056 Global Posts
    #5  

    Default

    For Hotmail when u delete on phone it sends to your delete folder online.

    Z10 I am using.

    As for Gmail I forget as I do not use that email much, but I think u correct it archives it.

    Posted via CB10, BB10, Z10
    New Phone: Iphone 4s, Old Phones: Blackberry Z10, Samsung Galaxy S3 (Sold), Iphone 4 (Used By Family)
    LTE Playbook 32gb (Dec 2012), OS version is 1753.
    On Rogers Service

    "When in doubt, buy a laptop"
  6. dracolnyte's Avatar
    CrackBerry Master

    Posts
    1,022 Posts
    #6  

    Default

    i just tried it and i can confirm that it goes to archive.
    Bold 9000 -> iPhone 5 -> White Z10
    Playbook 16GB
  7. makaveli86's Avatar
    CrackBerry Abuser

    Posts
    402 Posts
    #7  

    Default

    I had this issue A while back and came up with a fix. Search my post history and u will find it.

    If not I'll come back tmr during the day and I'll link the thread where I posted the fix. It's a pretty simple fix

    Posted via CB10
  8. nicole2013's Avatar
    CrackBerry User

    Posts
    64 Posts
    Thread AuthorThread Author   #8  

    Default

    Yes I found this thread: email deleted on Z10 but stays on Gmail

    Have tried the recommended fix and it seems to be working. Thanks everyone! Now if only I could get my calendar to sync, I would be a happy camper.
    EastMcCauley likes this.
  9. ubizmo's Avatar
    CrackBerry Genius

    Posts
    2,948 Posts
    Global Posts
    3,110 Global Posts
    PIN
    79ac4611
    #9  

    Default

    Ideally, we'd want to be able to choose whether to delete or archive from the device. Is there a way to do this?
  10. Jerry A's Avatar
    CrackBerry Abuser

    Posts
    325 Posts
    Global Posts
    348 Global Posts
    #10  

    Default

    This is a Gmail-ism that's existed for quite a bit. Nothing you can change on the phone. Go to Google Sync from the phone's browser and check the box for "Enable Delete Email As Trash For This Device."

    That's assuming you've configured via ActiveSync.

    If you're using IMAP, then you'll need to change your Gmail settings: Official Gmail Blog: New in Labs: Advanced IMAP Controls
  11. makaveli86's Avatar
    CrackBerry Abuser

    Posts
    402 Posts
    #11  

    Default

    Quote Originally Posted by nicole2013 View Post
    Yes I found this thread: email deleted on Z10 but stays on Gmail

    Have tried the recommended fix and it seems to be working. Thanks everyone! Now if only I could get my calendar to sync, I would be a happy camper.
    What os version are you on?
    What's ur carrier?
    Cuz the calendar sync issue is fixed In the updated os
  12. nicole2013's Avatar
    CrackBerry User

    Posts
    64 Posts
    Thread AuthorThread Author   #12  

    Default

    On the latest OS (10.0.10.85), with Telus. My calendar only syncs one way... if I add an event on my phone it will show up in my Google cal, but if I add an event on the computer, as well as any existing events in my GC, it does not appear on my phone. I have tried everything (different methods of adding the calendar, deleting, re-adding) and I just cannot get it to work. I have given up.
  13. EastMcCauley's Avatar
    CrackBerry User

    Posts
    96 Posts
    #13  

    Default

    Quote Originally Posted by nicole2013 View Post
    Yes I found this thread: email deleted on Z10 but stays on Gmail

    Have tried the recommended fix and it seems to be working. Thanks everyone! Now if only I could get my calendar to sync, I would be a happy camper.
    Why not just use the mobile version of the calendar in Google? Works great.

    Posted via CB10 on BlackBerry Z10
  14. AkashRuhela's Avatar
    CrackBerry User

    Posts
    66 Posts
    #14  

    Default

    I have played around with this and have the SOLUTION!!

    Log onto your Gmail account from your computer's Internet browser and go to your settings. In your settings click on the imap tab and change the setting to "Do not expunge Automatically." and then also change the setting under that to a setting that says something about moving deleted mail to trash. Save that and switch over to the Labels tab and look for the All Mail check boxes and un check the Show in IMAP option. This should get it working correctly. Just remember there is about a 15 - 20 min delay as to how everything is updated on the server when you do something on your phone. Hope this helps.

    Posted via CB10
  15. torpesco's Avatar
    CrackBerry Abuser

    Posts
    151 Posts
    #15  

    Default

    Ah - that's what I need to try. Showing all mail in IMAP. I've never turned it off, and had it once before on a desktop client, though, so was surprised to not see it on my phone. I created my own "@ archive" label for archiving from my phone, so delete is delete.

    Posted via CB10
  16. torpesco's Avatar
    CrackBerry Abuser

    Posts
    151 Posts
    #16  

    Default

    Wait... Un-check 'show in IMAP' for all mail? What is the goal of doing that?

    I want some way to both archive and delete. Since when I try to file to trash I get an error saying I can't, I have gmail set for IMAP delete to move messages to the trash folder. 'All Mail' doesn't appear in my folder list on the Z10, hence my hack of making an '@ archive' label.

    Posted via CB10
  17. AkashRuhela's Avatar
    CrackBerry User

    Posts
    66 Posts
    #17  

    Default

    You have to remove All Mail from IMAP otherwise the mail gets moved to the All Mail folder on Gmail due to their basic IMAP properties.

    Posted via CB10
  18. torpesco's Avatar
    CrackBerry Abuser

    Posts
    151 Posts
    #18  

    Default

    Wow. I see what you mean now. Definitely some wrinkles for BlackBerry to iron out. My 9790 handled this just fine. Disconnected my PlayBook from the account, so can't comment on what it does. Although the way I did things on the PlayBook was delete to archive and move to trash to actually delete...

    Posted via CB10
  19. nicole2013's Avatar
    CrackBerry User

    Posts
    64 Posts
    Thread AuthorThread Author   #19  

    Default

    Ok. So this expunge /trash/imap thing we are talking about actually did not work for me. Sigh.

    Posted via CB10
  20. makaveli86's Avatar
    CrackBerry Abuser

    Posts
    402 Posts
    #20  

    Default

    Nicole try this link and see what you see. You should enable the calendars you want

    www.google.com/calendar/syncselect

    Are you waiting for the calendars to actually sync? It's not instant there is a delay

    As for the imap thing basically if you want email to go to the trash label then disable auto expunge and choose the 2nd option under it I can't remember the words exactly. Then go to the labels tab to the left and disable all mail from showing up in imap by un checking it under the imap heading. Now when u delete it won't go to archive (what I call limbo) it will have a trash label and won't be in 'all mail'. I can't search my post history at the moment but this is the gist of it. It's a mess to search through this stuff in the forums I find lol but the post I made was from a few weeks ago maybe. It was in someone else's thread related to this issue as well.

    Posted via CB10
  21. makaveli86's Avatar
    CrackBerry Abuser

    Posts
    402 Posts
    #21  

    Default

    Here's the thread I'm talking about
    Email Deletion / Hub email options

    Note as I said the Gmail emails with the yellow tabs highlighted dont seem to be marked as trash. They still go to limbo aka archive.

    I would just create a new label called archive and move everything you want to keep to that label. This labels thing kinda annoying with Gmail having no actual folders lol

    Posted via CB10
  22. SDTRMG's Avatar
    CrackBerry Genius

    Posts
    2,113 Posts
    Global Posts
    2,119 Global Posts
    #22  

    Default

    I have this same problem, but it also happens on my iPad so its nothing to do with the z10 and more apple and icloud
  23. makaveli86's Avatar
    CrackBerry Abuser

    Posts
    402 Posts
    #23  

    Default

    It's how Google and Gmail works from what I can tell. It works ok on my iPhone because it was set up using exchange active sync before Google disabled it for non paying users. I suspect the poster who said it works fine on the older BlackBerry is not using imap as well as this issue is only with imap from what I've seen.

    Posted via CB10
  24. xtremesniper's Avatar
    CrackBerry Abuser

    Posts
    351 Posts
    #24  

    Default

    I did what everyone suggested, to no avail. All my mail, regardless of yellow tab or not, goes to archived after I delete from my phone. Really wish I could just "file" the email into "trash". Doesn't even let me do that.
  25. makaveli86's Avatar
    CrackBerry Abuser

    Posts
    402 Posts
    #25  

    Default

    Quote Originally Posted by xtremesniper View Post
    I did what everyone suggested, to no avail. All my mail, regardless of yellow tab or not, goes to archived after I delete from my phone. Really wish I could just "file" the email into "trash". Doesn't even let me do that.
    Did u disable all mail label from being seen in imap On a computer in gmail settings? Also have to disable auto expunge and enable the 2nd option as I posted in the thread I linked.
Page 1 of 2 12 LastLast

Similar Threads

  1. BB10 to launch in late q1 as oppose to early Q1
    By amjass12 in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 10-09-2012, 08:33 AM
  2. How do i send text as opposed to email?
    By santa2512 in forum BlackBerry Torch 9810
    Replies: 1
    Last Post: 11-27-2011, 03:47 AM
  3. How to get mail on my blackberry
    By Mike333 in forum General BlackBerry Discussion
    Replies: 6
    Last Post: 01-28-2009, 09:04 AM
  4. Replies: 6
    Last Post: 07-21-2008, 11:37 PM
  5. "Device Software" (as opposed to Desktop Manager Software)
    By NevadaDad in forum BlackBerry Pearl 81xx
    Replies: 23
    Last Post: 02-26-2008, 08:25 AM

Posting Permissions