Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
Like Tree1Likes
  • 2 Post By njblackberry
  1. SMCNI1968's Avatar
    CrackBerry User

    Posts
    31 Posts
    Thread AuthorThread Author   #1  

    Default Charging Z10

    Anybody have an issue plugging the Z10 in and it not starting to show the yellow charging symbol immediately? I seems occasionally I have to pull the charger out and insert it again to get it to come up.

    Thanks.
  2. Lendo's Avatar
    Retired Moderator

    Posts
    6,818 Posts
    Global Posts
    7,025 Global Posts
    #2  

    Default

    Some have said, it can take up to a minute for the charge to begin. Try waiting next time to see if it does start, and if not maybe take the charger back.
  3. FBA
    FBA is offline
    FBA's Avatar
    CrackBerry Genius

    Posts
    1,637 Posts
    Global Posts
    2,465 Global Posts
    #3  

    Default

    Known issue and there's a KB on it at the BBRY support site. Happens when you plug the charger in too slowly.
  4. DawgMan's Avatar
    CrackBerry Genius

    Posts
    2,076 Posts
    Global Posts
    2,079 Global Posts
    PIN
    T of Moonshine Please.
    #4  

    Default

    I've noticed that same issue. Also noticed that the charging cable must be inserted straight into the charging port on the Z10. Mine had a little play and wouldn't charge


    Posted via CB10
  5. SentFromMyBlackberry's Avatar
    CrackBerry User

    Posts
    10 Posts
    #5  

    Default

    I have the same issue. It's nice to know that it's not just me.

    I was at work and plugged it in assuming it was charging and an hour later I checked only to see it didn't charge any.

    Also happened before I went to sleep and I use my berry as an alarm. Good thing there was enough charge.

    Now I wait and check to see it charging before i leave it. Could my phone be defective? It does this with different oem chargers. If it doesn't charge immediately I have to pull it out then plug it in a few times. Sometimes it works immediately sometimes it doesn't.

    Posted via CB10
  6. njblackberry's Avatar
    Banned

    Posts
    2,947 Posts
    Global Posts
    3,100 Global Posts
    #6  

    Default

    Here's the KB article since no one posted it in this thread -> KB33636-BlackBerry 10 smartphone does not charge when plugged into a wall charger

    Certainly sounds a lot like the "You're Holding The Phone Wrong" issue that another company tried to pawn off.
  7. big samm's Avatar
    CrackBerry Abuser

    Posts
    447 Posts
    #7  

    Default Re: Charging Z10

    Yup same here it, there's a little delay for the little yellow bolt to show up i would say 5 to 10 secs...

    Sent from my Nexus 7 3G
  8. Cap_172R's Avatar
    CrackBerry Genius

    Posts
    2,405 Posts
    Global Posts
    2,528 Global Posts
    #8  

    Default

    Thanks guys! thought something was wrong for a minute...

Similar Threads

  1. Charging Cradle for the Blackberry Z10?
    By Sam Cully in forum BlackBerry 10 Accessories
    Replies: 9
    Last Post: 04-25-13, 09:26 AM
  2. Bedside mode while charging z10
    By CzechShark in forum BlackBerry Z10
    Replies: 6
    Last Post: 02-11-13, 08:59 PM
  3. How long should the initial charge for my Z10 be?
    By adinx in forum BlackBerry Z10
    Replies: 14
    Last Post: 02-06-13, 07:06 AM
  4. Charging Pod For Z10?
    By CCR601 in forum BlackBerry Z10
    Replies: 9
    Last Post: 02-01-13, 12:37 PM
  5. Z10/X10 Charging Dock Contacts?
    By dangerousfen in forum General BlackBerry Discussion
    Replies: 11
    Last Post: 12-30-12, 05:03 AM

Posting Permissions