Results 1 to 9 of 9
  1. day-cee's Avatar
    CrackBerry User

    Posts
    58 Posts
    Thread AuthorThread Author   #1  

    Default Charging problems

    When I plug my Z10, one out of two times, it won't charge, I need to unplug and plug again til I see the little lightning on the top left!

    Any body have that problem?

    Posted via CB10
  2. clmazda's Avatar
    CrackBerry Abuser

    Posts
    114 Posts
    #2  

    Default

    Yeah same here, but since the update it doesn't do it anymore!
  3. #3  

    Default

    Give it a few seconds, the update fixed the issue, but until you get it, the charging icon takes a few seconds to come on, even if the phone is charging. Don't unplug it thinking it's not charging right away.
  4. BoldBigWorm's Avatar
    CrackBerry Addict

    Posts
    509 Posts
    #4  

    Default

    Plug it in the phone first then plug it into the outlet. After a few charges you will be fine. It takes a few seconds to see the bolt when you plug it into the phone first.


    Posted via CB10
  5. day-cee's Avatar
    CrackBerry User

    Posts
    58 Posts
    Thread AuthorThread Author   #5  

    Default

    OK thanks

    Posted via CB10
  6. Cap_172R's Avatar
    CrackBerry Genius

    Posts
    2,390 Posts
    Global Posts
    2,405 Global Posts
    #6  

    Default

    The problem occurs if there is a delay inserting the charger into the micro usb port. If done in a continuous motion it works like a charm (then a couple seconds later the charge indicator, appears on the battery icon). See post for further details/reference (its the one that helped me)

    Quote Originally Posted by njblackberry View Post
    Here's the KB article since no one posted it in this thread -> KB33636-BlackBerry 10 smartphone does not charge when plugged into a wall charger

    Certainly sounds a lot like the "You're Holding The Phone Wrong" issue that another company tried to pawn off.
  7. vespesian's Avatar
    CrackBerry Abuser

    Posts
    134 Posts
    #7  

    Default

    I think part of the problem is that the micro-usb connector that comes with the z10 is sooo tight, that it can be hard to plug in accurately (straight, all the way). I bought a replacement usb/micro-usb cord (from CB) and, lo and behold, it connects waay better than the one included in the retail package, and it seems much sturdier. Weird.
  8. darkehawke's Avatar
    CrackBerry Genius

    Posts
    3,371 Posts
    Global Posts
    3,379 Global Posts
    #8  

    Default

    Quote Originally Posted by clmazda View Post
    Yeah same here, but since the update it doesn't do it anymore!
    exactly this here too
    Primary Device: Moto X
    Backup Device: Blackberry Z10
  9. quattro.pilot's Avatar
    CrackBerry User

    Posts
    67 Posts
    #9  

    Default

    Yup, same instance for me too... hasn't really been rectified on my phone since the 10.0.10.168 update. The charging indication also hangs on for waaaay after it actually shows 100%, often I don't get the transition to the "plug" symbol.

Similar Threads

  1. Battery Charging Problems
    By mhousealum in forum BlackBerry Pearl 81xx
    Replies: 34
    Last Post: 04-13-2011, 05:22 PM
  2. charging problems
    By mash in forum BlackBerry Pearl 81xx
    Replies: 8
    Last Post: 04-03-2011, 12:04 AM
  3. Charging Problems
    By MeanieBeanie in forum BlackBerry 71xx Series
    Replies: 3
    Last Post: 04-08-2008, 07:30 AM
  4. Usb Cable Charging Problem
    By SFJenn in forum BBOS Phone Accessories
    Replies: 10
    Last Post: 03-28-2008, 04:45 PM
  5. Charging problem!!!
    By tommy1879 in forum BlackBerry 8830 WE
    Replies: 12
    Last Post: 03-27-2008, 12:05 PM

Posting Permissions