Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
Like Tree3Likes
  • 1 Post By nothin2seehere
  • 1 Post By Omnitech
  • 1 Post By Omnitech
  1. nothin2seehere's Avatar
    CrackBerry Abuser

    Posts
    263 Posts
    Global Posts
    266 Global Posts
    Thread AuthorThread Author   #1  

    Default Cannot connect to Enterprise WPA

    Hi all

    Just got my Z10 here at work where we use an Enterprise WPA2 WiFi network. Unfortunately it won't connect. It gets to "Attempt 1 of 3 - Associating" and eventually times out after about 1 minute with an error (generic "Connection attempt timed out"). I have full signal, and my Android phone connects in a few seconds.

    The only way I could get through the first time setup was to create a wireless Hotspot on my other phone and connect to that.

    Any ideas on how to find out the support for this?

    Thanks

    n2c
  2. richbayliss's Avatar
    CrackBerry User

    Posts
    54 Posts
    Global Posts
    55 Global Posts
    #2  

    Default

    Could it be certificates? WPA2 requires certs on the handset in order to connect I believe and the BB10 ones may be missing a few??
  3. nothin2seehere's Avatar
    CrackBerry Abuser

    Posts
    263 Posts
    Global Posts
    266 Global Posts
    Thread AuthorThread Author   #3  

    Default

    Replying to my own post. From my networks people:

    The presence of the Wi-Fi direct == enabled capability flag in the beacon frames for the SSID prevents the device associating. Removing the capability flag lets it associate and get an IP address.

    Our kit is made by Cisco - not sure of the exact part numbers.
    Last edited by nothin2seehere; 02-04-2013 at 07:49 AM. Reason: Clarifying the fix.
    cjcampbell likes this.
  4. nothin2seehere's Avatar
    CrackBerry Abuser

    Posts
    263 Posts
    Global Posts
    266 Global Posts
    Thread AuthorThread Author   #4  

    Default

    Quote Originally Posted by richbayliss View Post
    Could it be certificates? WPA2 requires certs on the handset in order to connect I believe and the BB10 ones may be missing a few??
    It certainly used to be the case with the older BB OS 6 and earlier I think. I had to sync a Verisign cert to the device which was a very tedious process as I'm sure you know
  5. richbayliss's Avatar
    CrackBerry User

    Posts
    54 Posts
    Global Posts
    55 Global Posts
    #5  

    Default

    Seems like you may have your culprit already - but I just created a WPA2 Enterprise setup myself and connected with a user/password fine. So I think it may be something specific to your setup rather than a general feature issue.

    Update the thread, maybe others will have this problem...
  6. nothin2seehere's Avatar
    CrackBerry Abuser

    Posts
    263 Posts
    Global Posts
    266 Global Posts
    Thread AuthorThread Author   #6  

    Default

    Thanks richbayliss.

    I agree it is something to do with our config, but I doubt I'm going to be able to convince the team to change a setting on all the APs that might have negative consequences for other users.

    No, I'm going to have to contact Blackberry and log a support call, and somehow avoid being told to turn it off and on again, reset to defaults, change password, try different users etc
  7. Omnitech's Avatar
    Banned

    Posts
    10,593 Posts
    Global Posts
    10,601 Global Posts
    #7  

    Default

    Would be interested to see what becomes of this.
  8. polgara59's Avatar
    CrackBerry Abuser

    Posts
    214 Posts
    #8  

    Default

    How do you disable checking certificates in the Z10? That's what I need to do to connect to our WPA2Enterprise network. I was able to do that with my 9800 Torch, but can't find where to do that on my Z10.

    Any ideas?
  9. Omnitech's Avatar
    Banned

    Posts
    10,593 Posts
    Global Posts
    10,601 Global Posts
    #9  

    Default

    Quote Originally Posted by polgara59 View Post
    How do you disable checking certificates in the Z10? That's what I need to do to connect to our WPA2Enterprise network. I was able to do that with my 9800 Torch, but can't find where to do that on my Z10.

    Any ideas?
    If you disable certificate checking, you ruin the security model. It's like disabling the antivirus on your computer because you don't like it telling you that your subscription is expired.
  10. polgara59's Avatar
    CrackBerry Abuser

    Posts
    214 Posts
    #10  

    Default

    But I need to do that in order to connect to our network. I didn't create the dawn thing; I'm just trying to connect to it.
  11. Omnitech's Avatar
    Banned

    Posts
    10,593 Posts
    Global Posts
    10,601 Global Posts
    #11  

    Default

    If it's failing due to certificate checking because your company is using WPA-2 Enterprise with x.509 certificates, the proper way to get it working is to import your company's Radius server SSL certificate into the device, if your company is using an internal certificate authority. (If it were a traditional public CA, the certificate would be recognized automatically.)

    In legacy BBOS, there were I believe 3 main ways to import an SSL cert: via a special function in Desktop Manager/Blackberry Desktop, via an LDAP server, or via an email message.

    In BB10, there is a page in security settings where certificates can be imported, I don't have a detailed document but here is a page that shows a screenshot:

    Import Certificates on the bb10 device - BlackBerry Support Community Forums

    Here is what page 45 of the Z10 user guide says:

    If you use PEAP, EAP-TLS, EAP-FAST, or EAP-TTLS to connect to a Wi-Fi network, check that you installed the root
    certificate for the certificate authority server that created the certificate for the authentication server. The root
    certificate must be installed on your device before you can connect to the network. For more information, talk to your
    administrator.
    If you use EAP-TLS to connect to a Wi-Fi network, check that you installed your authentication certificate on your
    device. The authentication certificate must be installed on your device before you can connect to the network. For
    more information, talk to your administrator.
    Thanked by 2:
    aziandevil (03-27-2013),  polgara59 (02-09-2013) 
    polgara59 likes this.
  12. Omnitech's Avatar
    Banned

    Posts
    10,593 Posts
    Global Posts
    10,601 Global Posts
    #12  

    Default

    Here are some other links to discussions and documentation about importing SSL certs. The process seems to be similiar (perhaps not identical) to the one used on the Playbook:

    Re: Self-signed Certificates - BlackBerry Support Community Forums

    KB26515-How to import security certificates on the BlackBerry PlayBook

    Security Certificates for Your BlackBerry PlayBook - For Dummies
    Thanked by 2:
    aziandevil (03-27-2013),  polgara59 (02-09-2013) 
    polgara59 likes this.
  13. polgara59's Avatar
    CrackBerry Abuser

    Posts
    214 Posts
    #13  

    Default

    Okay, I did some more checking. The instructions for personal laptops to connect to our network says to uncheck "Validate server certificate." I'm not going to get any help from our IT guys because they only support iPhones. My Playbook works in our network, but for the life of me, I can't remember what I did to get it to work (that was almost 2 years ago!).

    The network is, as noted by Omnitech (thanks for your advice!), WPA2-Enterprise, subtype PEAP, inner link Auto. On my Playbook, I have no CA certificates or VPN profiles selected. It automatically obtains IP address and allow inter-access point handover.

    On my 9800, I was able to disable certificate validation for this network, which then allowed me to connect to our work network.

    In the grand scheme of things, I can live without a wifi connection on my phone at work, but it *would* be nice to have if I can figure it out (with some help from some very bright people here at Crackberry, of course!).
  14. Omnitech's Avatar
    Banned

    Posts
    10,593 Posts
    Global Posts
    10,601 Global Posts
    #14  

    Default

    Quote Originally Posted by polgara59 View Post
    The instructions for personal laptops to connect to our network says to uncheck "Validate server certificate."
    Hah, well if that's what your I.T. people are saying, I guess they aren't that serious about security anyway. Pity I don't know how to turn that off on the Z10 since it doesn't appear to be in the manual and I can't get one here yet.


    Quote Originally Posted by polgara59 View Post
    I'm not going to get any help from our IT guys because they only support iPhones. My Playbook works in our network, but for the life of me, I can't remember what I did to get it to work (that was almost 2 years ago!).
    Figures on the iPhone thing. No wonder they have no idea how anything else works.


    Quote Originally Posted by polgara59 View Post
    The network is, as noted by Omnitech (thanks for your advice!), WPA2-Enterprise, subtype PEAP, inner link Auto. On my Playbook, I have no CA certificates or VPN profiles selected. It automatically obtains IP address and allow inter-access point handover.
    Good to know. If I find out anything more I'll try to remember to post it here.
    Thanked by:
    polgara59 (02-09-2013) 
  15. polgara59's Avatar
    CrackBerry Abuser

    Posts
    214 Posts
    #15  

    Default

    Got it figured out and was able to connect to the work wife today. I went back and dug deeper into the settings on my PlayBook and my 9800, kept playing and finally got it to work!

    Thanks for the advice!

    Posted using CrackBerry App on BB10
  16. Omnitech's Avatar
    Banned

    Posts
    10,593 Posts
    Global Posts
    10,601 Global Posts
    #16  

    Default

    Quote Originally Posted by polgara59 View Post
    Got it figured out and was able to connect to the work wife today. I went back and dug deeper into the settings on my PlayBook and my 9800, kept playing and finally got it to work!

    Thanks for the advice!
    Glad you got it working. So do you remember where the setting was, by chance, for the benefit of other people with that issue?
  17. level's Avatar
    CrackBerry User

    Posts
    58 Posts
    Global Posts
    59 Global Posts
    #17  

    Default

    I seem to be having the same issue. Care to share any more information for the settings that worked?

    Thanks
    Bold 9000/Bold 9700/Bold 9900
    Focus/GSII
  18. nothin2seehere's Avatar
    CrackBerry Abuser

    Posts
    263 Posts
    Global Posts
    266 Global Posts
    Thread AuthorThread Author   #18  

    Default

    Friend just picked up a Q10. Connects to the wireless just fine. Still cannot get my Z10 connected even with the 10.1 firmware.

    FYI, the certificates are not internally signed, but from a public CA.
  19. Omnitech's Avatar
    Banned

    Posts
    10,593 Posts
    Global Posts
    10,601 Global Posts
    #19  

    Default

    Quote Originally Posted by nothin2seehere View Post
    Friend just picked up a Q10. Connects to the wireless just fine. Still cannot get my Z10 connected even with the 10.1 firmware.

    FYI, the certificates are not internally signed, but from a public CA.

    Quite strange that your friend with a Q10 can connect and you can't even with 10.1. Weird...
  20. nothin2seehere's Avatar
    CrackBerry Abuser

    Posts
    263 Posts
    Global Posts
    266 Global Posts
    Thread AuthorThread Author   #20  

    Default

    It's utterly bizarre. I can't believe the hardware is software is so different.. I might try a factory reset. My z10 is hardly customised anyway.

Similar Threads

  1. Cannot connect to the internet
    By funkymunky in forum BlackBerry Pearl 8100
    Replies: 2
    Last Post: 02-13-2008, 07:37 PM
  2. Cannot connect to Outlook/Exchange
    By sjthomp in forum BlackBerry 87xx Series
    Replies: 3
    Last Post: 12-14-2007, 10:40 PM
  3. Cannot connect to desktop
    By Trevor in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 11-06-2007, 03:09 PM
  4. Curve on AT&T cannot connect to Yahoo Mail anylonger
    By awm62 in forum BlackBerry Curve 83xx
    Replies: 4
    Last Post: 08-30-2007, 01:12 PM
  5. cannot connect to App Loader
    By bbfan1 in forum Business Users
    Replies: 3
    Last Post: 08-08-2007, 11:15 AM

Posting Permissions