Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 29
  1. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #1  

    Default Battery cm won't charge fully - charges 88% only

    My Z10 would go off at 50%. Pulled the battery and sim, left them out for an hour. Problem solved.

    New problem now: battery won't charge fully. It stops charging at 88%.

    Any and all suggestions appreciated.

    Thanks in advance.

    Posted via CB10
  2. djdragon's Avatar
    CrackBerry Addict

    Posts
    875 Posts
    #2  

    Default

    Don't ever pull the battery.

    Plug in the charger and turn shut off the phone while it's still plugged in. Wait till the red led turns green for a full charge. Problem fixed.

    Z10 10.2.0.1767 via CB10
    _________________________________________
    No such thing as a stupid question, only stupid answers.

    BBM Channel C0006F5A6
  3. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #3  

    Default

    Thanks DJ. I'll do as you suggested.

    In the mean time keep the suggestions coming.

    Posted via CB10
  4. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #4  

    Default

    Will post what happens after doing just what you suggested.

    Posted via CB10
  5. Baseball619's Avatar
    CrackBerry Abuser

    Posts
    339 Posts
    #5  

    Default

    Quote Originally Posted by djdragon View Post
    Don't ever pull the battery.

    Plug in the charger and turn shut off the phone while it's still plugged in. Wait till the red led turns green for a full charge. Problem fixed.

    Z10 10.2.0.1767 via CB10
    For the record, there's nothing technically wrong with pulling the battery if your phone isn't running anything.

    But if you're really paranoid about battery pulls, just manually power off your phone first and THEN pull the battery.

    Posted via CB10
    BlackBerry Curve 8330 / BlackBerry Torch 9860 / BLACKBERRY Z10
    Twitter: @_JohnRich / @_JaysHub
    http://www.JaysHub.org
  6. itsberryway's Avatar
    CrackBerry User

    Posts
    19 Posts
    #6  

    Default

    I had the same issue.

    For the next 2-3 times let the mobile drain the battery completely and turn off automatically.
    Then plug the charger and charge it till you see the full charge icon (this is when you don't see the lightning on the battery icon).
    Doing this for a couple of time has fixed the issue for me.

    Good luck

    Posted via CB10
  7. itsberryway's Avatar
    CrackBerry User

    Posts
    19 Posts
    #7  

    Default

    Quote Originally Posted by djdragon View Post
    Don't ever pull the battery.

    Plug in the charger and turn shut off the phone while it's still plugged in. Wait till the red led turns green for a full charge. Problem fixed.

    Z10 10.2.0.1767 via CB10
    I feel it's correct, I got into this problem when I was switching my SIM card between my old 9300 and new z10 with a few battery pulls.

    Posted via CB10
  8. tushargkwd's Avatar
    CrackBerry Addict

    Posts
    869 Posts
    PIN
    2AB5733F
    #8  

    Default

    It will go to 100% just be patient and it will improve in time.
    I had same issues.. its a known bug in STL 100-1

    Posted via the awesome keyboard on Z10STL100-1/10.2.0.1791 using CB10 App
    Flick typing on BB10 is awesome... and so is the Hub... pure addction
    --------------------------------------------------------
    Z10 STL100-1 10.2.1.2228 (2229 Radio), BlackBerry PlayBook 32, Samsung Omnia i900 WM6.5 (Retired)
  9. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #9  

    Default

    Thanks guys, I'll try it all. Please keep the suggestions coming.

    Posted via CB10
  10. djdragon's Avatar
    CrackBerry Addict

    Posts
    875 Posts
    #10  

    Default

    Quote Originally Posted by Baseball619 View Post
    For the record, there's nothing technically wrong with pulling the battery if your phone isn't running anything.

    But if you're really paranoid about battery pulls, just manually power off your phone first and THEN pull the battery.

    Posted via CB10
    For the record you're wrong. Swapping the battery after a power down or a pull in fact resets the charge counter and battery data thus making the OS repopulate the data and causing the device to resettle in. One of the reasons why the Z30 doesn't have a removable battery.

    Z10 10.2.0.1767 via CB10
    _________________________________________
    No such thing as a stupid question, only stupid answers.

    BBM Channel C0006F5A6
  11. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #11  

    Default

    did what DJ suggested. 7 hours on charge and the LED didn't turn green. It kept blinking in orangish color sign that it is still charging. Switched on the phone and found out it wasn't charging at all. Fully charged sign but as usual at 88%.

    Will try the second suggestion now. Drain the battery until it goes off automatically then charge it to see if it works.

    Posted via CB10
  12. sinlessearth's Avatar
    CrackBerry Addict

    Posts
    572 Posts
    Global Posts
    680 Global Posts
    #12  

    Default

    Quote Originally Posted by machangezi View Post
    did what DJ suggested. 7 hours on charge and the LED didn't turn green. It kept blinking in orangish color sign that it is still charging. Switched on the phone and found out it wasn't charging at all. Fully charged sign but as usual at 88%.

    Will try the second suggestion now. Drain the battery until it goes off automatically then charge it to see if it works.

    Posted via CB10
    What OS version are you on?
  13. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #13  

    Default

    OS 20.1.0.4181

    Posted via CB10
  14. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #14  

    Default

    Sorry

    OS 10.1.0.4181

    Posted via CB10
  15. Marko M1's Avatar
    CrackBerry Abuser

    Posts
    399 Posts
    #15  

    Default

    Do OS update ASAP. See after that what happens.
    Blackberry 8100 -> 9700 -> 9900 -> Z10 STL100-2 + Nokia E71
    Somebody asked you bribe? Report them anonymously on BribeSpot.com
  16. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #16  

    Default

    No update available in Thailand yet. Besides I read apps go crashing after update.

    Posted via CB10
  17. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #17  

    Default

    Ok I have fully drained the battery as suggested and charged it. It still charges up to 88%. Will drain and charge a few more times to see if it fixes the problem.

    Anyone with more ideas on how to go about fixing this issue please post here.

    Posted via CB10
  18. sybarite_abhi's Avatar
    CrackBerry User

    Posts
    23 Posts
    Global Posts
    25 Global Posts
    #18  

    Default

    Okay here's the solution. at least the one which worked for me. When ur phone charged by 88% and the battery meter shows its full charged, take out the battery and insert the charger WITHOUT BATTERY for 10-15 minutes. Take out the charger, insert the battery and Whoa !!! u r done.....!!! Now it may be the temporary solution. So now with battery inserted switch off the phone and plug in the charger and wait till its green. Ur ph battery and indicator are aligned now
  19. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #19  

    Default

    I'll give it a try. Thanks for suggestion buddy.

    Keep the suggestions coming chaps.

    Posted via CB10
  20. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #20  

    Default

    Sybarite, did as you suggested. Now my battery charges all the way to 98%! Thanks buddy.

    The problem is no matter how long I keep the phone on charge )left it for 2 4 hrd) the LED won't turn green. It keeps charging (orangish blinks). When I switch it on, the electric bolt isn't there. Shows fully charged but the battery meter (battery guru) is at 98%.



    Posted via CB10
  21. djdragon's Avatar
    CrackBerry Addict

    Posts
    875 Posts
    #21  

    Default

    You really need to update to 10.2.0.1791

    Z10 10.2.0.1791 via CB10
    _________________________________________
    No such thing as a stupid question, only stupid answers.

    BBM Channel C0006F5A6
  22. sybarite_abhi's Avatar
    CrackBerry User

    Posts
    23 Posts
    Global Posts
    25 Global Posts
    #22  

    Default

    I guess u r on STL-100 and its the common problem for this version. Also to tell u this process does not work for me . Every day my Z10 shows from 62-88 % anything in between after fully charged and when restart goes to 90-98 %. My only hope is 4500 Mah battery I've ordered from US and which will be in my hand by tmrw or day after and then only my life will be more exciting and tension free.
  23. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #23  

    Default

    Sybarite, how's it going with the new battery? Any good?

    Posted via CB10
  24. machangezi's Avatar
    CrackBerry User

    Posts
    24 Posts
    Thread AuthorThread Author   #24  

    Default

    The curse is back! My battery doesn't charge past 77%. I M on OS 10.2. Everything was fine before.

    Any fix guys?

    Posted via CB10
  25. zackiyulfuad's Avatar
    CrackBerry User

    Posts
    24 Posts
    #25  

    Default

    Reconnect charger and recharge in airplane mode. It will continue to 100%

    Posted via CB10
Page 1 of 2 12 LastLast

Similar Threads

  1. Battery drain
    By mpjheating in forum BBM on Android
    Replies: 44
    Last Post: 01-01-2014, 08:25 AM
  2. Battery drained on my Q10!!!
    By alex3A in forum BlackBerry Q10
    Replies: 8
    Last Post: 10-29-2013, 07:43 PM
  3. now if only BBM would come to the playbook
    By jonassabatini in forum General BBM Chat
    Replies: 5
    Last Post: 10-23-2013, 01:35 PM
  4. Bbm won't work on new iOS just released by apple
    By RHDJEEZY in forum General BlackBerry Discussion
    Replies: 7
    Last Post: 10-22-2013, 07:09 PM

Posting Permissions