Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
  1. nonthasit's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #1  

    Default my Bold 9700 unlocked but still wont work on any sim card in canada

    i brought my blackberry bold 9700 from hong kong through ebay so its said already unlocked and i checked on network it also said disabled. so i try in on telus sim card, bell , and rogers it wont work it show SOS on the top conner. please give me the solution to solve this problem please.
  2. dictoresno's Avatar
    CrackBerry Genius of Geniuses

    Posts
    8,850 Posts
    Global Posts
    9,254 Global Posts
    #2  

    Default

    sounds like the phone is indeed unlocked, just the wrong frequencies. once you insert SIM card and boot up a locked phone, it will ask you for the MEP code.

    you may be in an HSPA only area that doesnt offer EDGE. the 9700 you have may not have the proper 3G bands to accommodate this. doesnt Telus only have 3G only coverage in some spots with no EDGE to fall back on?? this would lead to the exact problem you are having. goto options > about. tell us what 3G bands you show listed. the bands you need are 1,2,5,6. one from overseas may be different, and will prevent you from accessing the network frequencies you need. your only option then will be to sell or trade it for a proper one.
  3. freethisberrydotcom's Avatar
    CrackBerry Genius

    Posts
    3,110 Posts
    #3  

    Default

    Have you tried switching it to 2G in mobile network options?
  4. nonthasit's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #4  

    Default

    i check on option-about and at 3G bands it show 1,4,8 .also when i boot up the phone it never ask me for MEP . I already tried change it to 2g i still show up SOS on top right conner but if i change it to 3G it show up no service
  5. sjsplaty's Avatar
    CrackBerry Abuser

    Posts
    208 Posts
    Global Posts
    213 Global Posts
    #5  

    Default

    1,4,8 bands are the AWS bands that Wind and Videotron use in Canada, and T-Mobile uses in the US.
  6. nonthasit's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #6  

    Default

    so what is that mean
  7. SwitchBeach's Avatar
    CrackBerry Genius

    Posts
    2,734 Posts
    Global Posts
    3,074 Global Posts
    #7  

    Default

    Try a SIM card from Wind Mobile.
  8. dictoresno's Avatar
    CrackBerry Genius of Geniuses

    Posts
    8,850 Posts
    Global Posts
    9,254 Global Posts
    #8  

    Default

    Quote Originally Posted by nonthasit View Post
    so what is that mean
    it means exactly what i said, you dont have the correct bands on your phone that your provider uses.
  9. freethisberrydotcom's Avatar
    CrackBerry Genius

    Posts
    3,110 Posts
    #9  

    Default

    Videotron, Wind, & Mobilicity use the same frequencies.
  10. unlockcellpro's Avatar
    CrackBerry Addict

    Posts
    563 Posts
    #10  

    Default

    If your still not happy with those carriers, try contacting the seller on ebay and ask to return the item i am sure they are flexible and given ebay’s rules will allow the return.
  11. Abdullahh121212's Avatar
    CrackBerry User

    Posts
    22 Posts
    #11  

    Default

    it also handels Orange network...i have the same problem, i bought a phone from orange in Uk, went to my country, got it unlocked completely...now i am here for UNI and when i tried vodafone sim card it dint work....I am not telling my mom that if i buy an Orange sim card for 1 pound it will work...so that she buys me the bold 9900 :P
  12. freethisberrydotcom's Avatar
    CrackBerry Genius

    Posts
    3,110 Posts
    #12  

    Default

    Good trade.
  13. Viera001's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #13  

    Default

    I had the same problem too, the sim card not work. I have BB 9320 from Indonesia (asia) which unluck already but the sim card didnt work just show me SOS in the right corner. I tried switch to 2G and 3G but still not work. I used sim card from Koodo company. I am very frustration. pls give me advice. merci

Posting Permissions