Page 1 of 3 123 LastLast
Results 1 to 25 of 70
  1. buylowsellhigh's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Thread AuthorThread Author   #1  

    Default Can't Make Calls: Sim Toolkit Control Error (Unlocked Bold)

    I have a Unlocked AT&T BOLD and I'm having some trouble with foreign SIM card here in Taiwan. I bought a Taiwan Mobile SIM Card (TW Mobile also offer BB Bolds). I inserted it into my ATT BOLD and couldn't make any calls. I get the following Error Message:

    Sim: Call Barred
    Call failed due to SIM Toolkit Control Error

    My phone was unlocked by AT&T; I told them I'm going overseas and they unlocked it free of charge by giving me unlock codes. I do have a non-BIS data plan but with the "data" turned off (just using voice version).

    I have latest firmware, already did a reset (battery out a few seconds). SIM card seems to be latest one since I just bought it a few hrs ago. Anyone have any ideas? The Bold was my favorite phone thus far but has been slipping down the list because of all these "international" issues I'm having. Thanks
  2. wickedgtr1's Avatar
    CrackBerry User

    Posts
    17 Posts
    #2  

    Default

    What does it say on the phone when you:

    Menu -> Options -> Advanced Options -> Sim Card:


    And at Sim Card Menu -> mepd
  3. buylowsellhigh's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Thread AuthorThread Author   #3  

    Default

    All says disabled.
  4. quadp's Avatar
    CrackBerry User

    Posts
    13 Posts
    #4  

    Default

    anyone have a fix for this? i am in the exact same position. .and it is frustrating....

    using unlocked at&t bold in fido in canada..
    please help if anyone has a working solution!
  5. #5  

    Default

    Sounds like AT&T unlocks might not work properly but you don't find out until you're away from home and test it. Yet another reason not to buy phones from AT&T.
  6. superben79's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #6  

    Default

    i had the same issue. and i resolved it. so it is doable.
  7. suzieY's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #7  

    Default

    SuperBen79 -- how did you resolve it?

    The AT&T phone I bought does not work with 2 SIMs from Rogers. One is an older card (July 2008) and other just bought today.

    This is really frustrating for me as I travel internationally a lot and need an unlocked phone.
  8. motavi's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #8  

    Default

    I am facing this same problem. everything says disabled. how do I enable it?
  9. motavi's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #9  

    Default

    i have tried everything from changing sim cards to wiping device, reinstalling OS. When I put my sim card in another bold, it can send off smses on a 3g network but not mine.

    Mine is an unlocked ATT bold. I am thinking ATT has blocked it but I can get 3G with the bb sign and data no problem. receiving smses are fine just cannot send out! but on edge, gsm and gprs i can send out no problem.

    can someone help as this is driving me crazy.

    thanks!
  10. aka.arj's Avatar
    CrackBerry Abuser

    Posts
    270 Posts
    PIN
    -
    #10  

    Default

    U could try unbranding ur fone and then giving the new sim a go..

    Posted from my CrackBerry at wapforums.crackberry.com
  11. giantfan30's Avatar
    CrackBerry Genius

    Posts
    1,533 Posts
    #11  

    Default

    Quote Originally Posted by Branta View Post
    Sounds like AT&T unlocks might not work properly but you don't find out until you're away from home and test it. Yet another reason not to buy phones from AT&T.


    i'm curious as to the logic in this statement
    elaborate please?
    Stupidity is a circumstance that can't be helped. ignorance is a choice
  12. koby ben simon's Avatar
    CrackBerry User

    Posts
    30 Posts
    #12  
  13. giantfan30's Avatar
    CrackBerry Genius

    Posts
    1,533 Posts
    #13  

    Default

    Quote Originally Posted by motavi View Post
    i have tried everything from changing sim cards to wiping device, reinstalling OS. When I put my sim card in another bold, it can send off smses on a 3g network but not mine.

    Mine is an unlocked ATT bold. I am thinking ATT has blocked it but I can get 3G with the bb sign and data no problem. receiving smses are fine just cannot send out! but on edge, gsm and gprs i can send out no problem.

    can someone help as this is driving me crazy.

    thanks!
    when you switched sim cards did any of you bother registering your device on the network you got the sim card from or did you just slap it in and expect everything to just magically work?
    did you get any service books from the new network you are on?
    try calling the Network you got the sim from and setting up BIS or if you dont want BIS just call the network and see what it is that you need to do to use the Bold on their network
    does the network you're trying to connect to support Blackberry devices?
    Stupidity is a circumstance that can't be helped. ignorance is a choice
  14. Spawn12's Avatar
    CrackBerry Genius

    Posts
    3,493 Posts
    Global Posts
    3,495 Global Posts
    #14  

    Default

    Quote Originally Posted by giantfan30 View Post
    when you switched sim cards did any of you bother registering your device on the network you got the sim card from or did you just slap it in and expect everything to just magically work?
    did you get any service books from the new network you are on?
    try calling the Network you got the sim from and setting up BIS or if you dont want BIS just call the network and see what it is that you need to do to use the Bold on their network
    does the network you're trying to connect to support Blackberry devices?
    Ermm you dont need BB services to make a simple call or text lol...i have an unlocked Bold from Tmobile here in the UK and all i do is just shove another networks sim card in and away i go...i dont need to use the BB services of another network to get it to make a simple call or text....fine if i was using data then yes i would have to but i dont have the BB symbol on the unlocked Bold and it works perfectly well.
  15. motavi's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #15  

    Default

    Quote Originally Posted by giantfan30 View Post
    when you switched sim cards did any of you bother registering your device on the network you got the sim card from or did you just slap it in and expect everything to just magically work?
    did you get any service books from the new network you are on?
    try calling the Network you got the sim from and setting up BIS or if you dont want BIS just call the network and see what it is that you need to do to use the Bold on their network
    does the network you're trying to connect to support Blackberry devices?
    Yes. I registered my sim card and resent my service books. BIS works fine.

    When I stuck in my friend's prepaid sim card, there was no data but 3g connection and I could send out. When I put my sim card back in same problem, can receive but cannot send out. Really really strange.
  16. vicsohi's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #16  

    Default Same problem

    I have the same problem. My phone is a AT&T phone unlocked and cant make call. I can send and receive text msg. any one help

    Sim: Call Barred
    Call failed due to SIM Toolkit Control Error
  17. motavi's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #17  

    Default

    I am still having this problem. receive sms ok, send out cannot. sim tool kit error. calls in and out ok. this is just on the 3g network. edge/gsm/gprs all working fine.
  18. #18  

    Default

    The indications here http://forums.crackberry.com/f83/cal...israel-186512/ suggest a SIM card incompatibility could be responsible.
  19. motavi's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #19  

    Default

    Thing is I tried that already but will try to get a replacement again.
  20. Jvaf's Avatar
    CrackBerry Addict

    Posts
    644 Posts
    #20  

    Default

    try a 3G simcard..
  21. motavi's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #21  

    Default

    FINALLY got it solved. It was the SIM card. Got a replacement (2nd time), it was a new batch I think and now no problems.
  22. motavi's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #22  

    Default

    it was funny 'cause when I got a replacement, it was a 3G sim card. but now it is all solved. man it was frustrating though!!
  23. HefnerG's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    #23  

    Default

    so wait your at&t phone works now? who is your service with?
  24. HefnerG's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    #24  

    Default

    can someone help me this is soooo frustrating that i cant use my phone and make outgoing calls
  25. HefnerG's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    #25  

    Default

    Motavi
    this question is mainly directed to you
Page 1 of 3 123 LastLast

Posting Permissions