11-15-11 07:27 PM
32 12
tools
  1. jelp2's Avatar
    I called VZ today for a replacement Torch due to screen issue. I remember a little while back so.done had an issue where the screen looked as if it had water damage. Mine just started showing up and then it would disappear. This happened a few time over the past couple of weeks. I realized whenever I came in front outside is when it would happen. It starting to get cooler where I live and it appears the weather is causing the problem. As soon as my Torch reaches room temp the screen would be perfect. Anyone else have any similar issues?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-01-11 09:03 PM
  2. DannyJK's Avatar
    My guess is something happens to the bonding agent that glues the digitizer to the plastic front panel when it reaches a certain temperature.

    Just a guess however, however, I doubt water could have entered the phone and ended up in the center of the screen like I have seen with people with this problem..

    Its most likely what I have said. Its actually common on devices with plastic screens that cover the LCD.

    Hope the new phone is better.
    11-02-11 02:33 AM
  3. John_Hey's Avatar
    I have got exact same issue twice in past week. Looks like water under screen in the middle.
    I happened when temperature was low - I live in Toronto. (between 0-5 C)
    Both cases it disappeared when the phone warmed up. (like I hold it on my face to get my body heat)

    Please report if you have this issue (we may get more as we enter winter) and we should get a replacement phone.
    11-02-11 08:33 AM
  4. ad19's Avatar
    I have the same issue, and I am also in Toronto.
    11-02-11 09:07 AM
  5. jelp2's Avatar
    I have a replacement on the way.. Other than the screen issue everything else works great. No button problems like others have reported, so now Im wondering if I should keep my phone if the screen issue is a common problem and not risk getting a replacement which could have the same problem along with new ones?!?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-11 09:55 AM
  6. bacon612's Avatar
    Yup, also having this issue. In Toronto as well. Suppose it makes sense that colder conditions are causing this.

    Perhaps this is why my touchscreen is not as accurate as I'd like it to be? Bad batch of phones?
    11-02-11 10:03 AM
  7. pjcloninger's Avatar
    I'm in Tennessee and have experienced the same issue with the screen. On all occasions, the phone was in a cooler climate when it happened.

    I just wonder if it is something I should return the phone for??

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-11 12:19 PM
  8. jelp2's Avatar
    So I put my phone in the fridge for about a minute and it duplicated the issue. I think everyone should try it to determine if it is just a bad batch of phones or if it is a hardware flaw. Remember the temp in a refrigerator is about 40 degrees, so there will be no harm to your phone......unless you spill milk or anything on it!

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-11 01:33 PM
  9. John_Hey's Avatar
    I did the exact same thing and left my phone in fridge for 5 minutes.
    .... and the watermark was there. (it went away after few minutes when the phone reached room temperature)

    Please test your phone and post the result here.
    11-02-11 02:28 PM
  10. tiffany2's Avatar
    I have the issue when I come in from the cold
    11-02-11 05:04 PM
  11. burnrubber's Avatar
    The only concern I would have with this is that over time the moisture/water spot would eventually leave a permanent water spot/stain as that is the nature of water.
    11-02-11 06:04 PM
  12. jelp2's Avatar
    The only concern I would have with this is that over time the moisture/water spot would eventually leave a permanent water spot/stain as that is the nature of water.
    That's why I called for a replacement. The issue itself doesn't cause any immmediate problems, but who knows if it will progressivley get worse.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-11 08:19 PM
  13. tiffany2's Avatar
    That's why I called for a replacement. The issue itself doesn't cause any immmediate problems, but who knows if it will progressivley get worse.

    Posted from my CrackBerry at wapforums.crackberry.com
    I was not so lucky when I called, my rep wouldn't do anything but suggest I take it to a corporate store ( which I don't have one in my area )
    11-02-11 08:59 PM
  14. burnrubber's Avatar
    That's why I called for a replacement. The issue itself doesn't cause any immmediate problems, but who knows if it will progressivley get worse.

    Posted from my CrackBerry at wapforums.crackberry.com
    One thing else to be concerned about is that if indeed it's water/moisture if you have a unrelated problem with the phone and take it in for repair the water dye markers inside the phone might turn color and the tech could say sorry there is water damage so your phone is not covered under warranty
    11-02-11 09:12 PM
  15. jelp2's Avatar
    I don't think its actually water or moisture. That's just the best way to describe the issue. The dye markers are normal and I've never got the phone wet or even near moisture. As DannyJk mentioned in an earlier post, it could be a bonding agent between screens.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-02-11 10:23 PM
  16. Scooter68's Avatar
    Mine does the Same thing! in Toronto too, I would say it looks like a film of oil in the center, warming up gets rid of it.

    I also coach a lot of hockey and notice that when coming off the ice my bb screen is very unresponsive. Many typing errors and many times won't type the pressed key until i warm it up. (very frustrating)

    This does not give me hope for a long cold winter!
    11-03-11 08:18 AM
  17. Janye's Avatar
    I live in Newfoundland and we have had cold temp and snow. I have not seen this issue yet and hope it don't happen to mine.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-03-11 09:46 AM
  18. jelp2's Avatar
    I live in Newfoundland and we have had cold temp and snow. I have not seen this issue yet and hope it don't happen to mine.

    Posted from my CrackBerry at wapforums.crackberry.com
    That could be promising and mean it's just a bad batch of phones rather than a design flaw.

    ***Jayne, I just noticed you have the 9800, this issue seems to be limited to the 9850/60.
    Last edited by jelp2; 11-03-11 at 10:43 AM.
    11-03-11 10:40 AM
  19. jelp2's Avatar
    Well I got my replacement 9850 today,(refurbished) and put it right into the refridgerator with my old one. NO Screen issue!!!! I have 5 days to return the old one, so I'm going to wait it out to see what happens.
    11-03-11 01:23 PM
  20. SEAWARRIOR's Avatar
    mine does this,,, made in mexico,,, bought it @ best buy but have sprint service,,, who should i see abt a replacement?
    11-03-11 07:24 PM
  21. SEAWARRIOR's Avatar
    can't they just replace the screen ?
    11-03-11 07:27 PM
  22. bacon612's Avatar
    Do you notice any differences in screen sensitivity/accuracy?
    11-03-11 08:20 PM
  23. jelp2's Avatar
    No difference in touch screen sensitivity/accuracy. Everything seems in line with my original. Both units were made in Mexico. I can't believe they have refurbished stock already.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-03-11 10:50 PM
  24. blackberry-unlocking710's Avatar
    Can you people please post where your device is made in... i see that many Mexico made devices are defect...
    11-04-11 05:26 PM
  25. jelp2's Avatar
    Here's another update.....so after receiving my replacement 9850 yesterday and putting it in the refridgerator for a minute and not seeing the screen issue I thought all was well. This morning I decided to try again. After a minute or so all looked good. I shut the door and left it there only meaning for another minute. My wife opened the door 35minutes later and said, you have your phone on the fridge again ? I told her I forgot it was in there and went to take it out....and there was a small screen issue, not as bad as my original and disappeared very fast. Almost as soon as I took it out.
    So maybe its a design flaw that must be lived with? I work outside all year around and a 40 degree refrigerator is warmer than most days in the winter.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-04-11 07:12 PM
32 12
LINK TO POST COPIED TO CLIPBOARD
";