Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By Zach Gilbert
  1. joshua delaware's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #1  

    Question 9810 will not store messages older than 14 days since updating to OS 7.1

    Hi - I have set it to keep messages forever, yet after 14 days old message (Yahoo, Hotmail, text messages, etc) are getting deleted. This started when I updated to 7.1 a few months ago. Any thoughts on how to stop this?
    Thanked by:
    Stump3r (12-18-2012) 
  2. Zach Gilbert's Avatar
    CrackBerry Abuser

    Posts
    127 Posts
    Global Posts
    136 Global Posts
    #2  

    Default

    Hey Joshua,

    You could try going into your email account settings and seeing what it is set to. BlackBerry gives you the option to show messages from the sat X amount of days. To do so go into the email in box, hit the BlackBerry menu key and select options. from the options screen you will want to select "Message Display and Actions", now scroll to the bottom and look for the option that says "keep messages for". How many days does it say?
    Zach Gilbert

    Twitter: @Zachgilbert

    Doing my best to help you get the most out of your BlackBerry!
    Thanked by:
    Stump3r (12-18-2012) 
    Stump3r likes this.
  3. Stump3r's Avatar
    CrackBerry User

    Posts
    71 Posts
    Global Posts
    139 Global Posts
    #3  

    Default

    Thanks to Joshua for the post and Zach for the cure! I had the same problem and totally forgot about finding the fix for it. Crackberry rocks!
  4. joshua delaware's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #4  

    Default

    Hi - sorry for the delayed response. It says 'forever' when I go into that menu. I am having the same problem with text messages as well.
  5. go1ndr's Avatar
    CrackBerry Genius

    Posts
    2,503 Posts
    Global Posts
    2,509 Global Posts
    #5  

    Default

    Quote Originally Posted by joshua delaware View Post
    Hi - sorry for the delayed response. It says 'forever' when I go into that menu. I am having the same problem with text messages as well.
    Hi OP and everyone! What the "forever" means is that YOU have elected to leave your messages on your server until YOU decided to remove them. You should do the same for your calendar options as well or they will delete after the default which I think is 90 days. For calendar, go to your calendar and then push the menu button (dots) and click on options. Once on options you will see the same message with "forever" as an option. Pick "forever".
    To remove them at a time of your choosing, you open your message folder (email or text) and highlight the messages you want to delete (you can highlight as many as you want at one time by holding down the shift key and scrolling down the list). It then gives you a choice of deleting on the handheld or both the handheld and server at the same time. If you click both, it will remove it from your mail server and you will not be able to pick it up on your pc if you use your computer for email as well. We leave all messages on our server as we need access to them from all of our devices. Good luck and I hope this helps.
  6. joshua delaware's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #6  

    Default

    Hi go1indr. Thanks for the response but this does not respond to my issue. My issue is that the messages only stay on my phone for 14 days. I would like them to stay on forever, but have no idea how to make that happen, despite the fact that I have forever marked.

    Thanks.
  7. go1ndr's Avatar
    CrackBerry Genius

    Posts
    2,503 Posts
    Global Posts
    2,509 Global Posts
    #7  

    Default

    I'm sorry my response didn't help. Unfortunately, other than the reply I posted, the only thing I can think to do is from the home screen, click the BB Menu Button and click on the option: "Show All Icons", then escape back. Once that is done, you will see a "Message Folder" that contains all of your messages, including emails (all accounts) and text messages. Open the Message folder and do as posted above--Options>Message Display>check forever on the box and save. Then from Home Screen menu, uncheck the "show all icons" command and that may save it. If that doesn't work I have no idea how to change it. The (text)Messages folder doesn't have the option to save on its option's page, only on the email options and calendar options so I hope this works fo you. Mine is set up like that and it works great. Good luck and let us know how it goes.

Similar Threads

  1. Help me retain messages older than 5 days
    By gordonbleu in forum BlackBerry PlayBook
    Replies: 2
    Last Post: 05-01-2012, 12:00 AM
  2. Is there a way to receive messages older than 30 days?
    By EdS817 in forum BlackBerry PlayBook
    Replies: 3
    Last Post: 03-05-2012, 08:45 AM
  3. bbm will not send messages
    By angoosemcgoose in forum Native BlackBerry OS Apps
    Replies: 10
    Last Post: 11-02-2010, 02:30 PM
  4. Messages older than xx days not auto deleting
    By CaitlinMF in forum BlackBerry Tour 9630
    Replies: 7
    Last Post: 01-28-2010, 04:35 AM
  5. Outlook rule applies, redirector will not forward message.
    By dr.zed in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 04-08-2008, 06:25 AM

Posting Permissions