Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By anon5129477
  1. D Mac's Avatar
    CrackBerry Addict

    Posts
    953 Posts
    Global Posts
    1,012 Global Posts
    Thread AuthorThread Author   #1  

    Default 9810 Dissassembly/Reassembly issues

    I just swapped out the full housing on my 9810 (OMG removing the screen and digitizer is difficult) and now it won't turn on.

    So obviously odds are I ruined it but any opinions or advice as to what the issue may be would be very much appreciated.

    Details:
    -Worked fine previously.
    -Full housing swap so Everything was disassembled and reassembled.
    -Now when I put the battery in the red light comes on for 5 seconds, goes off for 30 seconds, and then repeats forever.
    -Battery is fully charged, I tested it on my other 9810.

    Everything I have seen online suggests that the slow flashing of the red light suggests a software issue, but based on the circumstances it is most likely hardware related.

    Ideas? Thoughts?
    Click on the link below for some great free Blackberry Themes

    The Theme Zone
    http://thethemezone.blogspot.com
  2. anon5129477's Avatar
    CrackBerry Addict

    Posts
    744 Posts
    Global Posts
    919 Global Posts
    #2  

    Default

    we cant help. As a technician for a living I can tell you your best option is to take the thing apart again and look for errors. Reassemble and look for chances to screw up. Dont screw up this time!
    kozmo68 likes this.
  3. D Mac's Avatar
    CrackBerry Addict

    Posts
    953 Posts
    Global Posts
    1,012 Global Posts
    Thread AuthorThread Author   #3  

    Default

    Quote Originally Posted by Motorhead777 View Post
    we cant help. As a technician for a living I can tell you your best option is to take the thing apart again and look for errors. Reassemble and look for chances to screw up. Dont screw up this time!
    Thanks I'm gonna try that tonight. The problem is I am sure everything is assembled properly.

    Is it possible that a little dust in one of the connecters would cause that issue? Or perhaps if the heat gun damaged the screen would that cause it?

    I think I might take apart my other 9810 and swap the components 1 by 1 to try to figure it out.
    Click on the link below for some great free Blackberry Themes

    The Theme Zone
    http://thethemezone.blogspot.com
  4. Lawmen23's Avatar
    CrackBerry Abuser

    Posts
    197 Posts
    Global Posts
    344 Global Posts
    #4  

    Default

    just did mine last week. Replaced digitizer, reassembled and had the same problem...except I knew what it was. While using brute force to pry the glued in LCD away from the body, I accidentally cut the LCD ribbon. Reassembled anyway and slow pulse red light was the outcome. Ordered a new LCD, complete disassemble and reassemble again and I'm back up and running. I think something is just not plugged in properly.
  5. D Mac's Avatar
    CrackBerry Addict

    Posts
    953 Posts
    Global Posts
    1,012 Global Posts
    Thread AuthorThread Author   #5  

    Default

    Great thanks! I'll check the screen connection.
    Click on the link below for some great free Blackberry Themes

    The Theme Zone
    http://thethemezone.blogspot.com
  6. Andrew4life's Avatar
    CrackBerry Genius

    Posts
    2,747 Posts
    Global Posts
    2,748 Global Posts
    #6  

    Default

    I've taken apart my 9810 before so I could replace the digitizer. Luckily I didn't have to replace the LCD screen or something like that, those would have been to remove. This was also done without the proper torx screw drivers. I think I had the proper one for the first few big torx screws, but had to use a flat head and/or pliers with the smaller ones.
    Anyway, yes, the digitizer and screen are really hard to put together, I would definitely check all connections. You likely just have something not connected properly.
  7. D Mac's Avatar
    CrackBerry Addict

    Posts
    953 Posts
    Global Posts
    1,012 Global Posts
    Thread AuthorThread Author   #7  

    Default

    I took it completely apart again and reassembled it. I made sure all the connections were secure.

    It still won't turn on.

    Anyone want to buy a 9810 cheap?
    Click on the link below for some great free Blackberry Themes

    The Theme Zone
    http://thethemezone.blogspot.com
  8. #8  

    Default

    When I took mine apart, the problem I encountered was I had tightened the screws too much.
    Unlocked Rogers Z10 STL100-3 10.3.0.700 / Unlocked Bell Q10 SQN100-1 10.2.1.3247

Similar Threads

  1. Torch 9810 Issues report
    By sqa4life in forum BlackBerry Torch 9810
    Replies: 16
    Last Post: 12-12-2012, 11:03 AM
  2. 9810 Battery Life Issues
    By DTyrrell22 in forum BlackBerry Torch 9810
    Replies: 30
    Last Post: 09-14-2012, 02:12 PM
  3. 9810 Trackpad Issues
    By leo122 in forum BlackBerry Torch 9810
    Replies: 13
    Last Post: 08-24-2012, 03:29 PM
  4. Torch 9810, T-mobile issues
    By joelo_pr in forum BlackBerry Torch 9810
    Replies: 17
    Last Post: 10-26-2011, 08:42 PM
  5. Torch 9810 Headphone Jack Issues
    By jpmorbital in forum BlackBerry Torch 9810
    Replies: 2
    Last Post: 10-15-2011, 01:20 AM

Posting Permissions