1. yz450gn's Avatar
    my S2's screen started clicking very loud earlier today, it sounded like a crackling or crunching sound. it keeps doing this on and off now.
    has anyone else ever had this problem? how did you fix it?
    any help is appreciated
    04-24-10 04:42 PM
  2. aven's Avatar
    my replacement clicks extremely loud and it takes alot of pressure to click...i requested another one
    04-24-10 05:00 PM
  3. yz450gn's Avatar
    well, if i pull the battery it works fine... but it comes back

    it is like a metallic double clicking noise, very frustrating.... if i lock the phone and push screen i dont hear anything... so maybe a software issue or something is loose somewhere


    running the .607 software
    04-24-10 07:24 PM
  4. markhunsaker's Avatar
    I had a crunchy screen and I asked for a new replacement. I was told that the crunchy sound was becasue the glue was faulty between the glass overlay and the lcd digitizer.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-24-10 08:09 PM
  5. adambigge's Avatar
    I know exactly the sound you are talking about because my storm 2 was doing it too. It would be fine at first but after extended use (like typing a long message) the click would get very loud and then would have the "metallic" double click. Almost like a secondary rattle a millisecond after the initial click.

    Very aggravating. I explained it to VZW customer support and eventually got it replaced. Other than that it worked fine.

    My replacement (the first time I ever had to have one replaced) works perfectly.

    Call up VZW customer service and explain the problem and also explain how you know that RIM has issued refurbished units for the express purpose of replacing units with problematic screens. There is a VZW memo floating around detailing it.

    That is all it took for me to get my replacement.
    04-24-10 08:48 PM
  6. David526's Avatar
    my storm2 does the exact same thing. I was just dealing with this a half hour ago and gave up on it. It does it on and off every few days it does this. its still clicking really loud right now. It doesnt do it all of the time though. It seems the problem has only been occurring since I updated to .607.

    I dont know what to do. I'm afraid to get a replacement because the first time I had the Storm2, it had problems and the three replacements they sent me were all worse than the previous. I gave up on it and went Droid, but im back to storm2.

    This phone works great aside from this awful clicking, I'm just afraid I'll get sent one thats worse.
    04-24-10 10:03 PM
  7. Tito71's Avatar
    same issue here but since I am in Canada (a bought the unit on Kijiji) and unable to send it back to Verizon
    04-25-10 04:20 AM
  8. yz450gn's Avatar
    Yeah thanks for replies. I am using and unlocked one I bought of craigslist so I am pretty much screwed I guess. Well since no warranty or insurance, wonder if there is something that can be fixed

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-10 08:53 AM
LINK TO POST COPIED TO CLIPBOARD