Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 55
  1. nmong2007's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Thread AuthorThread Author   #1  

    Default Storm is on but just a black screen help!!!!!

    My storm was working fine all day i used the gps texting used it as a modem all that good stuff then i took it out of my pocket at work when i went to lunch and its a black screen..i did several battery pulls as well as took the memory card and sim card out got nothing..its on cause if i cover it with my hands the back light is lit up a little as well as the buttons and i know its still on because even tho i have the network contections off my alarm went off this morning but i couldnt turn it off...possible software problem with the video card....cause like i said it was working fine no problems?????
  2. Rider-on-the-storm's Avatar
    CrackBerry Abuser

    Posts
    294 Posts
    PIN
    cushion
    #2  

    Default

    Did you do a battery pull?
  3. jayharper08's Avatar
    CrackBerry Addict

    Posts
    628 Posts
    Global Posts
    636 Global Posts
    #3  

    Default

    That is weird because mine did the same exact thing yesterday morning. It was on but the display would not light up at all. Before that the screen was starting to act up. Did battery pulls and all and called verizon and got another one. Just got this one up and running today.
  4. nmong2007's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Thread AuthorThread Author   #4  

    Default

    ya my screen was acting up too its weird i did several battery pulls...i called verizion ther sending me a new one but still im just curious
  5. Craigiebob's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #5  

    Default

    Ahh Hello, I am glad to see that didnt just happen to me, So theres no fix I guess? Just gonna have to send it back....How long to they usually take cos I cant be without a phone.
  6. mdude85's Avatar
    CrackBerry Master

    Posts
    1,304 Posts
    Global Posts
    1,309 Global Posts
    #6  

    Default

    Was the little red LED blinking?
  7. Craigiebob's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #7  

    Default

    Quote Originally Posted by mdude85 View Post
    Was the little red LED blinking?
    its onyl on when it boots up then it just stays o the black very dimly lit screen, the buttons are lit up, just no screen responsiveness
  8. bbstorm4me's Avatar
    CrackBerry Abuser

    Posts
    430 Posts
    #8  

    Default

    I noticed that if you press the LOCK button and then press the screen it says whatever you programmed in for the locked screen message. Then if you let the screen timeout to black, it does not light back up when you press the screen.

    It seems like it is dead. Maybe you are pressing the lock button when it is in your pocket or something?

    This is different from when you have a password set and let it auto lock as then the screen will light up upon pressing it in.

    But when it is in this black screen mode if you press the LOCK button on the top left or press the RED HANGUP button, then it lights up the screen and either asks for the password or says the "Screen is locked. Press the Lock button to unlock."

    Then you have to enter the password.

    I am running .106 hybrid OS I think I saw this on .103 also. I am not sure I ever used the lock button prior to that so i do not know if .75 acted this way or not.
  9. ronhelms35's Avatar
    CrackBerry Newbie

    Posts
    8 Posts
    PIN
    304951D1
    #9  

    Default

    This happened to my Storm a week ago. Once in a while you can click on the screen and it will come back. But it will only allow 1-2 clicks before it goes back to black again. Verizon had me completely wipe the device, still nothing. They replaced the handset, thinking this was a short with the screen.
  10. RichYung47's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #10  

    Default

    i have the same problem but i have my storm unlocked for at&t doesn't have verizon service. am i just out of luck or is there anything i can do???
  11. Ninjaracing13's Avatar
    CrackBerry Newbie

    Posts
    4 Posts
    #11  

    Default

    I had the same problem. Since the phone still works i updated the os to .141/5.0 and it eventually started working again til i backed up my device lol. is verizon going to say anything about the upgraded os if i try to send mine back?
  12. kingkjs's Avatar
    CrackBerry User

    Posts
    19 Posts
    #12  

    Default

    Does changing the screen help or does the problem come back!?
    I need to no if to replace the screen or just by a new phone.
  13. ssjtiamat's Avatar
    CrackBerry Abuser

    Posts
    119 Posts
    Global Posts
    122 Global Posts
    PIN
    Not anymore :-)
    #13  

    Default

    You know. My sisters Storm had a similar problem that started after I updated her to 5.0 Well after some searching around and getting no help I tinkered for a bit. And it appears that with the USB bug there may also be a SD card bug. Because when her SD card is plugged into the phone she gets the black screen issue,. When I reboot her phone without the SD card, everything works as it should.

    So I formatted her card and reinstalled it. And now everything works as it should. Maybe a corrupt file on the card that 5.0 did not know how to handle?

    Try that... maybe it will help.
    Bumper Sticker: "My PS3 beat up your Xbox 360"

    Diverse By Design
  14. Eleni 22's Avatar
    CrackBerry Addict

    Posts
    805 Posts
    Global Posts
    922 Global Posts
    #14  

    Default

    I have a sort of similar situation with the black screen but mine happens when I try and respond to a text or email the keyboard goes black and I have it either turn the phone around or hoover on the pad itself and letter by letter they come back. Anyone else know why this is happening
  15. hawki's Avatar
    CrackBerry Newbie

    Posts
    8 Posts
    #15  

    Default

    I had that problem too once. Accu pull solved.
  16. MeikMeik's Avatar
    CrackBerry User

    Posts
    37 Posts
    PIN
    3104E00A
    #16  

    Default

    My storm did something very similar, only thing is mine wouldn't function at all. Nothing worked, it wouldn't even reboot (no flashing led light, nothing). The only thing it did do was get really hot. Verizon had to send me another phone.
  17. ClayB's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    #17  

    Default

    Mine also started doing this. To fix it I would have to push on the screen fairly hard and it would work for a while. Eventually the screen became completely unresponsive. Coincidentally it quit working all together during an argument with the gf. Needless to say it didn't turn out too well for the phone and I got a new one.

    Posted from my CrackBerry at wapforums.crackberry.com
  18. twester65's Avatar
    CrackBerry Addict

    Posts
    517 Posts
    #18  

    Default

    Sounds like what happened to my phone last summer. I pulled it out of my pocket and the screen wouldn't come on. In a dark room, I could see bits of the screen so it was clearly a hardware problem. Verizon replaced it without questions. So far, so good.
  19. kingkjs's Avatar
    CrackBerry User

    Posts
    19 Posts
    #19  

    Default

    Quote Originally Posted by ssjtiamat View Post
    You know. My sisters Storm had a similar problem that started after I updated her to 5.0 Well after some searching around and getting no help I tinkered for a bit. And it appears that with the USB bug there may also be a SD card bug. Because when her SD card is plugged into the phone she gets the black screen issue,. When I reboot her phone without the SD card, everything works as it should.

    So I formatted her card and reinstalled it. And now everything works as it should. Maybe a corrupt file on the card that 5.0 did not know how to handle?

    Try that... maybe it will help.

    I tryed this and the screen is still black! i seriously feel it is the screen that is defaulty. I would like to no if any1 replaced there screen and got the problem again!?
  20. mouazz's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #20  

    Default

    Look Guys
    i had the same trouble some days ago
    it bothered me all the day i was trying to understand whats wrong once
    i pulled the pattery and put it back again mobile open just for some seconds then the screen goes to sleepy mode and never open again until i repeat the pattery pull again

    then i found solution maybe its a lil bit stupid but it worked with me
    i removed sim card and i plugged headphones in my BB storm and i found thats its working then again i repeat the same several times and i found its working well
    then once i put back the simcard i found the same trouble

    Try more and more with the headphones in and out several times i made my storm work again )

    so try it out but be patient i made it 5 or 6 times

    i had the same trouble with iphone and solution was the headphones
  21. zmaerdstyle's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Global Posts
    8 Global Posts
    #21  

    Default

    I'm having a similar issue as many of you have described. For example, if the phone is on and the screen is dimmed, if I receive a text and go to press the screen, or any buttons, the screen is unresponsive. I can tell that the backlighting is on, but nothing shows on the screen. I have to leave the phone alone until the backlilght times out before trying again. After that, sometimes it works, and sometimes I have to wait for it to timeout again. This just started a few days ago and it's extremely frustrating! I will try some of the fixes you guys mentioned to see if that helps. If not, I'll be paying Verizon a visit!
  22. BBUser8830's Avatar
    CrackBerry User

    Posts
    58 Posts
    #22  

    Default

    Try connecting to a PC Via USB.....turn off then turn on.......if that doesn't work pull the battery while it's connected to the PC. See if this works.....please report back.

    MB
  23. yankee0412's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #23  

    Default

    Just got the black screen problem today. I charge it to see if that helps, it will reboot for a while, act normal and then go black again. Lucky me, my warranty ran out last week. Figures. I will try a few of the suggestions I'm seeing here before giving up.
  24. milkpowder's Avatar
    CrackBerry User

    Posts
    85 Posts
    #24  

    Default

    I've also had a similar problem before, twice, or thrice? Screen would just suddenly go dark. Pressed lock button and it seemed to do the trick for me. I have a password set so it would come up asking me to unlock. It's quite annoying to be honest. Fortunately it hasn't happened often. Methinks it is a software issue. Never had this problem in OS 4.7
    9500 w/ OS 5.0.0.580/643
  25. davehacker's Avatar
    CrackBerry User

    Posts
    53 Posts
    #25  

    Default

    Here is how I fixed it (my sceen was dark) - long story short, I used BlackBerry Desktop Manager to remove unused applications. Here is the long story:
    1 - this is has happened in the past. pulling the battery a few times did not work but has in the past
    2 - since pulling the battery did NOT work this time, I connected the phone to my computer with BlackBerry Desktop Manager.
    3 - first, I backed up what I could off the phone just in case (for me, mainly my pictures, most other things are synced up, like my e-mail and appointments)
    4 - I ran Application Loader, and removed (unchecked) several third party applications - sorry I uninstalled several so not really sure what the culprit was.
    5 - the uninstall automatically rebooted and worked.

    not sure if this will fix for everybody, but it did for me so I thought I would post.

    Thanks,

    Dave, www.ProOnGo.com
Page 1 of 3 123 LastLast

Posting Permissions