02-04-13 09:46 PM
77 1234
tools
  1. michaelwhyte's Avatar
    Hello:

    I have multiple calendars with gmail...has anyone had any luck with syncing multiple calendars with Playbook OS 2.0...

    It seems to sync the primary calendar but not other calendars...

    Thanks,

    Michael
    02-21-12 10:50 AM
  2. RetroAndreas's Avatar
    PB OS/2 Calendar will sync only with the primary Google calendar. It states so in the setup.
    02-21-12 11:41 AM
  3. peter9477's Avatar
    More so than that, it appears that if you set up a second gmail account you can't sync with its main calendar either. So only one gmail cal for now, period.

    Correction: this works. See follow-up below.
    Last edited by peter9477; 02-21-12 at 01:16 PM. Reason: Correct facts
    02-21-12 11:52 AM
  4. canadoc's Avatar
    i can't even get my main calendar to sync
    02-21-12 12:02 PM
  5. RetroAndreas's Avatar
    i can't even get my main calendar to sync
    Make sure the Gmail calendar icon has a check mark to show you want it displayed on your PB calendar. This had me stumped for a bit.
    02-21-12 12:06 PM
  6. BerryClever's Avatar
    Also, I had trouble syncing my calendar. My issue, however, was that I only setup my gmail account's e-mail, not everything. I ended up doing it a second time and it worked. I then went back and deleted my gmail only setup and kept the Email, Calendar and Contacts setup for my gmail account.

    As for the main calendar sync. I went to Gmail's calendar website and exported my sub calendars and then imported it into my primary Gmail calendar. It would be nice to categorize it, but for now, this will do for me.
    02-21-12 12:17 PM
  7. canadoc's Avatar
    Finally got it to sync. I had to delete the account on the PB and then do a manual setup via advanced.
    Nowif only they had a feature like the iPhone or iPad which by default also only does one calendar but then you can goto google mobile site and enable the others and have em all show up.
    02-21-12 12:25 PM
  8. egzbuen's Avatar
    Syncing with Gmail calendar needs patience specially when you have lots of entries.

    I almost posted a rant here at CB when after waiting a while, all my entries appeared. Apparently, it took awhile since I had slot of entries.

    I'm enjoying my PB right now with all of its functions.

    Hope everything goes well with you guys to.

    Cheers
    02-21-12 12:34 PM
  9. RetroAndreas's Avatar
    Syncing with Gmail calendar needs patience specially when you have lots of entries.
    Cheers
    I had the same situation with my contacts....hundreds of them....took some time but everything is good now.
    02-21-12 12:37 PM
  10. anderson620's Avatar
    I had the same situation with my contacts....hundreds of them....took some time but everything is good now.
    I ran into the same issue, but subsequent updates/syncs seem to go faster at least.

    By the way, love your signature!
    02-21-12 12:39 PM
  11. RetroAndreas's Avatar
    I ran into the same issue, but subsequent updates/syncs seem to go faster at least.

    By the way, love your signature!
    Yes, after the initial sync the updating syncs were fast.

    and thanks...an Isaac Asimov quote...
    02-21-12 12:47 PM
  12. peter9477's Avatar
    I was wrong about not being able to get the calendar for a second gmail account. I couldn't get it working for my wife's account (on my PB) but with a third account it worked. Might have been my mistake the first time... Will try again.
    02-21-12 12:51 PM
  13. peter9477's Avatar
    Okay, so the first time I tried was with my wife's account, so we could share each others calendars as we do on the PC. I simply entered her email and password in the Basic Setup fields. I forget whether it said it hadn't worked, or said it worked but then didn't give the option to get the calendar.

    The second time I used my company gmail address, and went into the Advanced Setup and specified a Gmail account type. Filled in the fields and let it test the connection. Then it gave me the usual options to synchronize Email, Contacts, and Calendar, and I turned off the first two. After some synchronizing those calendar entries appeared in my Calendar app.

    I went back and did the same thing with my wife's account and now I have THREE Gmail calendars (each from a separate account), as well as my own Facebook calendar, and the PlayBook (local) calendar. Seems to work fine, and I can even add entries to my wife's calendar!
    02-21-12 01:26 PM
  14. yauchunh's Avatar
    I ran into the same issue, but subsequent updates/syncs seem to go faster at least.

    By the way, love your signature!
    no problem when i did it. Once i clicked update, I went to sleep. Woke up, and everything was perfect!
    02-21-12 01:36 PM
  15. adamschuetze's Avatar
    Anybody tried setting up a gmail account that's using google apps? I can't get the google calendar to show up on my PlayBook. Email yes. Contacts yes.
    02-21-12 02:42 PM
  16. mkm_dz's Avatar
    Here is how i synced my google calendars.

    1.-Set up an email (gmail) account as stated in the add account panel. (This will setup your main calendar)
    2.-click on account->Add new account-> Email,calendar...->Advanced Setup->CalDav
    (Read this Get Started with CalDAV - Ayuda de Google Calendar) thats it, you can add your calendar. Repeat step 2 for more calendars.
    iheartstraws likes this.
    02-21-12 02:50 PM
  17. goodtastingsteak's Avatar
    Here is how i synced my google calendars.

    1.-Set up an email (gmail) account as stated in the add account panel. (This will setup your main calendar)
    2.-click on account->Add new account-> Email,calendar...->Advanced Setup->CalDav
    (Read this Get Started with CalDAV - Ayuda de Google Calendar) thats it, you can add your calendar. Repeat step 2 for more calendars.

    Does this method work for adding secondary calendars?
    02-21-12 03:00 PM
  18. dtong22's Avatar
    Syncing with Gmail calendar needs patience specially when you have lots of entries.

    I almost posted a rant here at CB when after waiting a while, all my entries appeared. Apparently, it took awhile since I had slot of entries.

    I'm enjoying my PB right now with all of its functions.

    Hope everything goes well with you guys to.

    Cheers
    I do not have wifi at work and I did the update through the BB desktop software with internet direct connection. So far so good.
    The GPS program that I bought for $5 still does not work. I had some hope that Os2 might juar correct its problem

    Daniel, Toronto
    02-21-12 03:20 PM
  19. mkm_dz's Avatar
    Does this method work for adding secondary calendars?
    Yes it does, you can add your primary calendar using the account and then add secondary calendars using the method described above.
    02-21-12 03:21 PM
  20. redbutt's Avatar
    Duh...editing my post...This is the URL that helped me get the settings correct:

    http://support.google.com/calendar/b...=99358#sunbird

    I also did have to use the calendar ID as the "email" address value.
    Last edited by redbutt; 02-21-12 at 03:36 PM.
    02-21-12 03:31 PM
  21. tubbycyclist's Avatar
    I stuck this post in another thread - apologies for cross posting but this seemed like the right place.

    This solution has worked for me and I have been able to sync 3 calendars over activesync to my PB. A brief write up for now as there is a blog article with instructions and no point in repeating them here.

    A quick search found that early "Mango" adopters had the same problem - only one calendar on activesync problem.

    This page in particular was helpful and I pretty much followed the instructions. FWIW I used Firefox with a User Agent switcher rather than Safari.

    The key features you need to be familiar with are:
    -changing the user agent string in a browser to access the relevant settings.
    -changing the string in the address bar.
    -understand how to disable javascript in your browser.

    The only significant difference is that Google now seem to use a Supported Multiple Calendars= false string to check the device. I simply changed this value to true and it worked.

    Hopefully this will be a one time operation.
    02-21-12 03:48 PM
  22. OneArmJack's Avatar
    Duh...editing my post...This is the URL that helped me get the settings correct:

    Get Started with CalDAV - Google Calendar Help

    I also did have to use the calendar ID as the "email" address value.
    It doesn't let you have the same email address in multiple CalDAV accounts but you don't need to use the calendar ID in that field: it seems to accept any valid email address.
    02-21-12 04:18 PM
  23. canadoc's Avatar
    I stuck this post in another thread - apologies for cross posting but this seemed like the right place.

    This solution has worked for me and I have been able to sync 3 calendars over activesync to my PB. A brief write up for now as there is a blog article with instructions and no point in repeating them here.

    A quick search found that early "Mango" adopters had the same problem - only one calendar on activesync problem.

    This page in particular was helpful and I pretty much followed the instructions. FWIW I used Firefox with a User Agent switcher rather than Safari.

    The key features you need to be familiar with are:
    -changing the user agent string in a browser to access the relevant settings.
    -changing the string in the address bar.
    -understand how to disable javascript in your browser.

    The only significant difference is that Google now seem to use a Supported Multiple Calendars= false string to check the device. I simply changed this value to true and it worked.

    Hopefully this will be a one time operation.
    Followed the information to the google mobile sync site and saw the playbook listed. I disabled javascript.
    When I select playbook I see no calendar options, only those to enable send as in e-mail.
    Could you type out a more step by step process in case i missed something?
    02-21-12 04:45 PM
  24. tubbycyclist's Avatar
    Install Firefox if you don’t have it.
    Open Firefox and go to Tools> Add Ons, do a search for User Agent Switcher and install it.
    Restart Firefox
    Go to Google and log in to your account
    Go to tools and use the User Agent Switcher to select iphone 3.0
    then jump to m.google.com/sync
    You should see the Playbook listed.
    Now go to the Edit>Preferences>Content menu and disable Javascript. If you use Windows you will need to go to Tools> Options>Content instead.
    Once you have disabled Javascript go back to the sync page and select your device.
    You will see a screen that say something like “Send Mail As”, but with NO calendar options.

    Here is the bit I think you may have missed
    Look at the address bar in your browser. There will be a long session address ending with “multiple calendars=false”. Change the word "false" to "true", and then refresh the page.
    The page should now have a list of calendars, select those you want to sync and hit the save button. It says you can only use one calendar but that is not the case
    You should see a message saying the device settings have changed.
    Reset your browser settings again once you close that tab.

    Hope that is clearer.
    For information: this will only work with your calendars and others shared calendars. Public calendars can not be added this way, and I would have thought the CalDAV method should work that is posted in this forum

    Here are a couple of amendments
    - added info about Options on Windows PC
    - linked to information about public calendars
    Last edited by tubbycyclist; 02-22-12 at 02:22 AM. Reason: Added information
    02-21-12 05:31 PM
  25. canadoc's Avatar
    missed changing the setting in the browser bar
    got it!
    made the changes.
    Now how about on the playbook end? Will these changes just lead to the calendar being repopulated? Or must I disable and reeneable everything?
    02-21-12 05:42 PM
77 1234
LINK TO POST COPIED TO CLIPBOARD
";