Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 28
Like Tree7Likes
  1. daivivo's Avatar
    CrackBerry User

    Posts
    11 Posts
    Thread AuthorThread Author   #1  

    Exclamation icons on the dock disappeared and cannot get them back!

    I just got a problem with my playbook, details are described as below:

    I upgraded the system to 2.1 beta and the device ran great; today I just dragged the browser icon on the dock to the first pane on home screen, so the dock was blank then, but when I tried to drag back the browser icon to the dock, there popped up a notification saying "array_insert invalid array index", and the browser icon just disappeared! I cannot find it back even after several reboots! I tried to google and search over the official website and the help docs, just cannot find any clue to the cause, so I'm asking you guys for help with the problem. Look forward to your quick response!

    Thanks a lot!
  2. daivivo's Avatar
    CrackBerry User

    Posts
    11 Posts
    Thread AuthorThread Author   #2  

    Default

    Any idea how to fix it?
  3. Superfly_FR's Avatar


    Posts
    13,162 Posts
    Global Posts
    13,200 Global Posts
    PIN
    Hey, what did you expect ?
    #3  

    Default

    Basic steps #1
    - Have you restarted your PB at least once ?
    [before doing next suggestion, perform a full backup with DM. Connecting to DM may also bring some light ;-)]
    - Try to hit the "search for updates" again, you may need additional files (happened to me)

    Let us know.

    BTW: double posting won't help you much. As this is the appropriate section, there's the link to follow-up your previous one icons on the dock disappeared and cannot get them back!
    Last edited by Superfly_FR; 06-05-12 at 04:39 AM.
  4. daivivo's Avatar
    CrackBerry User

    Posts
    11 Posts
    Thread AuthorThread Author   #4  

    Default

    Quote Originally Posted by Superfly_FR View Post
    Basic steps #1
    - Have you restarted your PB at least once ?
    [before doing next suggestion, perform a full backup with DM. Connecting to DM may also bring some light ;-)]
    - Try to hit the "search for updates" again, you may need additional files (happened to me)

    Let us know.

    BTW: double posting won't help you much. As this is the appropriate section, there's the link to follow-up your previous one icons on the dock disappeared and cannot get them back!
    thanks for your response.
    i tried to restart my PB many times but didn't work.
    i know reinstalling the system should fix the problem, but i just hate to do so
    thought it might be a beta problem, since i couldn't get any clue to the cause after googling the issue..
  5. indyaachen's Avatar
    CrackBerry User

    Posts
    72 Posts
    #5  

    Default

    The same thing happened to me when I was reinstalling the developers' beta 2.1. I restored from the backup I had taken that brought back the icons, but the sideloaded apps won't run.
    The only way out was to register again and then update to 2.1 over 2.1
    Since then it is running fine. good luck.
    Spacemonkie likes this.
  6. daivivo's Avatar
    CrackBerry User

    Posts
    11 Posts
    Thread AuthorThread Author   #6  

    Default

    Quote Originally Posted by indyaachen View Post
    The same thing happened to me when I was reinstalling the developers' beta 2.1. I restored from the backup I had taken that brought back the icons, but the sideloaded apps won't run.
    The only way out was to register again and then update to 2.1 over 2.1
    Since then it is running fine. good luck.
    yay, I've figured out your way is the only solution. cheers!
  7. SCrid2000's Avatar

    Posts
    10,625 Posts
    Global Posts
    10,639 Global Posts
    PIN
    PM me.
    #7  

    Default

    This will happen anytime you remove all the icons from the dock.
  8. pacoman03's Avatar
    CrackBerry Genius

    Posts
    3,597 Posts
    #8  

    Default

    One question. If your browser icon disappeared, and since your screenshot shows the browser running, how did you open your browser without a desktop icon?
  9. SCrid2000's Avatar

    Posts
    10,625 Posts
    Global Posts
    10,639 Global Posts
    PIN
    PM me.
    #9  

    Default

    Quote Originally Posted by pacoman03 View Post
    One question. If your browser icon disappeared, and since your screenshot shows the browser running, how did you open your browser without a desktop icon?
    His browser probably wasn't in the bar; if you lost your browser from this, either do a wipe or Buy App Drawer - Download App Drawer - Buy Apps from BlackBerry App World
    Last edited by SCrid2000; 06-11-12 at 05:48 PM.
  10. Spacemonkie's Avatar
    CrackBerry User

    Posts
    53 Posts
    #10  

    Default

    You can install 2.1 over 2.1?

    Sent from my BlackBerry Runtime for Android Apps using Tapatalk 2
    Last edited by Spacemonkie; 06-25-12 at 04:52 PM.
  11. Comineeyeaha's Avatar
    CrackBerry User

    Posts
    17 Posts
    Global Posts
    710 Global Posts
    #11  

    Default

    I'm having this same problem, but none of the above recommendations have helped. When I try to update, I'm told there is no update available. With each test, I'm losing more apps. Any more ideas?
  12. pacoman03's Avatar
    CrackBerry Genius

    Posts
    3,597 Posts
    #12  

    Default

    Quote Originally Posted by comineeyeaha View Post
    I'm having this same problem, but none of the above recommendations have helped. When I try to update, I'm told there is no update available. With each test, I'm losing more apps. Any more ideas?
    To update to the 2.1 beta, you have to register for it. See here- http://forums.crackberry.com/blackbe...le-now-727413/
  13. rash.m2k's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #13  

    Default Re: icons on the dock disappeared and cannot get them back!

    There is a fix/workaround that worked for me.

    Simply move all the icons/folders to the shortcut bar and then restart, all my icons are now back.
  14. Robert Calhoun's Avatar
    CrackBerry Addict

    Posts
    545 Posts
    Global Posts
    551 Global Posts
    #14  

    Default Re: icons on the dock disappeared and cannot get them back!

    Thank you for this tip... Worked for me as well.
  15. hiba.ballaith's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #15  

    Default Re: icons on the dock disappeared and cannot get them back!

    how do i register again ???
  16. pacoman03's Avatar
    CrackBerry Genius

    Posts
    3,597 Posts
    #16  

    Default Re: icons on the dock disappeared and cannot get them back!

    Quote Originally Posted by hiba.ballaith View Post
    how do i register again ???
    You don't. They're talking about reregistering for the 2.1 beta release, which is no longer available.
  17. jeroen_13's Avatar
    CrackBerry Genius

    Posts
    1,764 Posts
    PIN
    Just PM
    #17  

    Default

    Quote Originally Posted by rash.m2k View Post
    There is a fix/workaround that worked for me.

    Simply move all the icons/folders to the shortcut bar and then restart, all my icons are now back.
    Worked for me too !
    jdgdtg likes this.
  18. Xader's Avatar
    CrackBerry Abuser

    Posts
    369 Posts
    Global Posts
    509 Global Posts
    #18  

    Default Re: icons on the dock disappeared and cannot get them back!

    Quote Originally Posted by rash.m2k View Post
    There is a fix/workaround that worked for me.

    Simply move all the icons/folders to the shortcut bar and then restart, all my icons are now back.
    I had the same issue and this is how I solved it as well.
    jdgdtg likes this.
  19. Shredder00's Avatar
    CrackBerry User

    Posts
    14 Posts
    #19  

    Default Re: icons on the dock disappeared and cannot get them back!

    Quote Originally Posted by rash.m2k View Post
    There is a fix/workaround that worked for me.

    Simply move all the icons/folders to the shortcut bar and then restart, all my icons are now back.
    Worked perfectly. Thanks!!!
  20. mictoyman12's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #20  

    Default

    wow!!!! thank u so much for ur advice...........it worked after so many days of researching............even the BB website dont have a solution for this problem.............thank u so much, now i can enjoy my playbook again
  21. messaboutz_inc's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Global Posts
    1 Global Posts
    #21  

    Default

    Thank You So Much! I Backed Everything Up Just Incase I Lost It But Dragging Them Onto The Shorcut Bar (where the icons vanished) and restarted It Worked! Thanks Again Who Ever Suggested That!
    F2 likes this.
  22. myklgrant's Avatar
    CrackBerry User

    Posts
    51 Posts
    #22  

    Default

    So the fix worked as advertised and I am eternally grateful. The questions arises: How in god`s name did you figure this out. The solution was basically make it worse until it fixes itself.
    Thanks again.
  23. 7Bulldog7's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #23  

    Default

    Try this:

    1. Move all icons from the lower pane(s) into the Quick Launch bar until there are no icons visible on the BlackBerry PlayBook.
    2. Restart the BlackBerry PlayBook.

    This should work. Tell me what happens!
  24. 7Bulldog7's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #24  

    Default

    Did your games and apps from BlackBerry App World come back or did you have to reinstall them? Please tell me if they did or not because i will follow your advice. If you can give me the steps again. Thanks!
  25. Joseph Wong Kaskus's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #25  

    Default

    ITS WORK 100% , nice ....
Page 1 of 2 12 LastLast

Posting Permissions