Results 1 to 8 of 8
  1. devilxvergil's Avatar
    CrackBerry User

    Posts
    45 Posts
    Global Posts
    56 Global Posts
    Thread AuthorThread Author   #1  

    Unhappy defective display ?

    hi guys, i just bought a second hand playbook. was quite happy with it all the while, till i realised a white frame at the corners of the display. is it a problem with the software or defective screen ?
  2. kbz1960's Avatar
    Doesn't Matter

    Posts
    55,659 Posts
    Global Posts
    55,814 Global Posts
    #2  

    Default

    Maybe residue from a screen protector?
    Sent from me using my fingers. Be pantless in 5K. Febreze - for more than smells.
    the 50K CrackBerry challenge
    I'm no more qualified to say so because I own a BlackBerry
  3. devilxvergil's Avatar
    CrackBerry User

    Posts
    45 Posts
    Global Posts
    56 Global Posts
    Thread AuthorThread Author   #3  

    Default

    somehow, those white spots go away after keeping the display turned on for awhile. anyone else have this issue ?
  4. Bleeh's Avatar
    CrackBerry User

    Posts
    21 Posts
    #4  

    Default

    Same here
    Only workaround so far is to wait for the display to settle ... annoying though.
  5. #5  

    Default

    How bright do you keep the backlight? Mine is generally toned down quite a bit unless outdoors.
  6. Alt-F4's Avatar
    CrackBerry Abuser

    Posts
    403 Posts
    #6  

    Default

    Quote Originally Posted by F2 View Post
    How bright do you keep the backlight? Mine is generally toned down quite a bit unless outdoors.
    Yea ive always kept my brightness at around 33% quite dim and can't say I've ever noticed that. Idk
    My Modern Combat 2 Multiplayer id: Me551ah
    --->Modern Combat 2 Playbook Club<---
  7. devilxvergil's Avatar
    CrackBerry User

    Posts
    45 Posts
    Global Posts
    56 Global Posts
    Thread AuthorThread Author   #7  

    Default

    50% in the beginning, and 100% later, and still having the same spots. will try to pull off the screen protector later
  8. Ironjer's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Global Posts
    13 Global Posts
    #8  

    Default

    was having this problem then replaced the screen and the problem still there mainboard fail? wtf

Posting Permissions