Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 24 of 24
Like Tree1Likes
  • 1 Post By no expert
  1. 002445's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    Thread AuthorThread Author   #1  

    Default CalDAV on 2.0

    Hey there,

    I just downloaded 2.0 and it is a great upgrade from 1.X. Especially the native email and calendar will be a great addition for me since I use it primarily for business purposes.

    However I've been trying to set up my business calendar for a while but it does not seem to work. At the office we use a server with Mac OSX Server for syncing our calendars/contacts.

    Now I know that Apple and other hardware/software brands do not always work together very well but it is my understanding that CalDAV is an open protocol so it shouldn't matter.

    I think the problem is that the CalDAV setup on the Playbook asks for an emailadress, username and password for authentication while I only use a username and a password for authenticating on my laptop.

    Has anyone been able to set up CalDAV without an email address. Or even better, with the same setup like me using Mac OSX server.

    Besides this 2.0 works great!
  2. redbutt's Avatar
    CrackBerry User

    Posts
    24 Posts
    #2  

    Default

    no luck here either...
  3. redbutt's Avatar
    CrackBerry User

    Posts
    24 Posts
    #3  

    Default

    I finally got CalDAV to work with Google Calendar. In the server box, just use "www.google.com". However, it's still not syncing multiple calendars. It seems on the surface that you have to treat OS2 as an iPhone and go here to select multiple calendars:

    https://www.google.com/calendar/iphoneselect

    But, upon calendar refresh, I still only see the primary one.
    Thanked by:
    Technosnob (02-25-2012) 
  4. prez87's Avatar
    CrackBerry Abuser

    Posts
    248 Posts
    #4  

    Default

    From my understanding, if you you multiple calendars setup in Google, you will need setup each one individually on the Playbook. Each calendar has a code/name and you use it to setup the calendar as caldav.
    Curve 8330 -> Storm 9530 -> Torch 9800 Aug 2010 -> Bold 9900 June 2012 & Playbook 04/19/11 -> Z10
  5. prez87's Avatar
    CrackBerry Abuser

    Posts
    248 Posts
    #5  

    Default

    I tried the iphoneselect method too but no luck. Next thing I will try is to setup individual caldav calendars.
    Curve 8330 -> Storm 9530 -> Torch 9800 Aug 2010 -> Bold 9900 June 2012 & Playbook 04/19/11 -> Z10
  6. redbutt's Avatar
    CrackBerry User

    Posts
    24 Posts
    #6  

    Default

    Quote Originally Posted by prez87 View Post
    From my understanding, if you you multiple calendars setup in Google, you will need setup each one individually on the Playbook. Each calendar has a code/name and you use it to setup the calendar as caldav.
    Wow...I just tried this...and you are absolutely correct. You just use the calendar ID of the other calendars as the "email address" setting when setting up a new CalDAV account.

    UPDATE: Here's the settings that finally allowed syncing to work: http://support.google.com/calendar/b...=99358#sunbird
    Last edited by redbutt; 02-21-2012 at 02:41 PM.
  7. canadoc's Avatar
    CrackBerry Abuser

    Posts
    164 Posts
    Global Posts
    168 Global Posts
    #7  

    Default

    Did you use thunderbird or ical instructions?
    Where can I find the corresponding Calendar ID for each of my google calendars?
  8. prez87's Avatar
    CrackBerry Abuser

    Posts
    248 Posts
    #8  

    Default

    I didn't use either one - I clicked on the link below that said if you have an ipod touch etc click this article... CalDAV Calendar Sync - Google Mobile Help.

    To find the calendar ID, go to gmail -> Calendar -> Settings -> Calendars -> Click the calendar you want -> Scroll down to calendar adderss and look for Calendar ID there.
    Curve 8330 -> Storm 9530 -> Torch 9800 Aug 2010 -> Bold 9900 June 2012 & Playbook 04/19/11 -> Z10
    Thanked by:
    ismael280373 (12-12-2012) 
  9. pooger's Avatar
    CrackBerry Master

    Posts
    1,098 Posts
    Global Posts
    1,103 Global Posts
    #9  

    Default

    excellent tip. thanks. the www part was throwing me off when i tried it
  10. pooger's Avatar
    CrackBerry Master

    Posts
    1,098 Posts
    Global Posts
    1,103 Global Posts
    #10  

    Default

    What did you guys use to sync contacts to gmail contacts? carddav doesn't seem to work as easily
  11. dogposture's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #11  

    Default

    I'm having the same issues as the OP trying to connect to my own CalDav server. I'm running DaviCal on Ubuntu.

    CalDav features work fine under Thunderbird on my desktop machines but putting the same server info into the Playbook just returns errors.

    If I browse to <ServerIP>/davical/caldav.php/<user>/home in the playbook's browser it prompts me for my CalDav user name and password. Once entered the playbook downloads my home.ics file which suggests that it's capable of accessing my calendar data. I guessing the CalDav software in OS 2.0 is only set up to authenticate with services such as Yahoo and Google hence the requirement to add an email address in the account info Has anyone else had any luck getting calendar data from their private or work CalDav server?
  12. spiritmorin's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #12  

    Default Caldav whit SSL

    How can we send request to RIM about this issue?

    I releay like the native calendar client on my Plabook 2.0 It work great, it sync great on my hotmail or gmail account. But my info are on a Zimbra server at work. Zimbra work well in IMAP but no CalDAV nor CardDav whit SSL!!! I try the Adroid honeycom native calendar app in it bad, lag, fat, borring, missing thing, not good at all. I don't think it a big thing to add a secure way to sync calendar.

    Any Idea?

    BTW, CalDav and CardDav whit SSL work just fine on IPhone and IPad
    Wake up RIM, dont give a chance.
  13. deanwarren's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #13  

    Default Works for me!

    To sync to my google calendar was easy.

    I configured a new account, pressed the advanced button and then selected gmail (not email, calendar, contacts). It automatically picked on calendar and contacts.

    Hope this helps...
  14. TheManFromBievo's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #14  

    Default caldav doesnt work with davical?

    Im trying to get my playbook running os 2.1.something to synch with our caldav server running bedework. Did you ever get it to work?
  15. parbrook's Avatar
    CrackBerry Abuser

    Posts
    146 Posts
    #15  

    Default Re: CalDAV on 2.0

    I found that Zimbra works perfectly if you select Microsoft Exchange Activesync instead of IMAP when setting-up the account.

    I was really frustrated that I could not sync calendar and contacts when using IMAP, but when I tried the Exchange option and my Zimbra login, my mail, contacts and calendar synced without the need for any further settings.

    I should add that I am using OS 2.1.0.1088
  16. ralfyguy's Avatar
    CrackBerry Genius

    Posts
    2,951 Posts
    Global Posts
    2,952 Global Posts
    #16  

    Default Re: CalDAV on 2.0

    Quote Originally Posted by redbutt View Post
    Wow...I just tried this...and you are absolutely correct. You just use the calendar ID of the other calendars as the "email address" setting when setting up a new CalDAV account.

    UPDATE: Here's the settings that finally allowed syncing to work: http://support.google.com/calendar/b...=99358#sunbird
    I cannot get this to work. You got a step by step please?
  17. Flying_FKB's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #17  

    Default

    Select the CalDAV Account on your Playbook account setup. Type in your Google email-address in the username, and again the Google email-address in the email-address field. Password is the same as you use on Google. The server address is the tricky one: https://www.google.com/calendar/dav/...LADRESS/events . I had to type in the email address the following way to get it worked: exmaple%40gmail.com . So I used %40 instead of @ and it worked.

    Can someone verify that contacts and calendar is synched, too when you just set up the standard Gmail Account on the Playbook?
  18. #18  

    Default

    Last I tried, they were all working: Cal/Card Dav, ActiveSync and plain simple gmail add.

    Only the avatars were taking a bit too long to download.
    Quick Help BLACKBERRY HELP 101 | Direct load Android (APK) Apps : BB10 10.2.1|Sideloading apps: BB10/PlayBook | Update/Reload Software: BB7.1- - PlayBook - BB10 | Debrick: BB7.1- - PlayBook - BB10 | Backup 3rd Party Apps: BB7.1- - PlayBook & BB10: Just use BB Link | Battery Saving: BB7.1- - PlayBook - BB10

    Got a question? diego.nei@mobilenations.com | My Apps: Papo GP | My Channel: Project Management BBM Channel

  19. dimm0k's Avatar
    CrackBerry Master

    Posts
    1,242 Posts
    Global Posts
    1,304 Global Posts
    #19  

    Default

    ok, rather than start a new thread on CalDAV on the PB I figure I'd add onto this one as it got me a bit further than previously. So I basically have my default calendar added with CalDAV just fine. Now I want to add the US Holidays calendar as a second CalDAV calendar. Can anyone please direct me on what I should use for the settings?

    Username: my @gmail.com email address
    Email Address: en.usa#holiday@group.v.calendar.gmail.com
    Server Address: https://www.google.com/calendar/dav/<my @gmail.com email address>/events

    This pretty much adds a second calendar to my tablet, however the events are identical to my default. I figure it has something to do with the Server Address and the text I would put in between the < >. I've tried en.usa#holiday@group.v.calendar.google.com, en.usa#holiday@group.v.calendar.gmail.com, en.usa#holiday%40group.v.calendar.gmail.com, en.usa#holiday%40group.v.calendar.gmail.com, but none of them let me save the account unless I use my @gmail.com email address. Anyone get this to work??
    Rockin' PlayBook 2.1.0.1526 bridged with the Bold 9930 7.1.0.1033

    My 9630 theme: dimm0k's V1 theme
  20. no expert's Avatar
    CrackBerry User

    Posts
    17 Posts
    #20  

    Default

    Just tried this for US holidays, and it worked:

    usa__en%40holiday.calendar.google.com
    Palm m100 -> Sony Clie -> BlackBerry Pearl 8100 (red) -> BlackBerry Bold 9000 (black) -> BlackBerry Torch 9810 (white) -> BlackBerry Q10 (black) + BlackBerry PlayBook (64GB)
    Thanked by:
    dimm0k (04-09-2013) 
    dimm0k likes this.
  21. J1124G's Avatar
    CrackBerry User

    Posts
    53 Posts
    #21  

    Default

    [no expert], can you please give us your complete setup details.

    you said that you used [usa__en%40holiday.calendar.google.com]... that must have been part of the server address... correct?

    so here is my assumptions:

    Username: gmail_name@gmail.com
    Email address: en.usa#holiday@group.v.calendar.google.com
    Password: *******
    Server address: https://www.google.com/calendar/dav/...gle.com/events

    I tried this (plus many variations) and keep getting errors.
  22. dimm0k's Avatar
    CrackBerry Master

    Posts
    1,242 Posts
    Global Posts
    1,304 Global Posts
    #22  

    Default

    Quote Originally Posted by J1124G View Post
    [no expert], can you please give us your complete setup details.

    you said that you used [usa__en%40holiday.calendar.google.com]... that must have been part of the server address... correct?

    so here is my assumptions:

    Username: gmail_name@gmail.com
    Email address: en.usa#holiday@group.v.calendar.google.com
    Password: *******
    Server address: https://www.google.com/calendar/dav/...gle.com/events

    I tried this (plus many variations) and keep getting errors.
    Only thing you're missing is instead of en.usa#holiday@group.v.calendar.google.com, it should be en.usa#holiday@group.v.calendar.gmail.com for the Email address.
    Rockin' PlayBook 2.1.0.1526 bridged with the Bold 9930 7.1.0.1033

    My 9630 theme: dimm0k's V1 theme
  23. no expert's Avatar
    CrackBerry User

    Posts
    17 Posts
    #23  

    Default

    Oh dear, I didn't check back on this thread and missed you! If [dimm0k]'s answer didn't work for you, here's my setup:

    Username: gmail_name@gmail.com
    Email address: usa__en@holiday.calendar.google.com
    Password: *******
    Server address: https://www.google.com/calendar/dav/usa__en%40holiday.calendar.google.com/events

    HTH!
    Last edited by no expert; 05-01-2013 at 02:56 PM. Reason: removed hyperlink
    Palm m100 -> Sony Clie -> BlackBerry Pearl 8100 (red) -> BlackBerry Bold 9000 (black) -> BlackBerry Torch 9810 (white) -> BlackBerry Q10 (black) + BlackBerry PlayBook (64GB)
  24. no expert's Avatar
    CrackBerry User

    Posts
    17 Posts
    #24  

    Default

    One other oddity I've noticed about some of the non-user Google calendars, like US Holidays, is that the html code for embedding will sometimes work when the proper Calendar Address doesn't. Example: Houston Dynamos schedule

    Calendar Address (ID) shows
    mls_5726_%48ouston+%44ynamo#sports@group.v.calenda r.google.com

    but embedding code shows
    https://www.google.com/calendar/htmlembed?src=mls_5726_%2548ouston%2B%2544ynamo%23 sports%40group.v.calendar.google.com

    So, for the emaiI address I used
    mls_5726_%2548ouston%2B%2544ynamo%23sports@group.v .calendar.google.com

    and for (part of) the server address I used
    mls_5726_%2548ouston%2B%2544ynamo%23sports%40group .v.calendar.google.com

    and it worked. Looks like something to do with the handling of spaces, but my brain hurt trying to figure out any more than that.
    Palm m100 -> Sony Clie -> BlackBerry Pearl 8100 (red) -> BlackBerry Bold 9000 (black) -> BlackBerry Torch 9810 (white) -> BlackBerry Q10 (black) + BlackBerry PlayBook (64GB)

Posting Permissions