Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
Like Tree2Likes
  • 2 Post By F2
  1. wayoung's Avatar
    CrackBerry Addict

    Posts
    594 Posts
    Thread AuthorThread Author   #1  

    Default Playbook rapid charger stand problems?

    I bought one from crackberry a couple of months ago and already it has stopped working. The lightning bolt comes on but the playbook receives no charge. Anyone else ever have similar problems? Know if it is the charger or the device?

    I pre-ordered this device and have one of the original models with the recessed power button (although am on on my fourth charger ) so it is almost two years old - maybe it is simply wearing out.

    Hopefully f BB10 phones are a hit a new generation of playbooks comes out fast otherwise I may need to move on to an Android tablet.
  2. nappp's Avatar
    CrackBerry Genius

    Posts
    2,447 Posts
    #2  

    Default Re: Playbook rapid charger stand problems?

    for mine it worked perfectly out of the box for a few months. then it started acting a little like yours. mine still works great, but what I do each time is after I put it on the stand I move it side to side until both the lightning bolt is on and the backlight changes a little. the backlight will either get brighter or dimmer depending on how bright you have it normally.

    doing this has not let me down for a long time. what you can also do to take it the next step is to get battery guru from appworld and have it up while charging. it won't take more than a min to tell if its really charging as you will see the line go up on the chart. once it is charging you can close the program or leave it up and walk away.

    hope this helps!
    Sprint Q10
    32GB Playbook
    Thanked by:
    curve-20 (01-22-2013) 
  3. #3  

    Default

    If you get a lightning bolt the PB seems to be detecting a supply with enough milliAmps available and capable of charging the battery. That suggests the problem is probably in the PB rather than the charger. Try a full restart in case the charge control software is confused, and make sure the charging contacts are clean (both sides). If it charges from the regular yellow plug USB charger it could suggest a dirty or defective contact on the stand charging connection.
    <a href="http://www.galatis.de/starboard.php?d=5518"><!-- Something special for the spammers --></a>
    CrackBerry... where only Stupid People fight about Smart Phones
  4. #4  

    Default

    There are others threads on this. In summary, there are 3 spring-loaded pins in the dock (and travel version). Usually, one of those pins gets STUCK downward and if only TWO PINS make contact, you get what I call a FALSE LIGHTNING BOLT. You can try using a toothpick or probe and press in/out on the pin to see if you can free it. Use Electrical contact cleaner to maybe help. Also sometimes just jiggling the pb in the dock can help.

    Battery Guru really helps to monitor the process. It will show cradle charging and show the voltage - the voltage needs to be eventually near 9volts on after a minute or so.
    David in Durham and Wasp14 like this.

Similar Threads

  1. Playbook charger stand problems
    By Cencalblackberryguy in forum BlackBerry PlayBook
    Replies: 9
    Last Post: 01-09-2013, 07:22 PM
  2. Replies: 4
    Last Post: 12-28-2012, 09:59 AM
  3. Replies: 54
    Last Post: 02-18-2012, 03:28 PM
  4. PlayBook Rapid Charger Deal
    By TNSberry in forum BBOS Phone Accessories
    Replies: 1
    Last Post: 08-30-2011, 07:24 PM
  5. playbook rapid charger deal!!!!
    By je2345 in forum BlackBerry PlayBook
    Replies: 7
    Last Post: 05-29-2011, 11:30 AM

Posting Permissions