Results 1 to 9 of 9
  1. trx64's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    Thread AuthorThread Author   #1  

    Default PlayBook not charging (dock or stock charger)

    Last week, my PlayBook started to refuse to charge. It shows the lighning icon when the charger is connected, but it simply doesn't charge at all (I've even tryed a 24 hours charge, without success). I've tested the stock charger with another PlayBook and it was working fine. I've bought a charging dock, but it isn't charging the device too. The weird part is that the chargers are able to keep it on, but the battery charge is at 0% now. Any idea to solve this? Anyone had the same problem?
  2. neel69's Avatar
    CrackBerry User

    Posts
    27 Posts
    Global Posts
    52 Global Posts
    #2  

    Default

    I had the exact same issue. Tried evrything but failed. So I submitted it to the Service Centre. They said its a hardware problem.
  3. guerllamo7's Avatar
    CrackBerry Addict

    Posts
    897 Posts
    Global Posts
    898 Global Posts
    #3  

    Default

    I had this happen to one of my Playbooks. Here is what I did to fix it:

    I left the PB sit (not charging) for a day. Then I plugged it in with the cable, not the dock. I charged it for about 15 seconds then, when the light went out, I pulled it. I repeated the process about five times after giving it a minute to sit. On the fifth or sixth short charge the screen showed a low batter symbol. After that I just plugged it in and it charged fully.

    I don't know why some things work (because they don't make sense to me) but they do. I hope this helps you. If not, maybe you should send it in under warranty.
    My BlackBerry. Just love it, love it, love it.
  4. saudadeii's Avatar
    CrackBerry Genius

    Posts
    1,634 Posts
    Global Posts
    1,639 Global Posts
    #4  
    --
    8800 (Retired), 9000 (Retired), 9800 (T-Mobile), PB64 WiFi, Droid 4 (VZW)
  5. #5  

    Default

    You could try a Restart/reboot and/or call.

    To fix an issue, try these in order:

    Restart using the Battery Icon and press Restart

    Press and hold the Power button for 10-15 seconds. Then leave it for 20-30 seconds and see if it restarts.

    To REBOOT:
    Press and HOLD all three keys for about 10 - 20 seconds: PowerOn, VolUp and VolDown. Start with the PowerButton. Keep holding past the 3-choice options screen. If you hear a shutter type sound, you've taken a Screen Shot and probably missed the PowerButton.

    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
  6. trx64's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    Thread AuthorThread Author   #6  

    Default

    I've tryed a new 24 hrs charge with the dock. No change. It loads up to 3.53 V (and stop charging), but can't hold more than ten minutes without the charger.
  7. baggins15's Avatar
    CrackBerry User

    Posts
    28 Posts
    #7  

    Default

    This charging issue is very annoying. I have had the same problem since the upgrade to 668. It persists with 840. I can't trust that the phone will charge overnight. Many times I wake up to find it dead. I've had mine for more than a year. If there is no fix then it's just a paperweight...
  8. Hgouck's Avatar
    CrackBerry Master

    Posts
    1,099 Posts
    Global Posts
    1,124 Global Posts
    #8  

    Default

    Quote Originally Posted by baggins15 View Post
    This charging issue is very annoying. I have had the same problem since the upgrade to 668. It persists with 840. I can't trust that the phone will charge overnight. Many times I wake up to find it dead. I've had mine for more than a year. If there is no fix then it's just a paperweight...
    Your charger may be the problem. Try using a different charger if possible. Maybe plug it into a computers USB port. It is slower and you should try to not use it while charging this way but it would be a chance to check if it is your device or charger.
    I hope this helps.
  9. PatrickMJS's Avatar
    CrackBerry Genius

    Posts
    1,654 Posts
    #9  

    Default

    On Saturday a week and a half ago, I had the same problem as the OP, so I phoned the 1-800 #, same one as posted by F2. After a few minutes of troubleshooting, they Fedex'd me a box to send it in. The box arrived last Tuesday. I sent it back same day. Got my replacement PB on Friday. Just restored from my backup, reinstalled my apps, and I'm back. But, sheeshl what a hassle. It happened right after I installed .668 and yes, I was using the native mail app.
    Patrick from Calgary
    ------------------------------
    Z10 STL100-3, OS version 10.2.1.2141
    PB 64 GB, OS version 2.1.0.1526

Posting Permissions