Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 62
Like Tree1Likes
  1. JustShan08's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    Thread AuthorThread Author   #1  

    Default Playbook Battery and Charging Issues

    I've had my playbook for 4 months and loved it until now. the other morning I had over 50% battery life, so I plugged it in with the supplied wall charger before work. After work I was using it and noticed my battery was down to 10%. I have that battery info app and checked my battery, but everything was blank. Usually it has battery meter, life, temp, state and all sorts of info, but this time it was showing nothing. So i plugged it in with the wall charger and noticed i was getting no charging symbol. Tried holding the charger in different positions, but nothing. Now the playbook is dead and won't start up. Just has the 1 red light and 5 yellow blinks when you press the power button. I've tried the tricks, hard reset, plug in for 2 minutes and off for 2. and pressing the power button every 5 minutes and still nothing. Are there any other tricks out there or am I going to have to send it back to RIM.
    thanks,

    Justin
  2. oscar_expansion's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #2  

    Default

    sorry to hear that.
  3. byul's Avatar
    CrackBerry Genius

    Posts
    3,232 Posts
    Global Posts
    3,241 Global Posts
    PIN
    K. 27F3DC2E put cb in request
    #3  

    Default

    It could be that you have no more battery life left over and your charging port is damaged.
    So it could be an issue like this Playbook sent to RIM for usb port repair,now its back!.
    So i assume you are trying charge it and start it up without any results?
    gee gee baby~
  4. #4  

    Default

    I would leave it plugged in over night and see what happens.

    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com
    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
  5. Chaddface's Avatar
    CrackBerry Genius

    Posts
    3,513 Posts
    #5  

    Default

    It sounds to me like your charger died. RIM will replace it under warranty. In the meantime try to flip the blades in and out a few times. If you have BB phone charger you could try that too.

    If the app you talking about is that free android app in app world, I read somewhere it was broken with the last update. Maybe unrelated to your problem.
  6. rotorwrench's Avatar
    CrackBerry Genius

    Posts
    1,995 Posts
    Global Posts
    2,001 Global Posts
    PIN
    Forget it
    #6  

    Default

    I agree with above, I think your charger is toast. Do you have access to another charger? Better yet, if you have access to a BB phone, use the charger on it and see if it charges. This will isolate the problem to the charger or the PB.
    Last edited by rotorwrench; 05-09-2012 at 12:55 AM.
    If I agreed with you we'd both be wrong.
  7. trevlan006's Avatar
    CrackBerry Abuser

    Posts
    109 Posts
    #7  

    Default

    I now have an issue too. my PB is on the rapid charger, since last night around 12-midnight, it was glowing gree-yellow to show it was charging and it still is this AM.

    but it is 100% drained still, it wont power on it shows the battery needs charging symbol. the light is still glowing green-yellow , not a solid green.. 8 hours of charging and still 100% empty.. whatt he ???
    On June 26th 2011 , My daughter Angelina Elizabeth Bianco passed away. She was Born Nov 27th 2006, My world ended when she died.[/URL]
  8. robsteve's Avatar
    CrackBerry Genius

    Posts
    3,747 Posts
    #8  

    Default

    Quote Originally Posted by trevlan006 View Post
    I now have an issue too. my PB is on the rapid charger, since last night around 12-midnight, it was glowing gree-yellow to show it was charging and it still is this AM.

    but it is 100% drained still, it wont power on it shows the battery needs charging symbol. the light is still glowing green-yellow , not a solid green.. 8 hours of charging and still 100% empty.. whatt he ???
    Try cleaning the charging contacts on the PlayBook and the rapid charger. You should also try using the stock charger and see if that works. If your battery is dead, you may need to leave it on charge for a couple hours.
  9. JustShan08's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    Thread AuthorThread Author   #9  

    Default

    Hi, I have tried another charger and still have the same issue. The playbook has also been charging for a couple days straight so it should have been charged up full by now. I checked for my 90 day free tech support and apparently it starts the day you bought your product so it has expired, which makes no sense since the product carries a 1 year warranty.

    Does the rapid charger charge through those 3 dots on the bottom? If so I could buy one and try that, but I'm not sure if it's even worth it at this point.
    What kind of lights would be on the playbook to indicate that it is infact charging with the screen off if the charger was working as it should?
  10. Chaddface's Avatar
    CrackBerry Genius

    Posts
    3,513 Posts
    #10  

    Default

    If everything is working correctly:
    PB turned off and charging will pulse green light and steady green when fully charged.
    Yes, the rapid charger uses that magnetic port(3 pins) on the far right.
    I'm sure RIM will ask you to use a factory charger before they will begin troubleshooting. It can't hurt to get a rapid charger.
    Even if the tech support is over they will try to help you fix the problem before offering a replacement.
    Last edited by Chaddface; 05-09-2012 at 11:07 PM.
  11. #11  

    Default

    Re: Tech Support

    I'm not sure they hold fast to that 90 days. My unit is nearly (or now maybe a year old) and I called last week. I proceeded to ask my question and trouble shooting began. I've called back and it continues.

    When I did call she only made mention of extending my tech support for 90 additional days. So, give it a try.

    Besides, if it is a warranty issue, yes, coverage is for a year. Again, I'm not sure how they screen tech support versus warranty. Same phone number.

    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com
    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
    Thanked by:
    dirty127 (06-22-2012) 
  12. JustShan08's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    Thread AuthorThread Author   #12  

    Default

    After a couple days of trying everything with the playbook, still nothing. Now none of the lights light up. I got my hands on a rapid charger and there's nothing doing there either. I wanted to try and get my stuff off of the playbook before sending it in, incase they offer me a new one. I wonder if they will transfer my pics and vids to it lol.
  13. peter9477's Avatar
    CrackBerry Genius of Geniuses

    Posts
    5,216 Posts
    Global Posts
    5,218 Global Posts
    #13  

    Default

    JustShan08, if you haven't tried it already, and can afford one, go buy a rapid charger and use that. Probably either your charger is dead, or the USB port is ruined. The rapid charger uses the other connector and it's more robust, so that may well work for you where the current one does not.
    Battery Guru for BB10 tracks voltage, power, battery health. (Also on the PlayBook.) White Noise helps you sleep or concentrate.
    Follow us on Twitter or Facebook or visit Engenuity's mobile apps page.
  14. #14  

    Default

    I don't recall what was tried or not but give the stack charge a try (but I don't know if the rapid charger works for stack charge. Try both ways. But first, play with your usb charger fold/unfold the prongs which folks report can be an issue.

    Here's what I've captured:

    I was told about "stack" charging, 6 cycles of charge no charge, for 2 minutes each, charging for never more than 2 minutes.


    Plug the PB in with the factory charging cable (red light comes on for a several seconds, then goes off). Wait about 10 more seconds. Unplug PB for about 30 seconds.

    Repeat n times.

    n == 6 for me. Finally my PB light switched to green, then began to oscillate, signalling charging. After a few more minutes my PB came back to life.

    I'd leave the usb end plugged in and unplug from the wall, just to create less force on the small usb port on the pb.

    Try stack with the rapid charger, too?????

    Good luck
  15. Scotter75's Avatar
    CrackBerry Abuser

    Posts
    414 Posts
    #15  

    Default

    Give it the 3 button reset. This should clear up all glitches. Plug it in to recharge and try it.
  16. JustShan08's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    Thread AuthorThread Author   #16  

    Default

    Thanks for the suggestions, but unfortunately i'm not getting anywhere with this pb. I tried stack charging with both chargers, 3 button reset and all that. Still have no led lights whatsoever. I guess i'll be calling RIM in the morning.
  17. SWAT-ron2k11's Avatar
    CrackBerry User

    Posts
    69 Posts
    PIN
    2B66DFE2
    #17  

    Default

    I have the SOLUTION !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! You need to plug into the wall as soon as the red light turns on connected to your computer with the Blackberry desktop manger open.
    After it wont be able to connect so try to update.... now leave it connected to the computer for about 5-10 min. (Dont worry what the desktop manger says)

    Come back and now connect it to the wall charger, the screen should turn on with the red battery signal and the led starts to glow yellow. And there it is it charging. you just have to wait.

    How do i know it works i just did it. If this works for you leave a reply or thanks so i know. Good luck !
  18. JustShan08's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    Thread AuthorThread Author   #18  

    Default

    Just wanted to update everyone, I called RIM about my playbook issues and they had me send it in for repair. The process was extremely fast, it took 7 days from the day i called to getting a new playbook in my hands. They said they were going to repair mine, but i received a new playbook in the mail today. Would have been nice to get an explanation as to what happened to my old playbook. Either way i'm back up and running.
  19. #19  

    Default

    Good to hear.
  20. BuachailMor's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #20  

    Default Charging issues

    I've had the same problems. Tried all the tricks and bought a rapid charger. I get a red flashing light and that is all. RIM support have been responsive however have had no suggestions which worked. They offered to repair the device, however told me I will lose my data (some of which I do not have backed up as I was on a biz trip with recently loaded data when the battery ran down to 0%). The real issue is that there is no point in using a PB, especially for business use, which runs the risk of losing all data if the battery runs flat. Looking at numerous blogs, it's clear this is not an uncommon issue. Whilst the PB has some great attributes, RIM launched a proto type which was not and is not ready to be marketed and still falls short of promises made prior to its original launch. I would rather have one of their competitors tablets, which although not as sleek as the PB, at least doesn't come with the worry that simply letting the battery drain will cause a drama and potentially lose all stored data.
  21. #21  

    Default

    Quote Originally Posted by BuachailMor View Post
    I've had the same problems. Tried all the tricks and bought a rapid charger. I get a red flashing light and that is all. RIM support have been responsive however have had no suggestions which worked. They offered to repair the device, however told me I will lose my data (some of which I do not have backed up as I was on a biz trip with recently loaded data when the battery ran down to 0%). The real issue is that there is no point in using a PB, especially for business use, which runs the risk of losing all data if the battery runs flat. Looking at numerous blogs, it's clear this is not an uncommon issue. Whilst the PB has some great attributes, RIM launched a proto type which was not and is not ready to be marketed and still falls short of promises made prior to its original launch. I would rather have one of their competitors tablets, which although not as sleek as the PB, at least doesn't come with the worry that simply letting the battery drain will cause a drama and potentially lose all stored data.
    I do sympathize with your situation. Lately, folks have found a shorter Stack sequence may work better. If you cannot rely on the pb while away from a "backup" computer it could be an issue. It would be nice if rim added support for usb devices to backup to a harddrive dongle. See the last comment below:

    Locked, bricked

    I was told about "stack" charging, 6 cycles of charge no charge, for 2 minutes each, charging for never more than 2 minutes.


    Plug the PB in with the factory charging cable (red light comes on for a several seconds, then goes off). Wait about 10 more seconds. Unplug PB for about 30 seconds.

    Repeat n times.

    n == 6 for me. Finally my PB light switched to green, then began to oscillate, signalling charging. After a few more minutes my PB came back to life.

    You might want to UNplug/Replug at the wall/socket end to avoid using or damaging the weaker usb port on the pb itself.


    Just talked to tech support, because i'm impatient sometimes. Here is the initial process they gave me to try.

    Plug in the charger for 2 mins, unplug for 10 sec -> Repeat 6 to 8 times

    Then while unplugged perform the Hard reset (POWER, VOL + and - at the same time) . **When the red light comes on PLUG IN THE CHARGER**

    The playbook is supposed to then start charging/boot.
    ...........................

    Some have now found a shorter sequence works:

    Oh man I fixed it. I stack charged it! But not for 2 minutes.

    Every time my PB red signal goes off I removed the connection from the wall charger and placed it back within a second. I repeated it for almost 25-30 times and all in the

    sudden a big charger button showed up on the screen and a green light on the charging LED. I left th e power connection for 2 more hrs and started using it.
    ast_ph likes this.
  22. CFJSS's Avatar
    CrackBerry User

    Posts
    33 Posts
    #22  

    Default

    Just completed the
    plug in until red light goes off repeatedly 14 - 18 times then got a green light and is now at 10% and charging thanks for this tip
  23. edyb's Avatar
    CrackBerry Addict

    Posts
    788 Posts
    Global Posts
    818 Global Posts
    #23  

    Default

    Just an EXTRA TIP for some of you...

    I found out that my charger with "swing out" or "foldable" prongs was the issue. This was released in Canada, not sure about other regions.

    You plug it in, everything looks like it is connected right, but no charging! (lightning bolt icon doesn't appear over battery)

    The WALL PART needs to be JIGGLED because the "swinging prongs" are not making proper contacts. The USB port is FINE... that is NOT the problem. It is actually the BIG END plugged into the wall.

    Sometimes I had to flip it upside down, jiggle and try again. After a few tries, look to make sure the lightning bolt icon appears!!!!

    You can also confirm by using your phone to test the charger. Keep wiggling it and turning it around until you verify it is charging the phone. If it is, unplug your phone and plug in Playbook at USB end without moving the wall end too much.

    Anyone else confirm this issue with the swinging prong version??!?


    Sent from my BlackBerry 9810 using Crackberry Tapatalk Forum app
  24. Chaddface's Avatar
    CrackBerry Genius

    Posts
    3,513 Posts
    #24  

    Default

    Anyone else confirm this issue with the swinging prong version??!?
    I have never had that problem but it's not the first time I heard that.
    I think all the stock chargers are the swinging prong version.
  25. Stephen Amador's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #25  

    Default

    Recently my playbook battery died completely and it doesnt even charge just four red led lights come on! When I plug it into a certain plug it
    charges and the green led light comes on but then it stays stuck on the Logo Screen "Black Berry Playbook" it is hot like its charging but it just stays there. I left it like that for a whole day and nada! I unplugged the usb from the book and it immediately shuts off. WTF?!
Page 1 of 3 123 LastLast

Posting Permissions