03-25-13 07:51 AM
28 12
tools
  1. Angus_CB's Avatar
    I have seen several people reporting the same problem I was having with bridged SMS.
    All conversations were showing up under 1 or 2 contacts. I had never texted these contacts.
    The problem has be posted 3 or 4 times in the main OS 2.1.0.1032 thread. The resolution was also posted there but gets lost in a 40+ page thread. I take no credit for solving this just posting it so others may find it easier.

    The problem seems to be caused by non numeric characters in contact phone number fields.
    In my case I had several work contacts that had ( ) - in the Pager and / or Fax fields.
    Others have reported the problem being caused by letters being in phone number fields.
    So, if you are having this problem check your contacts and make sure any phone number is complete. I have numbers store two ways that seem to cause no problems, (555) 555-1212 and 555-555-1212.
    10-04-12 03:38 PM
  2. drew8484's Avatar
    Great. I have over 900 contacts. Are you telling me I need to edit all of them?
    10-05-12 05:35 AM
  3. easydoesit99's Avatar
    Hmm. Just changed all my 9800 phone numbers so there are no symbols in the phone numbers. Nothing. No additional contacts appeared on my PB after rebooting both devices twice. NEXT!
    10-05-12 07:40 AM
  4. kenorian's Avatar
    Wow. I had a few numbers that had an "x" in front of them for "extension". Got rid of them - all good.
    10-05-12 12:31 PM
  5. slalom's Avatar
    This is a significant bug. Annoying. I'm glad to have sms over bridge but this sucks.
    10-05-12 12:38 PM
  6. Angus_CB's Avatar
    Hmm. Just changed all my 9800 phone numbers so there are no symbols in the phone numbers. Nothing. No additional contacts appeared on my PB after rebooting both devices twice. NEXT!
    Make sure you don't have extra phone, pager or fax numbers that contain just a space.
    10-05-12 04:57 PM
  7. Angus_CB's Avatar
    Great. I have over 900 contacts. Are you telling me I need to edit all of them?
    Only if you want SMS to work correctly.
    Are they Outlook contacts? It's easier to edit them on a PC.
    Heavens1 likes this.
    10-05-12 04:59 PM
  8. Jmaxim's Avatar
    All my phone numbers are in the format 7185551212. There are no spaces or special characters, however, SMS still does not work. Outgoing SMS creates a duplicate entry without the contact name and incoming SMS does not show on the PB.
    10-06-12 07:47 AM
  9. eds817's Avatar
    All my contacts were created in Outlook and the default format is (123) 456-7890. I'm not having any issues.
    10-06-12 07:53 AM
  10. Old Ag's Avatar
    I'm the one who first posted the non numeric SMS issue. The solution only solves the issue of all the SMS messages appearing under a single contact. It looks like the PB does some sort of lookup based on the phones address book. The lookup gets broken by certain non numeric characters. The best way to fix it is to look at the contact info of the name that is appearing for all the SMS messages. I have nearly 800 contacts and only one was causing issues. Once I fixed the entry, everything worked. YMMV.

    Old Ag
    10-06-12 08:57 AM
  11. obsessive_compulsive's Avatar
    Thanks for the info. I was having the problem of texting my son then, when adding to or reviewing the text later it would show a work mates name. What the heck... I hadn't texted her before. I checked her contact info on my phone and I had listed her work extension number in the WORK2 field with an 'x' in front of the number. x1234. Once I removed the 'x' my texting issues appear to have disappeared. I searched through my addresses and hers was the only one with the non-numeric character in a number field.
    Hgouck likes this.
    10-06-12 10:30 AM
  12. Jmaxim's Avatar
    I give up. I certainly hope whom ever RIM has doing update and testing for the PB is not doing same for BB10. Could prove quite disastrous for RIM.
    10-06-12 03:27 PM
  13. Angus_CB's Avatar
    All my phone numbers are in the format 7185551212. There are no spaces or special characters, however, SMS still does not work. Outgoing SMS creates a duplicate entry without the contact name and incoming SMS does not show on the PB.
    Try changing a contact to the 718-555-1212 format and send an SMS to that contact.
    10-07-12 09:28 AM
  14. drew8484's Avatar
    [QUOTE=Old Ag;7663890]I'm the one who first posted the non numeric SMS issue. The solution only solves the issue of all the SMS messages appearing under a single contact. It looks like the PB does some sort of lookup based on the phones address book. The lookup gets broken by certain non numeric characters. The best way to fix it is to look at the contact info of the name that is appearing for all the SMS messages. I have nearly 800 contacts and only one was causing issues. Once I fixed the entry, everything worked. YMMV.

    Worked like a charm. Thanks!
    10-07-12 12:01 PM
  15. Jmaxim's Avatar
    Try changing a contact to the 718-555-1212 format and send an SMS to that contact.
    I made the change, 718-555-1212, sent a message from the phone, it creates an entry on the PB, no name and number is recorded as +17185551212. The person responded, however, response does not show on PB.
    10-07-12 01:15 PM
  16. JimCanuck's Avatar
    Looking up the BlackBerry Phone contact which was causing the problem, sure enough there was an erroneous phone number; deleting the content (it was note even a number) fixed the problem.
    10-07-12 01:35 PM
  17. slalom's Avatar
    I had 6 or 7 contacts (of 1400 or so) that were causing the problem. Once I cleaned them up, everything works fine.
    10-07-12 07:32 PM
  18. b121's Avatar
    Sorry if I've missed it. my pb shows 2 sms as unread, but its in error. anyone posted a fix for this yet? thanks!
    10-07-12 08:08 PM
  19. slalom's Avatar
    Sorry if I've missed it. my pb shows 2 sms as unread, but its in error. anyone posted a fix for this yet? thanks!
    If you've tried "mark all read" and are still showing two unread, chances are that the two are in a folder somewhere. Check the saved folder first.
    10-08-12 08:29 AM
  20. b121's Avatar
    Thanks for the suggestion. All of my sms are marked unread on my bb, but still shows 2 unread on my pb.
    10-08-12 09:36 AM
  21. slalom's Avatar
    Thanks for the suggestion. All of my sms are marked unread on my bb, but still shows 2 unread on my pb.
    Try scrolling through all of your SMS on your PB looking for the unread. Perhaps there is a command to "goto last unread" ... if there is, let me know.

    I've had a similar problem with GMAIL, though it appears a little differently. After reading all messages, I'll have an indicator appear on both my playbook and my 9810 showing two unread messages. When I hit "u" on my 9810 to go to last unread, I get a message saying "no unread messages in list" even though the indicator would suggest otherwise.

    When I scroll through the same email account on my PlayBook, I usually find the two offending, previously read, messages showing as unread. These are always from the same sender. Deleting them or marking them read will clear up the indicator on both devices.

    I don't know what causes this, but I've learned to live with it!
    10-08-12 09:50 AM
  22. Berryuman's Avatar
    Only sms contacts that show up with #s on my playbook are only those associated with the mobile field.
    10-08-12 10:17 AM
  23. b121's Avatar
    Thanks! Yes, I deleted all of the SMS's on my playbook and couldn't find any as unread on my BB. I'm thinking it may just be a bug.
    10-08-12 08:00 PM
  24. derekchan's Avatar
    My single contact did have special characters. However, I deleted this single contact that was flagging bridge sms to indicate all sms under and resolved issue. I still have lots of other contacts that has a * for internal company call routing and it's affecting the indexing. Good luck all.
    10-12-12 08:22 PM
  25. DoctorNeutron's Avatar
    I too am having bridged sms problems. So is the symptom of y'all's problem related
    To transmission of sms to the RONG people or what? Doc Neutron
    10-13-12 02:25 AM
28 12
LINK TO POST COPIED TO CLIPBOARD