Results 1 to 24 of 24
  1. aft1981's Avatar
    CrackBerry Abuser

    Posts
    163 Posts
    Thread AuthorThread Author   #1  

    Default Emails disappearing from messages application

    I thought I was imagining it, so I tested it over the past few hours...emails in my mailbox in the messages app disappear after an hour or so. Where do they go? Anybody else having this problem, can it be stopped, is there a simple setting? (I have looked, but can't find any relevant options).

    It's a pop3 account that I use for work. The account is also my main email account on my Bold 9930. I have both the Bold and the PB account settings to not delete emails from the server once they have been downloaded to the device, and only Outlook has that permission set. That way I know every email I get will be picked up by Outlook, but I have no reason for emails to remain on the Network Solutions server once they are received by Outlook.

    All I can think is that the PB, unlike the Bold, doesn't save emails locally, and constantly checks and sync's with the server, even though it's a pop3 account? Therefore if there are no emails on the server, then the PB deletes them from the messages app? This seems ridiculous to me and pretty much makes the new messages app on the PB redundant. I don't want to change Outlook to leave messages on the server, as I get so many, and with an average of 200-300mb of pdf attachments a week, I don't want the server to get full up.

    Any ideas?
  2. calles's Avatar
    CrackBerry Abuser

    Posts
    170 Posts
    #2  

    Default

    I initially had Message Sync Timeframe set to 1 day - I didn't realize what this setting was, so I would see a new message, but then it was 'gone'. Anyway, when I set the timeframe to 7 days everything was good - becasue that allows up to the last 7 days of messages to be displayed. Not sure if this is your problem, but thought I would mention it.
  3. aft1981's Avatar
    CrackBerry Abuser

    Posts
    163 Posts
    Thread AuthorThread Author   #3  

    Default

    The only option I can find like that is the 'Sync Interval' option (in the Accounts Setup screen), which runs from 15mins to 24 hours. I presumed that was how often the PB checks the server for new messages, not how long it keeps them on the device? Is there another option somewhere else?
  4. calles's Avatar
    CrackBerry Abuser

    Posts
    170 Posts
    #4  

    Default

    'Settings' (gear thing in upper right hand corner of home screen) / select 'Accounts' / select the email account you want to modify / select 'advanced settings' and scroll down to 'Messages Sync Timeframe ...again though, not sure if this is your problem.
  5. aft1981's Avatar
    CrackBerry Abuser

    Posts
    163 Posts
    Thread AuthorThread Author   #5  

    Default

    I don't have the 'advanced settings' option? I select accounts, select my email account, which takes me to the screen which has description...display name...username...email address...password...server address....port...use ssl....smtp username....smtp password....server address...port....encryption....syn interval...keep messages on server...and that's it. No option for 'advanced settings anywhere, and no option for 'messages sync timeframe'.
  6. calles's Avatar
    CrackBerry Abuser

    Posts
    170 Posts
    #6  

    Default

    See screen prints (i've never attached anything, so hope it works) ...
    Attached Thumbnails Attached Thumbnails Emails disappearing from messages application-img_00000013.jpg   Emails disappearing from messages application-img_00000014.jpg  
  7. sputneek's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,782 Posts
    Global Posts
    7,783 Global Posts
    #7  

    Default

    Quote Originally Posted by aft1981 View Post
    I don't have the 'advanced settings' option? I select accounts, select my email account, which takes me to the screen which has description...display name...username...email address...password...server address....port...use ssl....smtp username....smtp password....server address...port....encryption....syn interval...keep messages on server...and that's it. No option for 'advanced settings anywhere, and no option for 'messages sync timeframe'.
    I don't have that screen coming up that way either on my sympatico account. I noticed that Calles pulled up a Google account. Looks like it's different for POP accounts?
  8. calles's Avatar
    CrackBerry Abuser

    Posts
    170 Posts
    #8  

    Default

    Good eye, sputneek ...looks like I never took that into consideration, and after checking my other mail accounts, I see you are correct!
    Thanked by:
    sputneek (02-24-2012) 
  9. sputneek's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,782 Posts
    Global Posts
    7,783 Global Posts
    #9  

    Default

    Just glad to be of some help, I'm pretty new at this myself
  10. aft1981's Avatar
    CrackBerry Abuser

    Posts
    163 Posts
    Thread AuthorThread Author   #10  

    Default

    Thanks for trying lol.

    However, question still remains.....does anyone else have a problem with emails disappearing from their messages account? If not, does anyone else have a pop account set up on it, who also uses outlook, and who has outlook (or another mail program) delete messages from the server once they are downloaded into outlook?

    As it is, the mail application is completely useless.
  11. VerryBestr's Avatar
    CrackBerry Abuser

    Posts
    376 Posts
    #11  

    Default

    Quote Originally Posted by aft1981 View Post
    ...emails in my mailbox in the messages app disappear after an hour or so. .... It's a pop3 account that I use for work. The account is also my main email account on my Bold 9930. I have both the Bold and the PB account settings to not delete emails from the server once they have been downloaded to the device, and only Outlook has that permission set. That way I know every email I get will be picked up by Outlook, but I have no reason for emails to remain on the Network Solutions server once they are received by Outlook. ...
    The behavior you're seeing doesn't seem that unreasonable to me.

    Suppose a mail server allows both POP and IMAP access. An IMAP client can selectively delete messages on the server. How should a POP client react to this situation? There is really no clearly prescribed way it should react.

    In the original implementation of POP, emails were generally deleted soon after they were delivered to the ciient. But later, a "pseudo" synchronous mode was developed in which the email could remain on the server until the client decided to delete the mail on the server, when the user deleted the same email in the client. But there was also a different way of using mail remaining on the server -- here, the client was configured to leave the email on the server for a certain number of days as a sort of mail backup. These two reasons for leaving email on the server are somewhat incompatible.

    In these earlier implementations, a mail server delivered mail by either POP or IMAP, but not both. Now it is common for servers to deliver mail by POP, IMAP and ActiveSync. There is no clear definition of what a POP client should do when, "behind its back" so to speak, another client is messing around with its mail on the server. POP was designed for one client per mailbox.

    It sounds like the PlayBook mail client is trying to synchronize its inbox with the mail on the POP server. This is one way of interpreting what a POP ciient should do. Does the PlayBook have no advanced options that mention synchronization for POP mail?

    In any case, POP is a terrible way to access mail from more than one client -- it is just not designed for this situation. You would probably be better off accessing your mail via IMAP (or ActiveSync if available) from all of your clients, or at least, as many as possible.
    Last edited by VerryBestr; 02-25-2012 at 04:56 PM.
  12. cblguy's Avatar
    CrackBerry Newbie

    Posts
    8 Posts
    #12  

    Default

    Yes,I'm having a similar issue. I'm using a Microsoft Exchange account and the emails disappear as well. I thought it had something to do with me restarting, but it did it again today with no warning.
  13. yweleung's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #13  

    Default

    I'm having similar problem, but it's on my Hotmail account. There're a few emails that I viewed this morning through the Playbook message client, and now when I try to find them again, they were nowhere to be found. I logged into my Hotmail account from my desktop and I still can't find those emails. They're not in the Trash folder either, so I'm not sure how the Playbook message client somehow managed to delete those email from the Hotmail server without me initiating a delete.
    Thanked by:
    dc scotland (05-19-2013) 
  14. jarviser's Avatar
    CrackBerry Abuser

    Posts
    248 Posts
    #14  

    Default

    Quote Originally Posted by cblguy View Post
    Yes,I'm having a similar issue. I'm using a Microsoft Exchange account and the emails disappear as well. I thought it had something to do with me restarting, but it did it again today with no warning.
    Exchange activesync connection has a unique problem with all mails disappearing locally from pb, probably on change of wifi connection, not yet acknowledged byRIM but hopefully they have noticed as it affects their business users.

    Try changing sync period from 7 to 30 days and see if they resync. You will have to keep doing it,alternatively delete account and reinstall every time it happens.
    Thanked by:
    thewison (05-12-2012) 
  15. thewison's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    #15  

    Thumbs up Similar Problem Here

    Quote Originally Posted by jarviser View Post
    Exchange activesync connection has a unique problem with all mails disappearing locally from pb, probably on change of wifi connection, not yet acknowledged byRIM but hopefully they have noticed as it affects their business users.

    Try changing sync period from 7 to 30 days and see if they resync. You will have to keep doing it,alternatively delete account and reinstall every time it happens.
    Thanks, for your post. I reset my wireless router yesterday and subsequently lost my email on my Playbook which is hosted on an Exchange server.

    Thank you for the work-around with the changing of the sync period. I have my email back .
  16. polgara59's Avatar
    CrackBerry Abuser

    Posts
    193 Posts
    #16  

    Default

    Quote Originally Posted by aft1981 View Post
    Thanks for trying lol.

    However, question still remains.....does anyone else have a problem with emails disappearing from their messages account? If not, does anyone else have a pop account set up on it, who also uses outlook, and who has outlook (or another mail program) delete messages from the server once they are downloaded into outlook?
    I haven't had messages disappear from my Outlook after viewing them on my PB, but they *are* disappearing from my PB. I haven't paid close enough attention to see what the time frame is for the disappearance, and I know I'm not deleting them (a couple refer to hotel reservations I have made that I need to keep on my PB); they just vanish -- poof!

    I suppose it's a way of keeping my inbox on the PB clean, but I'd really rather take care of that myself! The only saving grace in my situation is that the emails are not disappearing from the servers -- Gmail anyways.
  17. #17  

    Default

    Quote Originally Posted by polgara59 View Post
    I haven't had messages disappear from my Outlook after viewing them on my PB, but they *are* disappearing from my PB. I haven't paid close enough attention to see what the time frame is for the disappearance, and I know I'm not deleting them (a couple refer to hotel reservations I have made that I need to keep on my PB); they just vanish -- poof!

    I suppose it's a way of keeping my inbox on the PB clean, but I'd really rather take care of that myself! The only saving grace in my situation is that the emails are not disappearing from the servers -- Gmail anyways.
    I believe from what I've read, there's a 30 day limit on holding emails. If you want to save them you will have to do something else with them.
    Thanked by:
    polgara59 (12-28-2012) 
  18. scalemaster34's Avatar
    CrackBerry Genius

    Posts
    3,876 Posts
    #18  

    Default Re: Emails disappearing from messages application

    depending on the settings of he account on the PlayBook it could be as few as 7 days up to 30 days max. you can adjust it for each account

    but 30 days is not very long... means you will have to use your browser or another device to go back futher than that.
    Thanked by:
    polgara59 (12-28-2012) 
  19. kwelamnp's Avatar
    CrackBerry Abuser

    Posts
    184 Posts
    #19  

    Default

    I have set my laptop mail program to leave mail on my ISPs POP server (also have Gmail and Outllok.com accounts set to do same) When I check mail, on the PB, if I delete it, it will delete the message on the server. I actually find this quite handy. I use the Playbook to delete mail, that I do not want to keep, immediately. The mail I do want is saved on my laptop. No problem so long as you use the laptop fairly regularly and set the PB to retain mail for 30 days.
    Thanked by:
    polgara59 (12-28-2012) 
  20. scalemaster34's Avatar
    CrackBerry Genius

    Posts
    3,876 Posts
    #20  

    Default

    Quote Originally Posted by kwelamnp View Post
    I have set my laptop mail program to leave mail on my ISPs POP server (also have Gmail and Outllok.com accounts set to do same) When I check mail, on the PB, if I delete it, it will delete the message on the server. I actually find this quite handy. I use the Playbook to delete mail, that I do not want to keep, immediately. The mail I do want is saved on my laptop. No problem so long as you use the laptop fairly regularly and set the PB to retain mail for 30 days.
    But you shouldn't have too... If someone wanted to keep all their email for 6 months, 1 Year or even 2 Years - if they had enough memory they should be able to do it! Or the app should be able to request the older mail like most email apps seem to do.
  21. kbz1960's Avatar
    Doesn't Matter

    Posts
    55,736 Posts
    Global Posts
    55,891 Global Posts
    #21  

    Default

    Is this from the inbox? What happens if you move them to a different folder?
    Sent from me using my fingers. Be pantless in 5K. Febreze - for more than smells.
    the 50K CrackBerry challenge
    I'm no more qualified to say so because I own a BlackBerry
  22. redoak47's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #22  

    Default

    "No problem so long as you use the laptop fairly regularly and set the PB to retain mail for 30 days."

    How do I set the PB to retain mail for 30 days? I can't find it. That would be much better than my messages all disappearing in a week as happens now.
  23. JJonPB's Avatar
    CrackBerry Abuser

    Posts
    130 Posts
    #23  

    Default

    It's an old thread, I know... My problem is related, but somehow different: if I leave Messages application open during PB reboot, all messages from my ActiveSync work account get wiped out. That one particular mailbox is just empty after the reboot, and no amount of sync attempts brings these emails back on my PB (all emails stay on the server, as well as on my Z10).

    Anyone experience similar issue?
  24. JJonPB's Avatar
    CrackBerry Abuser

    Posts
    130 Posts
    #24  

    Default

    Quote Originally Posted by JJonPB View Post
    It's an old thread, I know... My problem is related, but somehow different: if I leave Messages application open during PB reboot, all messages from my ActiveSync work account get wiped out. That one particular mailbox is just empty after the reboot, and no amount of sync attempts brings these emails back on my PB (all emails stay on the server, as well as on my Z10).

    Anyone experience similar issue?
    Am I alone with this issue?...

Posting Permissions