Page 1 of 2 12 LastLast
Results 1 to 25 of 42
Like Tree11Likes
  1. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #1  

    Question Android apps opens but while loading...crashes, but after reboot, works perfectly fine..but not long

    Hey guys,

    I don't know if this is a common problem, but when I have been using my playbook for some time, and when I open an android app, I wait for the blackberry logo shining for a minute, and it just crashes. Then I open again, and same thing. So I reboot, and now it loads so fast. And then after a few hours, it cycles..

    Is this common? Is there any setting I can change to prevent this?

    Please let me know!

    Thanks.
  2. DC506's Avatar
    CrackBerry Abuser

    Posts
    490 Posts
    Global Posts
    535 Global Posts
    PIN
    Pin:s & Needle:s
    #2  

    Default

    Too many android apps running at once or in background, using up memory????? Maybe download a task killer app.
    “If I had my life to live over again, I'd be a plumber.” - Albert Einstein
    sw6lee likes this.
  3. SCrid2000's Avatar

    Posts
    10,371 Posts
    Global Posts
    10,383 Global Posts
    PIN
    PM me.
    #3  

    Default

    Quote Originally Posted by DC506 View Post
    Too many android apps running at once or in background, using up memory????? Maybe download a task killer app.
    That's what it sounds like to me too.
    Android has a built in feature to shut down extra apps you're not using if they're causing problems, but I don't think that was ported to the PlayBook (also, running two OSes takes more RAM than just running one).
    sw6lee likes this.
  4. djenkins6's Avatar
    CrackBerry Genius

    Posts
    1,787 Posts
    Global Posts
    1,803 Global Posts
    #4  

    Default

    The android player is a lot better under 1088 but still buggy.... After running a few android apps a reboot solves the issues for a whille.

    I tried a task killer but after using it, it corrupted something and I ended up doing a wipe and reinstall of everything so for now I live with occasional reboots.
    sw6lee likes this.
  5. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #5  

    Default

    Quote Originally Posted by djenkins6 View Post
    The android player is a lot better under 1088 but still buggy.... After running a few android apps a reboot solves the issues for a whille.

    I tried a task killer but after using it, it corrupted something and I ended up doing a wipe and reinstall of everything so for now I live with occasional reboots.
    Yea, this is what's happening to me..I have Memory Eater from a long time ago, but it's not functional that well..so does memory eater corrupt mine too? I'm asking because my playbook doesn't seem to open many android apps that I sideloaded. When I first got the tablet, when i side loaded android apps, almost every single one opened up and operated fine, but now a LOT of them are just force closing..
  6. rkennedy01's Avatar
    CrackBerry Addict

    Posts
    664 Posts
    #6  

    Default Re: Android apps opens but while loading...crashes, but after reboot

    Quote Originally Posted by sw6lee View Post
    Yea, this is what's happening to me..I have Memory Eater from a long time ago, but it's not functional that well..so does memory eater corrupt mine too? I'm asking because my playbook doesn't seem to open many android apps that I sideloaded. When I first got the tablet, when i side loaded android apps, almost every single one opened up and operated fine, but now a LOT of them are just force closing..
    It sounds like you have upgraded in place one too many times. Wipe and start fresh. That's what I did and now 1088 is rock stable for me. I use mostly Android apps (TapaTalk, gReader, Swarm, ESFE, Google Maps) and I almost never have to reboot.

    RCK

    Sent from my BlackBerry Runtime for Android Apps using Tapatalk 2
    sw6lee likes this.
  7. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #7  

    Default

    Quote Originally Posted by rkennedy01 View Post
    It sounds like you have upgraded in place one too many times. Wipe and start fresh. That's what I did and now 1088 is rock stable for me. I use mostly Android apps (TapaTalk, gReader, Swarm, ESFE, Google Maps) and I almost never have to reboot.

    RCK

    Sent from my BlackBerry Runtime for Android Apps using Tapatalk 2
    Really?? Wow..I should try wiping it. Actually, I wiped a few weeks ago, but I backed up all my data, setting, and everything on blackberry desktop manager, and after wiping, I restored everything again.

    So doing this doesn't really wipe the entire thing? Should I NOT back up and restore this time?

    Thanks!
  8. #8  

    Default

    Quote Originally Posted by sw6lee View Post
    Really?? Wow..I should try wiping it. Actually, I wiped a few weeks ago, but I backed up all my data, setting, and everything on blackberry desktop manager, and after wiping, I restored everything again.

    So doing this doesn't really wipe the entire thing? Should I NOT back up and restore this time?



    Thanks!
    I'll only comment on the highlighted portion - you should make a backup of any unique data/files, especially any that may have changed or been added since the last time. As for restoring, some folks feel that depending on what you restore - settings or apps - you might be reintroducing erroneous settings or bad apps. But that could mean trying to weed out the problematic items or issues.
    Last edited by F2; 11-25-2012 at 03:48 PM.
    sw6lee likes this.
  9. jpash549's Avatar
    CrackBerry Genius

    Posts
    1,630 Posts
    Global Posts
    1,856 Global Posts
    #9  

    Default

    Get Advanced App Manager from BB app world. Has a task killer function and lets you see what is running. Assume you have upgraded to 2.01 OS.
    sw6lee likes this.
  10. #10  

    Default

    Quote Originally Posted by jpash549 View Post
    Get Advanced App Manager from BB app world. Has a task killer function and lets you see what is running. Assume you have upgraded to 2.01 OS.
    Just looking for clarification. I have "Advanced Manager" and am wondering if that is the same as "Advanced App Manager?" I've seen others also refer to Advanced App Manager. The one I've got - Its icon is a filing cabinet drawer slightly open.

    Thanks in advance
    sw6lee likes this.
  11. pacoman03's Avatar
    CrackBerry Genius

    Posts
    3,107 Posts
    #11  

    Default

    Advanced Manager on your PB is called Advanced App Manager in app world.
    Thanked by:
    F2 (11-25-2012) 
    sw6lee likes this.
  12. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #12  

    Default

    Hey guys,

    Thanks for all your replies. I have wiped my tablet and now I started from scratch, and android apps work MUCH better! After some while, it will still have that blackberry logo shining while loading android apps, but it never just closes, and it loads eventually. Then after this app loads fine, other android apps I open after that loads instantly again!

    BUT! I now have a different problem... It's really weird.. I need help! So the problem is that when I open an android apps and If I move away to another app, suddenly the android app is gone. It closes by itself without notifying me. So I reopen it, and if I move on to another app, same thing! It just disappears! I think it only happens to android apps. Also another thing is if I turn off screen while on android app, and keep it standby for sometime and come back, the android apps shows black screen and I have to keep swiping to get the android app to show on the screen again. I hope you understand. Also, when I swipe up while on android apps, it is not 100% smooth as before. It stutters a little bit, and also black color flashes on the android app window. It's really weird. I really hope I don't have to wipe again...but do you guys have any idea?

    I really need to get this fixed..

    Thanks!!
  13. pacoman03's Avatar
    CrackBerry Genius

    Posts
    3,107 Posts
    #13  

    Default

    How many, if any, sideloaded apps are you running, and any MP3 downloader apps?
  14. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #14  

    Default

    Quote Originally Posted by pacoman03 View Post
    How many, if any, sideloaded apps are you running, and any MP3 downloader apps?
    Well yesterday when this was happening, I had qPDF free version open, and I was playing Tiny Bird, and qPDF was keep closing while I was playing Tiny Bird. I think Repligo PDF closed too. And today, I had FolderSync open doing nothing, and I went to another app, and folder sync was just gone. So I reopened it, and this keeps happening. I don't run that many sideloaded apps at once. And even though not that many, if an android app is open for some time, the tablet slightly stutters while doing basic operations, where playbook was super smooth other times. It's not unbearably stuttering, but it's kind of annoying as it is supposed to be smooth. And black screen occurred a few times too.

    I do have an mp3 downloader app, which is Music Download, I think from Handster, but after I wiped the tablet last time (didn't restore any btw), I just redownloaded this app but never opened it yet.

    Any ideas...?
  15. pacoman03's Avatar
    CrackBerry Genius

    Posts
    3,107 Posts
    #15  

    Default

    The reason I asked was because I had another sideloaded MP3 downloader app that was causing me problems with the android player, whether open or not. What happened was that any time I would open an android app, and then minimize the app, when I brought the app back up, the screen would be black and I'd have to close it and then reopen it. This got to be annoying, so I wiped my PB, and the problem seemed solved. Then I started reloading my sideloaded apps, ten at a time, checking the android player each time. At some point, the problem came back, so I then uninstalled the previous ten sideloaded apps untill the problem went away. I traced the problem to the MP3 downloader app, since after I uninstalled it the problem went away, and reinstalling it brought the problem back. So I uninstalled it once more and trashed the bar file, and the problem hasn't come back. As I said, the problem was there even if the app wasn't running- why, I don't know. . Anyhow, I'd suggest uninstalling all of your sideloaded apps and then reinstalling one at a time to see if you can isolate the problem.
    F2 and sw6lee like this.
  16. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #16  

    Default

    I wiped again, but I backed up and restored only my settings, which was about 1MB.

    I still have the same problem though.. It seems like the android player is having hard time keeping 2 or more android apps open. I only have android apps from app world right now, and if I open two android apps, and switch between them by swiping up from the bottom (not left or right, not sure about this), sometimes the app window flashes black colour, and sometimes one of them reloads when I click it. And while using one of them, and swipe up, the other one shows a completely black window, and if I click that window, it maximizes, but completely black screen. But If I keep swiping from the top or do weird stuff, the app screen comes back to normal..And I believe If I keep using other apps, the android apps will close by itself as well, just like when I started having this problem. NONE of these were occuring until a few days ago though. Running quite a few android apps had no problem, and they weren't closing or the window wasn't flickering.

    I'm not sure what to do.. I really hope I don't need to send it for repair..?? I don't like going through that kind of process..I just want this to work properly. It only happens with android apps..

    Any more advices are welcome..
  17. SparkyBC's Avatar
    CrackBerry Master

    Posts
    1,101 Posts
    #17  

    Default

    Android player isn't 100% error proof. Even if an app appears to be working on it in can do mysterious things the longer it runs. If you side load the apps all the more reason they screw up.
  18. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #18  

    Default

    Quote Originally Posted by SparkyBC View Post
    Android player isn't 100% error proof. Even if an app appears to be working on it in can do mysterious things the longer it runs. If you side load the apps all the more reason they screw up.
    As I said..I don't have any sideloaded apps right now after I wiped, but I still have this problem. Also..This didn't happen few weeks ago..Every android app was stayed open just fine..without flickering or reloading..
  19. #19  

    Default

    Quote Originally Posted by sw6lee View Post
    As I said..I don't have any sideloaded apps right now after I wiped, but I still have this problem. Also..This didn't happen few weeks ago..Every android app was stayed open just fine..without flickering or reloading..
    Do you recall the order in which you added new apps or Android apps? You might try reversing the INSTALLS and try deleting them - remove the newest first and go back.

    I, too, am getting more Black screens when switching but I don't recall what apps I might have added more recently that might have caused the issue. I wonder if just reboot more often might clear it up - kind of extraordinary housekeeping to clean out the cobwebs.
  20. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #20  

    Default

    Quote Originally Posted by F2 View Post
    Do you recall the order in which you added new apps or Android apps? You might try reversing the INSTALLS and try deleting them - remove the newest first and go back.

    I, too, am getting more Black screens when switching but I don't recall what apps I might have added more recently that might have caused the issue. I wonder if just reboot more often might clear it up - kind of extraordinary housekeeping to clean out the cobwebs.
    Thank god i'm not the only one!! I actually don't think it's an app that's causing the problem because I only have few apps right now that I've always been using, and still the problem is there. I'll list the apps I have: Air browser, evernote, Wunderlist, Korean KB, LauncherYouTube, Recipe Box, Scrapbook, SimpleBrowser+, Speedtest, Dolphin Browser. The only android apps I have, which are both from app world, are Wunderlist and dolphin. And If I have both of them open, and also another native playbook app, and I switch between them, I keep seeing black flickering on one of the android apps open. And I bet if I keep using one of the three apps, at least one of the android apps will close itself, or show black screen completely, if you know what I mean..

    EDIT: Btw, this is after I tried your suggestion where I deleted all the new apps that I recently installed..
  21. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #21  

    Default

    K..I'm starting to feel like playbook was always acting like this (I mean the android apps..). Well...I really don't think so, but I just security wiped one more time and with NO backup or restore, and after the tablet booted up on the newest firmware, I download JUST two apps, which are android: Wunderlist and Dolphin browser. And the problem is still there..

    I am not sure what's wrong, or not even sure if there is anything wrong now...
  22. #22  

    Default

    I can only speculate that the newest OS taxes the memory of the pb more than the prior OS but that is speculation. Maybe rim tweaked (and broke or partially messed up) some other aspect of the Android player. The app I use the most is Words W/Friends and that does seem to freeze up more than in the past but maybe I'm playing it more or running more other apps. Also, for me, I'm down to about 2.5 to 3 gigs of memory - I need to clean up more.
  23. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #23  

    Default

    Omg...I'm having exactly same problem as before again!! After using the tablet for some time, If i open an android app downloaded from app world, the blackberry logo shines, and then the app crashes. D:< How many time did I wipe this tablet..What should I do now..
  24. sw6lee's Avatar
    CrackBerry User

    Posts
    48 Posts
    Global Posts
    51 Global Posts
    Thread AuthorThread Author   #24  

    Default

    So Nobody else has the Android apps closing problem?

    I'm really getting frustrated now that I can't keep qpdf app opened! It closes SO easily when I open other apps..and android apps keep showing black screen too when switching between apps..

    I've wiped my tablet at lest 5 time in a few days..and am too exhausted to do that anymore..I wonder if there is any setting I can change? I don't know why this started recently! It has never been acting like this for few months of having this tablet..

    Could you guys at least tell me if you guys are NOT having the problem, or I'm not along??

    Possible solutions are welcome too..

    Thanks.
  25. #25  

    Default

    Quote Originally Posted by sw6lee View Post
    So Nobody else has the Android apps closing problem?

    I'm really getting frustrated now that I can't keep qpdf app opened! It closes SO easily when I open other apps..and android apps keep showing black screen too when switching between apps..

    I've wiped my tablet at lest 5 time in a few days..and am too exhausted to do that anymore..I wonder if there is any setting I can change? I don't know why this started recently! It has never been acting like this for few months of having this tablet..

    Could you guys at least tell me if you guys are NOT having the problem, or I'm not along??

    Possible solutions are welcome too..

    Thanks.
    Did you add any new apps, either from appworld or sideloaded ones? Did you maybe add a bunch of files (data) to the pb, that may be using more of its memory or storage.

    When you say you "wiped" your tablet - what did you do? Did you totally REinstall the OS using the Desktop software or merely use the Security wipe options.

    I'm also reluctant to go that step at restoring a 64 gig pb takes a long time.
Page 1 of 2 12 LastLast

Similar Threads

  1. My Android apps runs perfectly...but?
    By JVRudnick in forum PlayBook Android App Sideloading
    Replies: 3
    Last Post: 03-15-2012, 08:27 AM
  2. AppWorld and Android Apps. Quantity but little Quality.
    By Rgainsmi in forum PlayBook Apps & Games
    Replies: 11
    Last Post: 03-13-2012, 06:25 PM
  3. OS 2.0 but no android apps available
    By MrClem89 in forum BlackBerry PlayBook OS
    Replies: 7
    Last Post: 02-21-2012, 10:33 AM
  4. Correct ot state that Android app can run on PB but..
    By Mom2Fab5 in forum PlayBook Apps & Games
    Replies: 2
    Last Post: 04-23-2011, 02:26 PM
  5. 8310 crashing minutes after reboot
    By savocado in forum BlackBerry Curve 83xx
    Replies: 2
    Last Post: 07-09-2009, 10:09 AM

Posting Permissions