Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. ricardoarlington's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Thread AuthorThread Author   #1  

    Default Big Problems with WIFi on my Blackberry 8120

    Hello all,

    I am a first time BB owner, and I just signed up to Crackberry. I'll admit that I am initially signing up because I really need help, but I have been reading posts and I think I will stay on after this!

    OK, so here's my situation: I have a brand new Blackberry Pearl 8120 from AT&T, I'm in Palo Alto, California, and I absolutely for the life of me cannot get WiFi to work on this thing. I did not purchase the data plan because every where I go I get free WiFi (home, work, most of the way walking to work down University Avenue). I've been fooling around with it every day for a week, and I have been reading the posts on Crackberry, and none of the advice to previous posters seems to work for me. Forgive me in advance if I write like a newb on this topic!

    ---

    The phone is a Blackberry Pearl 8120, which is supposed to have WiFi independent of AT&T's data plan, the reason I bought it.

    Initially I was using the internet browser thinking I was using my home WiFi network, but after calling AT&T I found out that in fact I had been using AT&T 's data plan all along (and I got dingged $$ for it!). So to be sure that I wasn't using AT&T's data plan, I had AT&T add what's called "NO WIX" to the account, a feature which blocks the AT&T data pan from being used on my phone. The AT&T tech guy said that with NO WIX added, if I was on the internet at all I would know for a fact that it was WiFi and not AT&T.

    I have attempted to use a number of WiFi networks, so the problem is almost certainly with my phone and not with my home WiFi. I've attempted to connect to a WEP protected network at home (I entered the WEP key), and 4 or 5 different open networks including a solid one at Stanford Campus which works fine on my other devices.

    When I go to "Set up WiFi Connection" / "Scan For Networks", it finds my home network (called "Lolita"), asks me for my WEP kep, and once I enter it it says "connected". There is a small padlock, a green check mark, and 4 of 5 bars in green.

    In "Manage Connections", the "WiFi" box is checked. On my home screen in the top middle it says "AT&T - Lolita", which I assume means that the phone thinks I am connected to those two networks. On the home screen, top right, the WiFi symbol is there but it is grey in color.

    Under "WiFi Options", "WiFi Selection Mode" is set to "Manual" (though I have also tried "Automatic"), and my network "Lolita" is at the top of the list of "Saved Wi-Fi Profiles." Next to "Lolita" there is a small round yellow circle with a line through it.

    Under "Mobile Network Options", "Data Services" is "On", and Mobile Network is "At&T".

    Under "Settings" / "options" / "Browser", "Default Browser" is set to "Hotspot Browser" (though I have also tried the other option, "Media Net").

    When I click on the Browser or the Gmail Application, the internet does not work. Sometimes I just get a screen that says "AT&T" in big black letters. And sometimes there is a dialogue box that says something about not being in an area with data capabilities. Also when I try to use Gmail I get "this program requires a working data connection, etc etc"

    When I called AT&T tech support, the call started off badly because the technician didn't even KNOW that the 8120 had WiFi capabilities until I told him about it! I worked with him for 30 minutes, we couldn't fix it, and he finally said "unfortunately we don't offer support for this aspect of your phone" or something similar! LOL

    So... I'm begging all of you to please offer any help you can! Thanks for reading my long *** post, and your time is very much appreciated.

    Look for ward to hearing from you, and let me know if there's anything else I can describe for you.

    Rick
  2. bmcclure937's Avatar
    CrackBerry Genius of Geniuses

    Posts
    6,864 Posts
    Global Posts
    6,995 Global Posts
    #2  

    Default

    I read through your post... first of all, do you have a data plan?

    Secondly, please follow the link for the WiFi guide... in my signature!

    Thirdly, Welcome to CrackBerry and I hope we can help!!
    No longer a CrackBerry addict. Moved to Android - could not be happier!
  3. ricardoarlington's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Thread AuthorThread Author   #3  

    Default

    Hi,

    Nope, I don't have a data plan. I did not get it on purpose since I have WiFi almost everywhere I go. However, before AT&T added "NO WIX" to my account, I did have a pay per use in place (unfortunately).

    I had a look at your awesome guides already, great work on those, but I can't seem to figure it out even with those!

    Thanks,

    Adrian
  4. bmcclure937's Avatar
    CrackBerry Genius of Geniuses

    Posts
    6,864 Posts
    Global Posts
    6,995 Global Posts
    #4  

    Default

    I do not know this for a fact, but I think that ATT Berries cannot use the WiFi for data when they do not have a data plan on the line... I do not know from experience because I do all of my testing on TMobile.

    I hope an ATT WiFi user can step in and make some comments!
    No longer a CrackBerry addict. Moved to Android - could not be happier!
  5. EnamelCoating's Avatar
    CrackBerry User

    Posts
    12 Posts
    #5  

    Default

    I'm having the same prob. I've read every post and did all the search on the 8120 and wifi. I am with ATT/Cingular. Yes, followed that guide.....

    someone tell us how to get this working. and, oh, i am connected, but its a yellow circle with a minus sign. so i still cant get the browser to load. and i have also turned off data in the manage option.

    someone help us
  6. pimpcane19's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #6  

    Default

    I am having the exact same problem as enamelcoating.
  7. dknyberry's Avatar
    CrackBerry Abuser

    Posts
    456 Posts
    Global Posts
    457 Global Posts
    PIN
    Buh Bye Pearl
    #7  

    Default

    Works fine for me. I'm on AT&T with an 8120, but I do have the data plan. Maybe they disable the wifi capability somehow if you don't sign up for their data plan.
  8. BlackPearl890's Avatar
    CrackBerry Genius

    Posts
    1,614 Posts
    PIN
    ......
    #8  

    Default

    i also have an 8120 with no data plan (but with Claro), my settings are exactly as yours and my wi-fi works both at home and college, about the "small round yellow circle with a line through it" it's always like that, and the apps we'll some DO need a data plan in order to work

    here are some links you might find useful, hope you figure it out

    http://forums.crackberry.com/f65/can...nection-57850/

    http://forums.crackberry.com/f33/can...ta-plan-36286/

    http://forums.crackberry.com/f65/bla...se-wifi-29376/

    http://forums.crackberry.com/f65/wif...tt-only-66445/

    Good Luck!

    i ♥ my 8900!!! (5.0.0.509)
    blackpearl890@crackberry.com

    Follow me on Twitter*
  9. m11stephen's Avatar
    CrackBerry Abuser

    Posts
    381 Posts
    PIN
    24AFCD3C
    #9  

    Default

    In order to use WIFI on the AT&T 8120, you need to have a data plan. Tmobile, however, lets you use WIFI without a data plan so you may consider switching to that.

Posting Permissions