1. ka-lin's Avatar
    Hi everyone,
    Yesterday I have noticed that my device becomes unusually hot, and battery drains too fast. Even when it is plugged to AC charger, the charger (OEM BB) becomes very hot.
    Here is a screenshot of my system:
    Android Runtime high CPU usage-img_20170417_070950.png

    Android Runtime high CPU usage-img_20170417_070942.png

    Attachment 421380

    I'm on 10.3.3.1463, have updated my phone 1 monts or so ago, with not any problems until yesterday.

    Any suggestions will be appreciated..

    Posted via CB10
    04-16-17 11:28 PM
  2. conite's Avatar
    Hold power button down until device begins restarting. Then don't touch it for 15 minutes.
    04-16-17 11:37 PM
  3. ka-lin's Avatar
    Unfortunately, this didn't help, device still generates some heat, and uses high CPU resources....I have turned network services off, nothing changes. Restarted my phone several times, nothing..

    Posted via CB10
    04-17-17 12:51 AM
  4. elfabio80's Avatar
    Your Android player consume is very very high. Do you have many android apps installed. Maybe some of them or only one is getting you some problems. Try to unistall one. Extreme solution, do a security wipe or use an autoloader. I hope it helps.

    Posted via CB10
    04-17-17 01:27 AM
  5. ka-lin's Avatar
    I didn't installed any new Android apps these days, so I assume there is no anything wrong with them. I have turned off WiFi, and the phone cools down, and CPU usage goes back to normal, well, for now..Now I will monitor battery drainage and phone temperature to be sure the Wifi is the main reason.
    I cannot explain this to myself.
    04-17-17 02:33 AM
  6. ka-lin's Avatar
    Even now Android Runtime seems to consume more battery, even at idle mode, when device is not used:

    Android Runtime high CPU usage-img_20170417_114020.png

    Posted via CB10
    04-17-17 03:45 AM
  7. Rico4you's Avatar
    Hello have you recently installed 10.3.3?
    In case..
    http://support.blackberry.com/kb/art...nguage=English

    Posted via CB10
    04-17-17 06:30 AM
  8. ka-lin's Avatar
    Very interesting...So they didn't find a solution yet? I have installed 10.3.3 version a few weeks ago, so the 24h settling period was ended anyway. I'm still hoping for an solution before hard reset and OS reloading..
    Meanwhile, Android Player still consumes more battery, than System:

    Android Runtime high CPU usage-img_20170417_175919.png

    Is that normal, or I'm just getting paranoid?
    Thanks!

    Posted via CB10
    04-17-17 10:02 AM
  9. Invictus0's Avatar
    What apps are showing high usage in the CPU tab?
    04-17-17 10:32 AM
  10. ka-lin's Avatar
    System and Android Player are most CPU usage consumers:

    Android Runtime high CPU usage-img_20170417_183947.png

    Android Runtime high CPU usage-img_20170417_184001.png

    Posted via CB10
    04-17-17 10:43 AM
  11. elfabio80's Avatar
    Did you settle with Blue Mail your email in push? Maybe this could be the culprit. The email in push consumes a lot also with BB10 native system.

    Posted via CB10
    04-17-17 01:45 PM
  12. JD Wu's Avatar
    I had this exact same issue. I assume it's from updating a certain android app. A hard reset seems to have fixed it for me. Hold Up+Down volume. Are you able to connect to BlackBerry Link.
    Last edited by JD Wu; 04-17-17 at 09:57 PM.
    04-17-17 07:37 PM
  13. ka-lin's Avatar
    Fixed. Just reloaded OS via autoloader, then got the following:

    Android Runtime high CPU usage-img_20170418_065052.png

    Much, much better than before.

    Not installed Google Play services, yet..I'm not sure will they affect battery performance as well?
    I've installed a few Android apps.


    Posted via CB10
    04-17-17 10:55 PM
  14. armchairtycoon's Avatar
    Disable blackberry protect and turn off location services

    Overheating will stop

    Thanks

    Posted via CB10
    04-18-17 12:58 AM

Similar Threads

  1. m Most Secure Android Phone
    By Coyote55 in forum BlackBerry Priv
    Replies: 7
    Last Post: 05-10-17, 04:23 PM
  2. Problem to install a working Android WhatsApp on BB10.3.3.1463.
    By Andre Dourado in forum Ask a Question
    Replies: 7
    Last Post: 04-22-17, 12:04 AM
  3. Android version
    By Elite trader in forum BlackBerry Passport
    Replies: 3
    Last Post: 04-16-17, 10:31 PM
  4. BlackBerry runtime for Android?
    By evodevo69 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 04-16-17, 10:30 PM
  5. Android Wear 2.0 and BBM
    By Hilton_K in forum BlackBerry Android OS
    Replies: 2
    Last Post: 04-15-17, 09:51 PM
LINK TO POST COPIED TO CLIPBOARD