Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. hormazd.mistry's Avatar
    CrackBerry Newbie

    Posts
    8 Posts
    PIN
    221c6572
    Thread AuthorThread Author   #1  

    Default Whatsapp doesn't work on Wi-Fi

    I'm currently facing a unique issue.

    I'm travelling abroad and was hoping to keep in touch with my friends and family via WhatsApp. While I'm at home I've a full data plan which allows me to browse the internet as well as use the chat applications, hence WhatsApp works for me without any issues.

    I do not have an international roaming plan & hence my phone stays on "SOS" mode here in the foreign country. When I connect to wi-fi here, my broiwser works & I'm able to browse websites, twitter for blackberry works and it shows me twitter updates; however WhatsApp doesn't work. When I send a message, it shows me a clock icon & then stays on that screen.

    If anyone has any clue on why WhatsApp isn't working on Wi-Fi please let me know. Any information that you may be able to share will prove helpful to me.

    Thanks and regards,
    Hormazd
  2. Elite1's Avatar


    Posts
    12,919 Posts
    Global Posts
    13,059 Global Posts
    PIN
    C0001F61B
    #2  

    Default

    Hmmm... I can't find a setting within WhatsApp for delivery method. Could have sworn there was.
    Oh well!

    I have 3 ideas for you:

    1. Is your WA version current? Their support page in Twitter says out-of-date versions may have issues?

    2. Have you tried actually turning your wireless network OFF instead of leaving it as "SOS"? Open your Manage Connections app and click the Wireless Network box at the very top to uncheck it.

    3. Are your Permissions all set to Allow? Open your Options app, open Applications, scroll to WhatsApp and click your MENU key. Select Edit Permissions, then ensure all Permissions are set to Allow.
    Saving the world, one OS at a time...

    Follow Me On Twitter: @elite1_
    How to Lock/Password-Lock/Unlock for newer OS for Bold 99xx/97xx/9650, Torch 98xx, Tour 9630, Storm2, Curve 93xx/8900

    Curve 8330Tour 9630Bold 9700Torch 9800Bold 9900Z10
    Z30
    psst... Here's THANKS button
  3. natlama's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #3  

    Default

    I was actually having the same problem just now, and by playing with it, i fixed it! I just went to Options, Networks and connections, Wifi-network and allow the hotspot to my computer, and boom! All my emails came flushing down
  4. ntombi trudies zondo's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #4  

    Default

    hi im ntombi i have a problem with my blackberry whatsapp,couse i cant make a profile picture couse its dont allow me .i dont know what a problem please help me ,i tried many time but nothing .nd ever ppl send me vidio,or picture .i cant se that picture
  5. ntombi trudies zondo's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #5  

    Default

    please help
  6. Joel Kunjumon's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #6  

    Default

    does anyone know how to make whatsapp work on wifi ??? it was working all this while den it asked to update ,i updated and den it stoped workin on wifi
  7. johnthebig's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #7  

    Default

    You can make it work with aerize wifix.
  8. ML Thakur's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #8  

    Default Whatsapp not working with WIFI only

    NO BIS plan..WIFI Only internet service
    whatsapp not working. installed Aerize Wifix but it worked olny once a day for few minutes.
    found serial for Aerize wifix but its still not working.
    BB handset BOLD 9900
    kindly advise a solution

Posting Permissions