Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 4 1234 LastLast
Results 1 to 25 of 84
  1. MarcPandora's Avatar
    Pandora

    Posts
    312 Posts
    Thread AuthorThread Author   #1  

    Default Pandora 1.0.3

    We're happy to announce the release of our latest version of Pandora on the BlackBerry. You can download and install it by pointing your BlackBerry browser to http://www.pandora.com

    As always, if you have any problems feel free to email our support staff at pandora-support@pandora.com and they will be more than happy to help you. They really do answer every email!

    Here is a summary of some of the changes in this build:

    - Support for Wi-Fi on devices that have it (using a high quality AAC-HE stereo audio stream)
    - Bluetooth support (you can now explicitly enable it and disable it rather than relying on the default audio routing in the device)
    - Options screen (accessible from Station List menu) to select preferences for Bluetooth and Wi-Fi (on wi-fi capable devices)
    - Support for the Nextel 8350i (only over Wi-Fi)
    - Keyboard shortcuts, including pause/play functionality using the mute key (even when Pandora is running in the background)
    - Focus cursor on Now Playing screen should be easier to control on trackball devices
    - Various other minor enhancements and fixes


    In anticipation of some of the questions that may come up, here are some additional notes:

    - To re-iterate: you can get to the "Options" screen from the menu on the "Station List" screen
    - By default Bluetooth is disabled. Once enabled, it will try to use A2DP and if that fails, regular Blutooth. If no Bluetooth channels are working (i.e. no BT headsets are paired and on), the regular audio paths will be used (headphones or speakerphone)
    - If you add or remove a Bluetooth headset while music is playing in Pandora, you may need to pause/play the song for the correct audio routing to kick in (or wait for the next song to start)
    - In our testing, not all A2DP headsets worked properly with all BlackBerry devices. However, these headsets also had problems playing music with the native media player so this issue seems to be out of our control. For example, on a Curve 8330 the Sony DR-BT160As headset exhibited "crackling" and tempo shifts (audio playing slower than it should) in both Pandora and the BlackBerry media player
    - Not all mono Bluetooth headsets are capable of playing music
    - When using both Bluetooth A2DP and Wi-Fi, the audio may cut out for brief periods during network activity. We're currently investigating the cause of this.
    - The 8350i is "Wi-Fi only" because in our testing, the iDEN mobile network was not fast enough to keep up with our audio streams
    - Stereo AAC-HE streams over the mobile network will have to wait, we're still working on some issues
    - Still no resolution on audio issues encountered by some Storm devices (songs starting from beginning after a call, not auto-advancing, etc.)
    - Keyboard shortcuts are as follows:
    SPACE or mute key - Play/Pause (mute key works while Pandora is backgrounded, too)
    S - Skip
    U - Thumb up
    D - Thumb down
    L - Station list
    C - Close ad
    M - More info for ad

    Also, just a friendly reminder that if you are using Pandora over the mobile network you WILL need a BlackBerry data plan with "unlimited" data. If you have any problems connecting to Pandora please email pandora-support@pandora.com and they can walk you through some troubleshooting steps to try and resolve your problems.

    Thanks!

    Marc @ Pandora
    Last edited by MarcPandora; 04-29-2009 at 10:21 PM.
  2. cdf3's Avatar
    CrackBerry Genius

    Posts
    3,029 Posts
    Global Posts
    4,593 Global Posts
    #2  

    Default

    Thanks for the update info. Just downloaded the updated version.

    Posted from my CrackBerry at wapforums.crackberry.com
  3. ArmaK's Avatar
    CrackBerry Genius of Geniuses

    Posts
    7,894 Posts
    #3  

    Default

    Thanks for the update.

    Posted from my CrackBerry at wapforums.crackberry.com
  4. vinmontRD's Avatar
    CrackBerry Addict

    Posts
    816 Posts
    #4  

    Default

    Thanks Marc -- just downloaded and installed on my 8900. Looks good so far...
  5. josh05's Avatar
    CrackBerry Abuser

    Posts
    276 Posts
    #5  

    Default

    Thanks. Pandora rocks!

    Posted from my CrackBerry at wapforums.crackberry.com
  6. duck383's Avatar
    CrackBerry Master

    Posts
    1,238 Posts
    Global Posts
    1,285 Global Posts
    PIN
    794B3A96 (Gs4) / 280D52AD (Bold)
    #6  

    Default

    thanks checkin it out now
  7. cdf3's Avatar
    CrackBerry Genius

    Posts
    3,029 Posts
    Global Posts
    4,593 Global Posts
    #7  

    Default

    I wish Pandora could allow me to choose if I wanted to go to my stations page without playing the previous station upon startup. There are times when I load Pandora, I'd rather not listen to the last station played before shutting down the application from the previous session. If I want to listen to a different station I have to wait to the previous station loads, then stop it, go to my stations page, and then I'm able to choose another station. That's my only gripe.

    Posted from my CrackBerry at wapforums.crackberry.com
  8. MarcPandora's Avatar
    Pandora

    Posts
    312 Posts
    Thread AuthorThread Author   #8  

    Default

    Quote Originally Posted by cdf3 View Post
    I wish Pandora could allow me to choose if I wanted to go to my stations page without playing the previous station upon startup. There are times when I load Pandora, I'd rather not listen to the last station played before shutting down the application from the previous session. If I want to listen to a different station I have to wait to the previous station loads, then stop it, go to my stations page, and then I'm able to choose another station. That's my only gripe.

    Posted from my CrackBerry at wapforums.crackberry.com
    I'll suggest this to our product development team - it seems like something that might belong in the "options" screen.

    Thanks for the suggestion!

    Marc @ Pandora
  9. cdf3's Avatar
    CrackBerry Genius

    Posts
    3,029 Posts
    Global Posts
    4,593 Global Posts
    #9  

    Default

    Thanks. I've been looking for it in the options section, but could never locate it. I can't wait until they add this feature.

    Posted from my CrackBerry at wapforums.crackberry.com
  10. peike's Avatar
    CrackBerry User

    Posts
    38 Posts
    #10  

    Default

    Thanks Marc, This is GREAT!!
    No problems running this version with Storm .122 OS songs seem to advance fine.

    Not to sound Nagging, cuz it's not but have you heard any rumours about a stereo version yet?

    I'd even pay if the sound quality was great [not that it isn't good already].

    UPDATE: The new player played the first two songs with no problems. However, the player stopped after the second song -0:00 but did not go to the new song. What is interesting is the fact that it thinks the song is still playing but it will not let you pause it. Not sure what to do other than close and reopen player. When pressing the advance button. Message reply is "Please wait until the next song is completely loaded".

    Guess I will have to retract original statement of "no problems with songs advancing".

    Thanks,

    --Joey
    Last edited by peike; 04-30-2009 at 01:13 AM.
  11. MarcPandora's Avatar
    Pandora

    Posts
    312 Posts
    Thread AuthorThread Author   #11  

    Default

    Quote Originally Posted by peike View Post
    UPDATE: The new player played the first two songs with no problems. However, the player stopped after the second song -0:00 but did not go to the new song. What is interesting is the fact that it thinks the song is still playing but it will not let you pause it. Not sure what to do other than close and reopen player. When pressing the advance button. Message reply is "Please wait until the next song is completely loaded".
    Thanks Joey - we're working hard with RIM to figure out why the Storm does this sometimes, even on the latest .122 firmware. If I can't get information this week I'll be sure to corner some engineers next week at WES 2009 to get some answers. In the meantime, thanks for your patience!

    Marc @ Pandora
  12. digitalb0y's Avatar
    CrackBerry Genius

    Posts
    2,011 Posts
    PIN
    KY AND THE BRAIN, BRAIN, BRAIN...
    #12  

    Default

    Thanks for the heads up Marc! By the way, do you know what changed in version 1.0.2 that made it break on Bolds running OS 5.0? And do you know if 1.0.3 fixes whatever it is that made it break in 1.0.2?

    I know that 5.0 is not an official platform yet and don't expect you to address it before it's time, so I'll absolutely be patient, but it would be nice to know WHEN there's a version that will work with 5.0 so I don't keep overwriting my working 1.0.1 version with a version that doesn't work and have to restore from backup.
  13. MarcPandora's Avatar
    Pandora

    Posts
    312 Posts
    Thread AuthorThread Author   #13  

    Default

    Quote Originally Posted by digitalb0y View Post
    Thanks for the heads up Marc! By the way, do you know what changed in version 1.0.2 that made it break on Bolds running OS 5.0? And do you know if 1.0.3 fixes whatever it is that made it break in 1.0.2?

    I know that 5.0 is not an official platform yet and don't expect you to address it before it's time, so I'll absolutely be patient, but it would be nice to know WHEN there's a version that will work with 5.0 so I don't keep overwriting my working 1.0.1 version with a version that doesn't work and have to restore from backup.
    We haven't tested on 5.0 (our test matrix on supported phones and networks is big enough as is!) so I don't know what would have changed in 1.0.2 to cause it to not work - but you are more than welcome to give 1.0.3 a try and report on your findings. I'm sure other adventurous beta testers on 5.0 would like to know.

    Marc @ Pandora
  14. ImGeorgeous's Avatar
    CrackBerry Addict

    Posts
    750 Posts
    Global Posts
    751 Global Posts
    #14  

    Default

    1.0.3 on WiFi is very, very choppy!
  15. digitalb0y's Avatar
    CrackBerry Genius

    Posts
    2,011 Posts
    PIN
    KY AND THE BRAIN, BRAIN, BRAIN...
    #15  

    Default

    Thanks Marc!

    Unfortunately the news is bad so far for 5.0 users though. Icon shows up, but when you I click it:



    That's with all permissions set to allow, after installing directly over 1.0.1. I'll try a clean install, but then I might have to drop back down for this version. Thanks anyway, Marc!
    Attached Thumbnails Attached Thumbnails Pandora 1.0.3-screenshot.png  
  16. futureeuqb's Avatar
    CrackBerry User

    Posts
    21 Posts
    PIN
    31E6D161
    #16  

    Default

    Thanks for the update!
  17. ibegary's Avatar
    CrackBerry User

    Posts
    26 Posts
    Global Posts
    38 Global Posts
    #17  

    Default

    Works great on my 8230.
  18. zaxxon's Avatar
    CrackBerry Abuser

    Posts
    136 Posts
    Global Posts
    139 Global Posts
    #18  

    Default

    +1 for the request below. I wish there was a setting that would say "Play last station on startup: Y/N" where if "N" it will simply start Pandora into the my stations list and wait for station selection.

    Quote Originally Posted by cdf3 View Post
    I wish Pandora could allow me to choose if I wanted to go to my stations page without playing the previous station upon startup. There are times when I load Pandora, I'd rather not listen to the last station played before shutting down the application from the previous session. If I want to listen to a different station I have to wait to the previous station loads, then stop it, go to my stations page, and then I'm able to choose another station. That's my only gripe.

    Posted from my CrackBerry at wapforums.crackberry.com
  19. haxit's Avatar
    CrackBerry User

    Posts
    51 Posts
    #19  

    Default

    Quote Originally Posted by digitalb0y View Post
    Thanks Marc!

    Unfortunately the news is bad so far for 5.0 users though. Icon shows up, but when you I click it:



    That's with all permissions set to allow, after installing directly over 1.0.1. I'll try a clean install, but then I might have to drop back down for this version. Thanks anyway, Marc!
    Well Thats not good. 1.01 worked on 5.0.. 1.02 broke on 5.0.. and 1.03 is still broke on 5.0.. Come on 5.0.0.120 we are ready to meet you!
  20. LimeTwyst's Avatar
    CrackBerry User

    Posts
    24 Posts
    #20  

    Default

    Hmmm well I was all excited thinking this would be great - I had gotten 1.0.1 to work on my Curve after adjusting some of the permissions, but now I've installed 1.0.3 and have run with default permissions and also tried several changes to the default permissions (aside from allowing PIM - I refuse to do that - too much sensitive data there), I can't get it to run.

    I've uninstalled and reinstalled too.

    The error is "Could not connect due to a security exception. Please check firewall settings."

    Help?
  21. fritter's Avatar
    CrackBerry User

    Posts
    45 Posts
    #21  

    Default

    does anyone have 1.0.1 link or file?
  22. MarcPandora's Avatar
    Pandora

    Posts
    312 Posts
    Thread AuthorThread Author   #22  

    Default

    Quote Originally Posted by LimeTwyst View Post
    Hmmm well I was all excited thinking this would be great - I had gotten 1.0.1 to work on my Curve after adjusting some of the permissions, but now I've installed 1.0.3 and have run with default permissions and also tried several changes to the default permissions (aside from allowing PIM - I refuse to do that - too much sensitive data there), I can't get it to run.

    I've uninstalled and reinstalled too.

    The error is "Could not connect due to a security exception. Please check firewall settings."

    Help?
    You may need to disable or reset the firewall to run the application. The option to do so is under: Options -> Security Settings -> Firewall.

    When you get to the Firewall page, there may be a tiny red lock symbol next to the word "Enabled".

    If not change that to "Disabled" and save the change.

    If you do see the lock you won't be able to turn the firewall off. However you may still be able to disable the specific rule that blocks us. Each rule has a separate line, and a a check box next to it. Uncheck the box next to Blackberry Internet Service and save the change. Then try Pandora again.

    Marc @ Pandora
  23. H_D
    H_D is offline
    H_D's Avatar
    CrackBerry Genius

    Posts
    1,685 Posts
    Global Posts
    2,563 Global Posts
    PIN
    GTalk
    #23  

    Default

    Great update!
  24. brad9920's Avatar
    CrackBerry User

    Posts
    38 Posts
    Global Posts
    39 Global Posts
    #24  

    Default

    Verizion said even on the BB unlimited plan you will be charged for streaming!
  25. H_D
    H_D is offline
    H_D's Avatar
    CrackBerry Genius

    Posts
    1,685 Posts
    Global Posts
    2,563 Global Posts
    PIN
    GTalk
    #25  

    Default

    Quote Originally Posted by brad9920 View Post
    Verizion said even on the BB unlimited plan you will be charged for streaming!
    Wooow, that sux man. Switch to Sprint, they dont.
Page 1 of 4 1234 LastLast

Posting Permissions