1. Sheyi's Avatar
    I have a Blackberry Bold from Germany and it came without MMS capability? Does anybody know how or why? And would I be better off downloading a software that does have the MMS? I cannot log into facebook mobile neither and I think it is due to the lack of MMS. Someone help! Thanks.
    09-20-08 12:29 PM
  2. Allyson Kazmucha's Avatar
    I have a Blackberry Bold from Germany and it came without MMS capability? Does anybody know how or why? And would I be better off downloading a software that does have the MMS? I cannot log into facebook mobile neither and I think it is due to the lack of MMS. Someone help! Thanks.
    MMS is a carrier provision from what I understand. it is carrier dependent. The bold is capable of sending/receiving MMS but the carrier has to provision it.

    My guess is your carrier doesn't support it.
    09-20-08 12:31 PM
  3. avmsam's Avatar
    call ur provider... they may need to send the service books
    09-20-08 12:35 PM
  4. bodisaffa's Avatar
    Carrier dependant for MMS give them a call . Facebook is data , also carrier dependant give a call they should set you up

    Posted from my CrackBerry at wapforums.crackberry.com
    09-20-08 12:38 PM
  5. sunkast's Avatar
    MMS is a carrier provision from what I understand. it is carrier dependent. The bold is capable of sending/receiving MMS but the carrier has to provision it.

    My guess is your carrier doesn't support it.
    Tmobile supports MMS on all BBs. Telus, and Sprint do not support MMS on any BB. Verizon will only support MMS on BBs that have a camera. Alltel will only support MMS on the 8330.

    The problem comes down to service books. Try resending your service books from the TMobile BIS site. You could be out of luck though as I have heard that the Bold requires it's own service books. So using the Bold on a carrier that does not sell it, does not have the service books.
    09-20-08 12:38 PM
  6. bodisaffa's Avatar
    p.s. welcome to CB
    09-20-08 01:11 PM
  7. laurent08's Avatar
    My bold wasn't receiving MMS initially, even though all other data services were working ...

    I just sent an MMS to myself (I.e.: from my bold to my own number), seems that triggered it to start working.

    Try it.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-21-08 02:02 AM
LINK TO POST COPIED TO CLIPBOARD