Page 1 of 2 12 LastLast
Results 1 to 25 of 33
Like Tree4Likes
  1. spoonjab's Avatar
    CrackBerry User

    Posts
    14 Posts
    Thread AuthorThread Author   #1  

    Default Gmail, Google Maps, Opera Mini, YahooGo, GoogleVoice for Blackberry ALX

    Please note that all these programs work on a Sprint Blackberry Pearl with firmware 4.3. Users have reported other blackberrys working, but no promises.

    I did about 6 hours of searching to get the latest versions of Gmail, GoogleMaps, and Opera Mini on my new Blackberry Pearl v4.3. The internet community was very helpful with getting ALX install files for GoogleMaps and OperaMini, but completely failed on a non-OTA (over the air) new version of Gmail (2.0). Gmail version 1.1 through ALX install was available in a couple places.

    I use SERO on Sprint and so I get unlimited data usage, but not on the Blackberry network (that means no Blackberry internet browser, and no blackberry email).

    All my installations require an install over USB through Blackberry Desktop Manager with ALX/COD files because the Blackberry internet browser is missing.

    I am using a 8130 Pearl with v4.3 and all the linked programs may or may not work on other version of the BB.

    To install these programs:
    1. unzip each program to a separate folder on your desktop
    2. run Blackberry Desktop Manager (I installed mine via the CD that came with the phone)
    3. click Application Loader > Next
    4. click the Add button and navigate to the folder of the program you want to install. The only file that will show up is the ALX file. Open it. You're done!

    Note: you probably want to back up the ZIP's because these files are hard to find.

    Gmail 2.0.6 ALX
    Google Maps 2.3.2 ALX
    Google Maps 3.0.2 JAR
    Opera Mini 4.2 ALX
    Yahoo!Go 3.0.47 ALX - Created this one myself!
    Google Voice 0.1.415 ALX - Created this one myself!
    Gmail 2.0.6 for fimrware 4.7 ALX - Created this one myself!


    NOTE: Google Maps 3.0.2 includes a .JAR file, not .ALX for installing. All you have to do is copy the whole folder to your media card. Then go to the "Media" app and press the option button (left of trackball). Choose 'explore'. Find the .JAR file and open it. It will install from there.

    I am currently looking for the installation files for Facebook, versions lower than 1.5. If you have them let me know! (apparently versions 1.5 & 1.6 don't work on firmware 4.3)


    User superm1 has created this amazing thread about getting your blackberry to include MMS and the Blackberry Browser on non BIS/BES phones. Using firmware 4.5, he says you can do "over the air" installations. This eliminates the need to install using USB. When following his instructions, make sure to press ALT + 'S' 'S' 'B' 'E' 'B'
    Attached Files Attached Files
    Last edited by spoonjab; 07-19-2009 at 02:14 PM. Reason: Updated GoogleMaps/GoogleVoice version
    Thanked by 5:
    Clrd4appr (02-27-2012),  Joshua Tenpenny (09-05-2012),  kafkacell (12-03-2012),  Lilia Galitska (12-09-2012),  tchekov13 (03-21-2012) 
    Clrd4appr and Lilia Galitska like this.
  2. Tony Wei's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #2  

    Default

    Spoonjab,

    Thanks for posting. Is there anyway that you can post GoogleMaps 2.3.2 alx again? Thanks!
  3. decepticon's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #3  

    Default

    thanks for the files! I am on a Sprint SERO plan and have to load with DM. I do however get an error when trying to load the gmail app on my 8830. I get "Error starting googlemail:symbol" "deviceinfol.getsoftwareversion" not found

    any ideas?
  4. ls2ttgto's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #4  

    Default

    I am getting this same error as well.

    "Error starting googlemail:symbol" "deviceinfol.getsoftwareversion" not found

    Any ideas?
  5. jockil's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #5  

    Default

    I got the same error when install 2.0.6. Uninstall (remove) and then install the 2.0.5, it worked.

    Perl 8100 4.2

    Thanks
  6. bbnewbie123's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #6  

    Default Thank You!

    just want to thank you for all the great stuff you have posted! it will save me soo much work! THANKS again!

    (btw, i created this account just to say "thank you")...lol
    mobahil likes this.
  7. jimmycali's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    #7  

    Default

    Thanks a bunch for posting this. Looking forward to using it. I'm on a BB8310 (Ver 4.5.x) on AT&T. Just disconnected my BB plan for the cheaper generic version. I was also able to install the app on the phone using AppLoader. However, when trying to run it on the phone, both GMail and YahooGO apps popped up w/ a message telling me that I dont have internet access. How does one get around this?

    I tested the internet access w/ opera and logicMail. Both work fine. I even uninstalled, then re-installed the apps and did a manual battery disconnect to reboot the phone. I've even disabled my firewall..no luck

    Please help!

    -Jimmy
  8. koteswar's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #8  

    Default

    Dear Spoonjab avatar,

    You are awesome, your help is unforgettable. I installed google mail, yahoo 3.0 and google maps, all successfully on my Sprint SERO phone, Blackberry Curve 8330m.

    Please tell me your favourite charity organization, I will donate $15 on your name.

    thanks
    sincerely
    Kotes
  9. spoonjab's Avatar
    CrackBerry User

    Posts
    14 Posts
    Thread AuthorThread Author   #9  

    Default

    Updated post with Google Voice 0.1.415 (just came out from google today). Google Voice is the old Grandcentral service.

    It should work on all blackberrys.
  10. spoonjab's Avatar
    CrackBerry User

    Posts
    14 Posts
    Thread AuthorThread Author   #10  

    Default

    Quote Originally Posted by koteswar View Post
    Dear Spoonjab avatar,

    You are awesome, your help is unforgettable. I installed google mail, yahoo 3.0 and google maps, all successfully on my Sprint SERO phone, Blackberry Curve 8330m.

    Please tell me your favourite charity organization, I will donate $15 on your name.

    thanks
    sincerely
    Kotes
    My favorite charity is... I don't have one. You could donate my way tho: twistedmetal2002 at yahoo.com. Through paypal.
  11. spoonjab's Avatar
    CrackBerry User

    Posts
    14 Posts
    Thread AuthorThread Author   #11  

    Default

    Quote Originally Posted by jimmycali View Post
    Thanks a bunch for posting this. Looking forward to using it. I'm on a BB8310 (Ver 4.5.x) on AT&T. Just disconnected my BB plan for the cheaper generic version. I was also able to install the app on the phone using AppLoader. However, when trying to run it on the phone, both GMail and YahooGO apps popped up w/ a message telling me that I dont have internet access. How does one get around this?

    I tested the internet access w/ opera and logicMail. Both work fine. I even uninstalled, then re-installed the apps and did a manual battery disconnect to reboot the phone. I've even disabled my firewall..no luck

    Please help!

    -Jimmy
    Sorry, I have no idea why those apps aren't connecting. I'm on sprint SERO (which uses a generic data plan). It seems weird that Opera is working and the others aren't. I'm guessing its something on the side of AT&T. My phone just asks me if i want to allow internet access to each program, i set it to "always allow" and that's it.
  12. superm1's Avatar
    CrackBerry User

    Posts
    34 Posts
    Global Posts
    101 Global Posts
    #12  

    Default

    In a different thread i've posted a set of service books that get you MMS and internet access. Load those up and you can install all these apps OTA (like normal folks on BIS too). Far easier
  13. bainsstatic's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Global Posts
    16 Global Posts
    #13  

    Default

    Quote Originally Posted by superm1 View Post
    In a different thread i've posted a set of service books that get you MMS and internet access. Load those up and you can install all these apps OTA (like normal folks on BIS too). Far easier
    Could you please link the thread? Been waiting for this for AGES
  14. superm1's Avatar
    CrackBerry User

    Posts
    34 Posts
    Global Posts
    101 Global Posts
    #14  
  15. thinknate's Avatar
    CrackBerry User

    Posts
    47 Posts
    Global Posts
    196 Global Posts
    #15  

    Default

    Thanks for posting the files and info!

    Does GPS work within Google Maps for any of you SERO users? Mine doesn't seem to.
  16. superm1's Avatar
    CrackBerry User

    Posts
    34 Posts
    Global Posts
    101 Global Posts
    #16  

    Default

    wfm. Never had any problems with my GPS.
  17. whiba's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    Global Posts
    28 Global Posts
    #17  

    Default

    this thread:

    forums.crackberry.com/f35/facebook-1-5-os-4-2-1-4-5-a-183302/index2.html

    has a link to the Facebook 1.2 files. Downloaded and worked great for me!


    I'm new, so i can't post direct links apparently. Add the http in at the beginning.
  18. riomadera's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #18  

    Default

    Kotewar,

    I too have a BB 8830 Curve and the SERO plan but I am having such a difficult time installing any of the .alx files (ex. Gmail, GMaps etc.). I have BB OS 4.5.

    What is your version. Is my phone defective? I literally cannot install any of the apps from the forum you mentioned you were able to get all the apps from.

    Your help is much much appreciated.

    Thanks!
  19. DD1968's Avatar
    CrackBerry Genius

    Posts
    2,471 Posts
    #19  

    Default

    Isn't there a free PC app called OTA installer??
    You install it on your PC, paste the OTA link and it downloads the JAD and COD files from the link to your PC.
    You then drag the files to your SD card, then in media>explore find the JAD and it will install on the phone from there... Wouldn't this be easier for those of you without a BB plan and can't do an OTA install??

    Posted from my CrackBerry at wapforums.crackberry.com
  20. revoltbplime86's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #20  

    Default

    works great on my bb pearl 4.5 from sprint with my sero plan. THANX!!!
  21. andrewhearne2009's Avatar
    CrackBerry User

    Posts
    11 Posts
    #21  

    Default

    Yahoo 3.0 works on my Bold - thanks just curious though how all icons are the same not like Y! for the email etc, is there any way I can change that. thanks, but good job though
  22. miladinoski's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #22  

    Default

    Thank you; what a life-saver!!
  23. ravi9977's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    PIN
    2820BFFA
    #23  

    Default

    Hi All,

    I have a BB8310 without data plan (using GPRS, Vodatfone India), and able to access yahoo mail & other sites throught vodafone live... but cant access GMAIL....

    I tried to install Opera Mini but it never allowed me... it says
    "The application operette$2dhifi has attemperd to open a connection to a location inside the firewall and outside the fire wall which is not allowed by your IT policy."

    Also when i trie to install GoogleMail_2.0.6_for_BB it takes its own sweet time and returns with an error message that I dont have an working data connection...

    Could any one help me out?
  24. lroge224's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #24  

    Default

    THANK YOU! you helped a fellow Blackberry carrier out!
  25. PaulaJava's Avatar
    CrackBerry User

    Posts
    70 Posts
    #25  

    Wink Thank you!!!

    SpoonJab!!

    You are a life saver. I wiped out my BlackBerry not realizing GMail app had been discontinued. I was freaked out! The native app drives me crazy. Now I have my app back and I hope it continues to work from here on out. Thanks a bunch!
    ~paula
Page 1 of 2 12 LastLast

Posting Permissions