Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. msghmr's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #1  

    Talking Blackberry newbs - "907 Invalid COD" while downloading apps? Here is your answer!

    Okay, well, I'm a Blackberry newb. First off, it's a fantastic device with some really amazing software features. Kudos to RIM for making it very easy to upgrade/downgrade your OS.

    Which is what I've been doing nonstop for two days. Here is my story:

    I received an 8310 from my boss at work. It was used by a previous employee, so I wiped the device and began to enjoy my new gateway to all that is the glorious mobile internet.

    It came with Facebook 1.2. Awesome! I can check out my friends' status pages and reply to them! But no, Facebook 1.2 cannot respond to a friend's status. No worries, Facebook 1.6 is out, so I'll just erase Facebook 1.2, get the new version, and...

    "907 Invalid COD". From sifting through *every Blackberry forum on the internet*, I found that this error is usually accompanied by further information, such as "Connection timed out" or "503 Internal Server Error". Mine, however, only stoically gives the 907 error without any further explanation.

    Common wisdom says that you should get it from the App Store, but the App Store is unavailable in my country. So I surfed to the blackberry mobile site to download it to my computer and then deploy to the blackberry. No luck, for some reason Blackberry does not allow you to do this anymore.

    I try again from the browser on the blackberry. "907 Invalid COD". I can install everything else, even from the browser, so I assume the blackberry site is broken. I download version 1.5. 1.2. 1.5.32 from some helpful folks at the Crackberry forums. It installs fine, but I get no icon. It turns out that this is because 1.5 only supports OS 4.6, and "only" 4.5 is available on the 8310.

    I downgrade to OS 4.2. 4.5 again. Three different versions of 4.5. Back to 4.2, all trying different Facebook versions - no luck. What's worse is that everyone else's issue seems to be resolved by using Facebook 1.6, but no matter which version of the OS I use, I still get "907 Invalid COD" from the download site.

    Blackberry newbs.. do not despair. There is a VERY simple explanation. THERE ARE TWO BROWSERS ON THE BLACKBERRY. While I'm waiting for my full Blackberry service to be activated, I'm using the generic blackberry service from my provider, EDGE and all, but - no service books. I sent the request for service books, but there are none to be had until my service is upgraded.

    It's unusual for an ISP to give Blackberry service in this way. What I've been using all this time is the WAP browser, which *cannot download the Facebook app*. I had no idea that this was going on, since I had no experience to rely on. I suspect that a lot of users were trying to do this in the United States, but since they could get the app from the App Store, some never actually figured this out.

    NEWBS LIKE ME, YOUR BLACKBERRY DEVICE HAS TWO BROWSERS, AND THE PROPER ONE IS ONLY AVAILABLE AFTER YOU RECEIVE SERVICE BOOKS.

    That is my story. I hope it helps someone. I love, LOVE my 8310, and I'm looking forward to the many good times we'll share in the future.
    Last edited by msghmr; 08-03-2009 at 09:29 PM. Reason: Spelling error.
  2. cnc7's Avatar
    CrackBerry User

    Posts
    52 Posts
    Global Posts
    99 Global Posts
    #2  

    Default

    that's a great story.. and kudos for hanging in there and figuring it out instead of calling it a P.O.S BB and tossing it out.
    8100>8330>9530>8330>9530>9630
  3. huckduck's Avatar
    CrackBerry Abuser

    Posts
    184 Posts
    PIN
    a PINprick on a PINhead
    #3  

    Default

    Hrm funny.

    my WAP browser is disabled. never used it. still gotten this error.
  4. msghmr's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #4  

    Default

    Quote Originally Posted by huckduck View Post
    my WAP browser is disabled. never used it. still gotten this error.
    The title of my post may be a bit misleading.. I'm referring specifically to "907 Invalid COD" when it doesn't have any further explanatory text to accompany the error, such as "500 internal server error", etc. If you've had this, I'm sure others wouldn't mind if you posted how you fixed it in this thread! I didn't have much luck finding threads referring specifically to this during my troubleshooting marathon.
    Last edited by msghmr; 08-04-2009 at 02:18 AM.
  5. xliderider's Avatar
    Mr. X

    Posts
    13,013 Posts
    Global Posts
    13,901 Global Posts
    PIN
    T of beer please!
    #5  

    Default

    Wow, that's a seriously long post for a noob!

    Great post though...

    Posted from my CrackBerry at wapforums.crackberry.com
  6. huckduck's Avatar
    CrackBerry Abuser

    Posts
    184 Posts
    PIN
    a PINprick on a PINhead
    #6  

    Default

    Quote Originally Posted by msghmr View Post
    The title of my post may be a bit misleading.. I'm referring specifically to "907 Invalid COD" when it doesn't have any further explanatory text to accompany the error, such as "500 internal server error", etc. If you've had this, I'm sure others wouldn't mind if you posted how you fixed it in this thread! I didn't have much luck finding threads referring specifically to this during my troubleshooting marathon.
    it is a 907 Error.

    Specific Error

    907 Invalid COD
    Unable to extract ZIP
  7. msghmr's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #7  

    Default

    Quote Originally Posted by huckduck View Post
    it is a 907 Error.

    Specific Error

    907 Invalid COD
    Unable to extract ZIP
    Yes, in this case, there is no "Unable to extract ZIP" part of the error. *only* the 907.
  8. bybykinzz's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #8  

    Default

    i wanted to install themes to my blackberry 8520.. we do not have any BIS in Brunei.. .. but evertime i install themes 907 invalid COD appeared.. and how do i fix this again??
  9. Kepeli's Avatar
    CrackBerry Abuser

    Posts
    398 Posts
    #9  

    Default

    I do not use Facebook, but if I ever do, I'll know what to do should I encounter this scenario. Very informative and detailed. Great post.
  10. KasiCatastrophe's Avatar
    CrackBerry Genius of Geniuses

    Posts
    9,296 Posts
    #10  

    Default

    Quote Originally Posted by msghmr View Post
    The title of my post may be a bit misleading.. I'm referring specifically to "907 Invalid COD" when it doesn't have any further explanatory text to accompany the error, such as "500 internal server error", etc. If you've had this, I'm sure others wouldn't mind if you posted how you fixed it in this thread! I didn't have much luck finding threads referring specifically to this during my troubleshooting marathon.
    Very informative post, however that isn't the only thing that causes it.

    I never use the WAP browser and have experienced the "907 Invalid COD" error with no other error messages while trying to download themes in the past. It usually turned out to be an error on the host site where the theme was being downloaded from.

    Posted from my CrackBerry at wapforums.crackberry.com

Posting Permissions