Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Matty1873's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #1  

    Default Blackberry App World error / can't connect

    Hi all had update a few days ago for Blackberry App World after update I have Uncaught exception:
    java.lang.NoClassDefFound
    Error

    I cant connect to App World at all now, any ideas?
  2. jaBBu's Avatar
    CrackBerry User

    Posts
    28 Posts
    Global Posts
    40 Global Posts
    #2  

    Default AppWorld fix - new version

    RIM has fixed this for devices running OS5 (see KB29364 Article - After upgrading to AppWorld 3.1.0.56 error message "Exception: java.lang.NoClassDefFoundError" occurs) by posting a new version (3.1.0.58). I think it has something to do with the new BlackBerry Identity App (RIM's version of single sign on) but I haven't seen any write ups to confirm that. I tested this on my OS5 device and looks good so far.
    jaBBu

    Efficiency is doing things right;
    Effectiveness is doing the right things.
  3. floatboat's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    #3  

    Default

    I updated my 9700 to 3.1.0.58 after going through updating to 3.1.0.56 and finding the Noclassdeffound and then downgraded back to 3.1.0.29 by downloading from http://rroy.com/otaarchive. This 3.1.0.58 workaround is not a solution as it does not recognize my identity and so does not allow me to log in and hence I cannot do anything in the Appworld. Had to downgrade again to 3.1.0.29!!

    RIM has not tested the update thoroughly and so we the users end up wasting time upgrading to find out that it does not work and have to downgrade to earlier version. I hope RIM will wake up and provide more solid updates!
  4. kship's Avatar
    CrackBerry User

    Posts
    25 Posts
    #4  

    Default

    Hi, It did not work on my 9550. RIMs BS is starting to wear thin. I want to get the Bridge for my playbook but cannot get the app due to this problem.
  5. floatboat's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    #5  

    Default

    Kship, you might be able to solve your problem by downgrading to an earlier version. You have to delete first the Appworld you have installed and download an earlier version appropriate to your OS version from the link provided above (rroy dot com). You can read more by googling "appworld noclassdeffound". The supportforums dot blackberry dot com has quite a bit of discussion on this. I tried to put the link here but had difficulty posting it due to my limited posts I have here.

Posting Permissions