1. Alphabase's Avatar
    Hi Folks,

    I put a brand new 128gb Samsung evo+ card in my new Dtek60 when I got the phone at Christmas time.

    On March 17th some of my phones apps would not work and I rebooted my phone. It has since complained that my SD card was not loaded and or corrupted.

    My card was formatted as internal storage as I never intended to take it out and would transfer files wirelessly. I spent a good deal of time trying one program after another to format it and restore it all to no avail.

    I managed to get a replacement over the weekend so I had a fair bit of re installation to do and was thankful for google drive backing up my pics!

    Everything is up and running again but I worry it will happen again...

    Has anyone had a similar issue? Is it harder on a card to be internal storage rather than external?

    Just want to prepare myself if this happens again in 3 months. The card is warrantied for 10 years so 3 months really does not cut it.
    03-20-17 08:52 AM
  2. mad_mdx's Avatar
    Just sounds like a defective card, but I've heard there are cards specifically made for being used as internal storage as well.. Might want to look into that if it fails again
    03-20-17 09:06 AM
  3. yohannyphm's Avatar
    Don't know if it's a coincidence but same thing happened to me on the 16th, I was using the camera at work to send pictures to a colleague. The camera and messenger app got sluggish and picture couldn't be seen. Then I saw the message that the card was corrupted. This never happened to me in my Dtek60 which I got on launch day. Mine was a SandDisk Ultra 64. The only time this happened to me was with The PRIV before the MicrosoftexFat for BlackBerry App was released so don't know if is related. BTW mine was set as portable storage.
    Attached Thumbnails Internal Storage SD card corrupted-37510.jpg  
    03-20-17 09:19 AM
  4. RDZONE99's Avatar
    I've had an issue with my sd card too! I did buy another SanDisk 64gb ultra (white and grey version....not sure if it makes a difference) but not using it at present as I don't want to risk it happening again. The old corrupted card was the standard SanDisk 64 ultra one.

    Prior to the 64gb card...i was using a 32gb SanDisk and had no issues whatsoever.
    03-20-17 03:19 PM
  5. Fordberry's Avatar
    I had the same problem in my Dtek60. It said corrupted card on the phone. It was a 64gb I bought a replacement 128gb and did not have any issues. I tried formatting the bad one on my desktop and kept getting corrupted card. So I tried it one more time in the phone and formatted it in the phone. Now the card is working fine even on my desktop computer.
    03-20-17 05:28 PM
  6. Alphabase's Avatar
    Yes I tried formatting on my phone (would just give me an error and not format the card), and my PC using a variety of tools. None were successful. Hoping the new card works OK. The reviews for the Samsung Evo+ cards are very positive though I did notice some on bestbuy that seemed to indicated people have had the same issue as me previously.
    03-21-17 11:28 AM

Similar Threads

  1. Micro SD corrupted
    By jenaram in forum Ask a Question
    Replies: 11
    Last Post: 03-20-17, 11:18 AM
  2. Swapping SIM card
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 03-20-17, 06:27 AM
  3. Virtual link from internal memory to SD Card
    By flexmaen in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 03-19-17, 02:36 PM
  4. Replies: 4
    Last Post: 03-18-17, 02:00 PM
  5. No more connection from external to our internal BES 5 Express Server
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 03-17-17, 10:16 AM
LINK TO POST COPIED TO CLIPBOARD
";